Thunderbolt Display w/MBA Clamshell Mode

Discussion in 'Mac Accessories' started by rpg51, Oct 27, 2012.

  1. rpg51, Oct 27, 2012
    Last edited: Oct 27, 2012

    rpg51 macrumors 6502

    rpg51

    Joined:
    Jul 4, 2012
    #1
    I tried this question many months ago here on the forum without success so I thought I might give it one more try. I often use an MBA with a Thunderbolt Display in clamshell mode. I have an external wireless USB mouse and keyboard connected to the display via a usb receiver plugged into a usb port on the display. I have an apple bluetooth trackpad and the preferences in the MBA are set so that the trackpad is supposed to wake up the MBA. Bluetooth is turned on.

    I find that when I connect the TBD to the MBA while the MBA is running the display come on just fine but the wireless USB mouse and the wireless USB keyboard attached to the TBD do not function. On the other hand, if I shut down the MBA first, before connecting the TBD, the USB mouse and the USB keyboard work fine.

    Also, I noticed today that if I plug the USB receiver for the keyboard and mouse into the MBA instead of the TBD - the system works fully - I can connect while the MBA is running, the TBD comes on, and the mouse and keyboard work fine.

    Is there a way to get it working properly - connect without rebooting - when the usb receiver is plugged into the TBD usb port rather than the MBA usb port. I would prefer not to have that usb receiver connected full time in my MBA because I travel with it a lot and I'm afraid I will lose it.

    If not, perhaps I should go with a bluetooth keyboard and mouse instead of wireless usb? Any advantages/disadvantages between bluetooth v usb? I do not like the apple wireless keyboard but I do see that logitec makes a solar bluetooth so I suppose I could try that.
     
  2. rpg51 thread starter macrumors 6502

    rpg51

    Joined:
    Jul 4, 2012
    #2
    I'll add this and then hope some folks chime in:

    I have experienced delay when using the apple bluetooth key board. Drove me nuts. No delay with my usb keyboard. So, was this just a unique and unusual thing or is there a difference between usb and bluetooth in this regard?? I came across this somewhere on the internets - any truth to it:

    "Differences between Bluetooth and Wireless USB

    The difference between Bluetooth and Wireless USB is the speed - empirically you will normally forever see speeds less than 1 Mbps with Bluetooth. Wireless USB, on the other hand, is rated for 480 Mbps at 5 meters. Both technologies are slower at further distances, but Wireless USB should always be faster than Bluetooth. A further obvious difference between Bluetooth and Wireless USB is security Bluetooth devices are extremely vulnerable to signal-hijacking whereas the security standard for WUSB is very strict and should result in a much more secure connection this is very important for any request which may require the transfer of sensitive data or information."
     
  3. mawyatt macrumors member

    Joined:
    Aug 27, 2012
    #3
    I had a similar experience with MBPr and TBD using wireless Microsoft keyboard and mouse. Switched to Apple USB keyboard and Apple wireless mouse and USB keyboard wakes up MBPr. I did note something that if the MBPr is connected to TBD and pigtail power connector from TBD TB cable is not engaged the TBD maybe not operate with MBPr closed.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    There's a known issue with at least the USB hub on the TBD...several threads at the Apple forums. I've witnessed it myself. Some have said that if you use a separate Thunderbolt cable from your laptop to the TDB via the port on the TBD, the problem goes away. $49 solution.
     
  5. rpg51 thread starter macrumors 6502

    rpg51

    Joined:
    Jul 4, 2012
    #5
    My issue

    is not a failure to wake up issue I don't think. When I connect the MBA is awake and the computer display appears on the TBD just fine. The problem is that the wireless usb keyboard (logitec) gets zero response and the wireless usb mouse gets zero response. Its interesting because my external apple bluetooth touch pad does get a response and I can move the cursor around - but even with that I cannot execute commands - only way to get out of the situation is to reboot while connected to the TBD. If I boot with the TBD connected to the MBA everything works perfectly.

    I have seen these other reports and they seem close - but not 100% identical - to the problem I am having. I know the problem goes away if I use the usb receiver plugged into the MBA which is a FREE fix, although annoying, and so unless there is another clearly understood fix I'm not inclined to spend money on things.

    Shouldn't this be fixed by Apple? Seems like a defect, no? I am new to Apple and was given to understand they are good about standing behind things like this.
     
  6. helveta macrumors member

    Joined:
    Mar 31, 2012
    #6
    I'm one of those with similar problems and I've been waiting a year for a solution. My MBA is my first apple and overall I'm very happy with it, but this is very frustrating.

    Since I have a TB backup drive I'm not sure substituting a TB cable would work for me.

    You're right, it doesn't seem this problem is getting any attention from apple. Kind a disappointing in a $1,000 TB hub.
     
  7. rpg51 thread starter macrumors 6502

    rpg51

    Joined:
    Jul 4, 2012
    #7
    Have you contacted

    Apple support/warranty about the issue? Did they help you?
     
  8. rpg51 thread starter macrumors 6502

    rpg51

    Joined:
    Jul 4, 2012
    #8
    Mystery Appears to be Solved

    I contacted Apple Support. Very pleasant lady walked through the issue with me on the phone and I demonstrated the problem. She recommended as a first step that I plug the monitor power cord directly into a wall outlet, rather than the UPS I have been using.

    Bingo - problem appears solved. Everything is working perfectly so far.

    I will use this for a day or two and see if it all continues to work. I'm optimistic. She suggested that when you first connect the MBA to the monitor a full consistent power source is important and she suspects that the UPS is not providing the power needed at that start up phase. Whatever. If this solves the issue I am a happy camper.
     

Share This Page