Thunderbolt Display weird behaviour

Discussion in 'Mac Accessories' started by Itzamna, Jun 6, 2015.

  1. Itzamna macrumors regular

    Joined:
    Jun 5, 2011
    #1
    Hello there.

    So, today my TBD decided that he would act like dead. No power, no power on usb, no image, nothing... When i connected it to the wall power supply i heard a weird noise from the top of my table, but can't tell where it was.

    I started to panic and started to look for an authorised Apple thingy (we don't have Apple Stores in here) on the Internet.

    After 5-10 minutes of the first cardiac arrest of my TBD, i decided to plug it again to the wall socket (this time directly and not via the protected socket) and puff... The usb hard drive powered up and the green light shown up. I powered up my MBP and voilá, image on both screens...

    I thought that it would be the protected socked, so, just to test i connected the TBD via the protected socked but he works aswell, as nothing ever happened...


    So, now i'm like "what the hell happened?" And now i'm afraid to connect the power plug on my MBP because i'm afraid that the power supply on my TBD is damaged and might damage de computer.


    What do you guys think happened? Any similar experiences? What should i do?
     
  2. Itzamna, Jun 6, 2015
    Last edited: Jun 6, 2015

    Itzamna thread starter macrumors regular

    Joined:
    Jun 5, 2011
    #2
    Another thing i forgot. Its very hot in here. Last time i checked was about 34'ish ºc (93ºF). When this happened it was at the peak of the day, so it was probably 1-2ºc higher.


    Do you think it can be related?
     

Share This Page