Thunderbolt display won't wake up

Discussion in 'OS X Mavericks (10.9)' started by JP-F, Oct 24, 2013.

  1. JP-F macrumors newbie

    Joined:
    Oct 24, 2013
    #1
    I have a 2011 MacBook Pro and a 27 inches Thunderbolt display that I use as single display when I'm at home.
    Since I upgraded to Maverick, the external monitor doesn't wake up from sleep. I tried opening and closing my MacBook to make it switch displays, but it doesn't work. Of course, trying to type (I have a wireless Apple keyboard) doesn't work either. I have to unplug the monitor and plug it in again in order for it to work again.
    Anyone knows what else I could do ?
    Thanks :)
     
  2. yupp macrumors newbie

    Joined:
    Oct 24, 2013
    #2
    I have exactly the same configuration (MacBook Pro 2011, Thunderboldt 27', Apple wireless keyboard) and exactly the same problem: MBPro does not wake up from sleep.

    After opening the MBPro I have to unplug the Thunderboldt-wire and then to plug in it again - its the only way that it works.

    Seems to be a bug of Mavericks :(
    Hope Apple will respond immediately ...
     
  3. tbaer macrumors member

    Joined:
    Mar 11, 2012
    #3
    Interesting. I have a MBA 2013 connected to a Thunderbolt display and don't have this issue. Actually the wake-up speed has improved over the previous OS version. So maybe this is a device specific issue?
     
  4. cambookpro macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #4
    2011 MacBook Pro here, Thunderbolt display is working fine.

    Have you tried all the usual stuff recommended (restart, SMC & PRAM reset etc?)
     
  5. Caosao macrumors newbie

    Joined:
    Oct 24, 2013
    #5
    I have the same problem with MacBook Pro 2012 (MD102), Thunderbolt 27' and external WD My Book Studio firewire drive. It just doesn't wake up.
    After I unplug the cable and plug again it wakes and I have a message "Eject drive before disconnecting or turning it off". It seems like Maverick tries to eject external drive before go to sleep. I never had that before :(
     
  6. yupp macrumors newbie

    Joined:
    Oct 24, 2013
    #6
  7. JP-F thread starter macrumors newbie

    Joined:
    Oct 24, 2013
    #7
    It worked too :)

    Resetting the SMC solved my problem.
    Thank you so much ! :)
     
  8. Caosao macrumors newbie

    Joined:
    Oct 24, 2013
    #8
    @ cambookpro:
    Thank you! Looks like it solved the problem.
     
  9. yupp macrumors newbie

    Joined:
    Oct 24, 2013
    #9
    I was wrong !

    I had thought that my problem is solved. But I was wrong1 Two or three times wakes TB as planned, then it is over and I have to unplug the TB cable and re-plug.

    In the "Apple Support Communities" I read that this error with TB seems to exist for years (it means, that this is NOT a bug of Mavericks!), but Apple not yet found a solution until today.

    https://discussions.apple.com/thread/3356740?start=90&tstart=0

    Very annoying!
    YUPP
     

Share This Page