Thunderbolt firmware update causing boot failure.

Discussion in 'macOS' started by RolandVet, Jul 1, 2011.

  1. RolandVet macrumors member

    Joined:
    May 8, 2009
    #1
    Hi guys.

    My MBP just asked me to install new firmware for thunderbolt, and I clicked yes. The usual dont interrupt and connect to power source pop-ups appeared so I did both and then left the MBP to do it's job.

    Now when i start-up the MBP all i get is a blank screen. I tried recovering from cd but when holding option key no menu appears to allow me to boot from cd, leading me to believe that the laptop freezes pre-boot selection.

    Anyone else with similar problems?

    Stock Low end 13" with vertex 2 in optibay.

    PS. Not sure if this is the correct place to post this question/statement. Move if i'm incorrect.
     
  2. bjdaly macrumors newbie

    Joined:
    Jul 5, 2011
    Location:
    Australia
    #2
    PRAM reset fixed it for me

    I also put this on the same post at the Apple forum but just in case you miss it there...

    I reset the PRAM and that fixed the problem.

    After the reboot it then applied the firmware update again and it worked fine the second go around.


    Resetting PRAM and NVRAM
    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
    Your computer's PRAM and the NVRAM are reset to the default values. The clock settings may be reset to a default date on some models.


    More info here: http://support.apple.com/kb/HT1379
     
  3. RolandVet thread starter macrumors member

    Joined:
    May 8, 2009
    #3
    Although I answered you in the thread you mentioned long before you posted here, thanks for answering.

    Like I said before, the PRAM reset was without success (although the reset was successful). I had to remove my Vertex-2 drive. Even though this was successful I am dissapointed that I had to remove the drive.

    The SSD was declared dead. Any computer, be it MAC or pc, crashed when the drive connected. I've contacted Steve by email and have been asked to phone. I haven't had the time to do so yet.

    Greetings,

    Sent from my HTC Wildfire.
     

Share This Page