thunderbolt firmware update killed SSD communication?

Discussion in 'MacBook Pro' started by carboncow, May 16, 2013.

  1. carboncow, May 16, 2013
    Last edited: May 16, 2013

    carboncow macrumors member

    Joined:
    Jul 1, 2009
    #1
    Hello,

    I'm a pretty solid IT guy and am having trouble figuring this out...here is my situation.

    2011 2.0 i7 running 500gb SSD in with a 1TB spinner in the DVD slot.

    OSX (mt. lion) just gave me an update for thunderbolt...which I obliged. My Crucial M4 (500gb) wouldn't boot. I was able to see through disk utility that the disk was not recognized now for whatever reason. Slapped in a OCZ Agility3 (256gb) that used to work fine...it's not recognized either. Then I put in an old 5400rpm spinner and it showed right up...I was able to restore.

    Now I'm trying to view both the two SSDs (Crucial and OCZ) via firewire in an external case and they still don't show up. Then I tried a USB case (non powered) and they don't show up but a spinner does.

    1. Is anyone else reporting issues with SSD not working or getting bricked?
    2. Does anyone have an idea here or a better way to troubleshoot if I'm off base?

    No I don't know what firmware these drives have...since they worked I didn't bother as I've had bad experience with SSD firmware upgrades...and now this firmware upgrade for thunderbolt!
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    I've seen reports here of TB ports being fried or devices connecting to the USB or TB port being damaged if the were connected during the FW update. I don't recall seeing anything internal.

    I would guess that trying the drives in a different machine or a PC and a different enclosure or adapter wold help verify if the drives were bricked. I can say its pretty easy to brick most OZC drives, a little harder for crucial.

    Its not good if your machine has now become a SSD brick maker. What would a genius say?
     
  3. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #3
    Had a similar issue on my mac mini after update. Support had me do an SMC and PRAM reset and that seemed to make it work again. You may need to "option" start after that and select the SSD. Then check your startup disk setting in preferences.

    SMC:
    Note: Portable computers that have a battery you should not remove on your own include MacBook Pro (Early 2009) and later, all models of MacBook Air, and MacBook (Late 2009).
    Shut down the computer.
    Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
    On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
    Release all the keys and the power button at the same time.
    Press the power button to turn on the computer.
    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.

    http://support.apple.com/kb/HT3964

    PRAM:
    • Shut down the computer.
    • Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step
    • Turn on the computer.
    • Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    • Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    • Release the keys.
     
  4. carboncow thread starter macrumors member

    Joined:
    Jul 1, 2009
    #4
    Here's the update...and I'm sure I'll be back next week with more in case anyone finds a need in this post...

    I took off work early to run down to the Apple store and caught a pretty sharp guy there. They had no data on the latest thunderbolt firmware causing issues but he did acknowledge the issue a year ago with certain MBP15 motherboards getting bricked from the thunderbolt firmware update.

    I had to leave my MBP15 at work while I restored to a painfully slow 5400 drive and took the two SDD to the genius bar since I had no 2.5 enclosures. they determined both SSDs were bricked after trying on thunderbolt, USB2 and FW800 enclosures...Disk Utility simply doesn't seem them.

    I"m screwed on the older OCZ but stand a chance with the newer Crucial and their great 3 year warranty. I found on their website a procedure to unbrick a SSD, see this link: http://forum.crucial.com/t5/Solid-State-Drives-SSD-Knowledge/Why-did-my-SSD-quot-disappear-quot-from-my-system/ta-p/65215 but I won't have a chance to test this until the middle of next week...if it doesn't work it's RMA time and I'll get a faster spinner for the MBP15 and wait until anyone else has any posted issues...maybe a firmware fix will be needed (like last year) or maybe the Crucial will come back to life. The chance of both bricking is pretty minimal so I'm really scratching my head on this one.

    Genius bar sent me on my way with a simple "good luck" not that I think they are obligated to do much...only if I bought their overpriced SSD.

    My friend says he may have a old used 128 laying around to see if we can brick three of them!
     

Share This Page