thunderbolt firmware update not updating

Discussion in 'MacBook Pro' started by cinek, Jul 10, 2011.

  1. cinek, Jul 10, 2011
    Last edited: Jul 10, 2011

    cinek macrumors 6502

    Joined:
    Mar 12, 2011
    #1
    checked for updates today, showed a java update and a thunderbolt update, I tried installing both, but the thunderbolt update keeps showing up. Tried installing it again, but it's still showing :S

    edit: nvm - unplugged my external monitor and it updated
     
  2. skiltrip macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #2
    I found your topic searching because I have the same problem. Yet, I'm trying to update it without a monitor plugged in. hmm.
     
  3. jimbo1mcm macrumors 68000

    Joined:
    Mar 21, 2010
    #3
    same issue

    won't update the Thunderbolt stuff
     
  4. cinek thread starter macrumors 6502

    Joined:
    Mar 12, 2011
    #4
    try disconnecting all usb devices etc & restart it before updating
     
  5. FenixDigital macrumors newbie

    Joined:
    Aug 13, 2011
    Location:
    Palma de Mallorca, Spain
    #5
    That is a common issue at our shop.

    Simple question:

    Are you updating connected to a power source?

    If you are not, this is normal. MAC OS X is not going to update ANYTHING critical as (any) firmware if it is not connected to an external power source. Battery is not considered by MAC OS X as a reliable power supply, therefore it will prevent ANY failure during such a critical process (that must not be interrupted in any way) by not allowing it at all.

    Therefore in that case you will experience the following:

    - Update will download.
    - Update will uncompress and install will start.
    - After installing software it will reboot.
    - A gray screen will appear, then the apple will show in darker gray.
    - Then a status bar will show up, eventually by about 1 second (that is the time the EFI delays to know if it's magsafe is connected or not).
    - Then the process will be interrupted by itself as a safety precaution in the moment it notices it is not connected.

    So next time do it normally, but TAKE CARE you DO CONNECT your magsafe to your computer before you start the process, and it hopefully will go smooth as... (think in something really smooth ;) he he)

    Hope this helps someone.

    Cheers from Mallorca (Spain)
     
  6. stu531 macrumors newbie

    Joined:
    Dec 18, 2008
    #6
    Hi,

    I've tried this a number of times with the Magsafe power plugged in. It still doesn't update, after a number of times. If I go back to Software Update, it still asks me to install the Thunderbolt Firmware, as if it hadn't updated.

    So for me, it's not working even with power on.

    Cheers,
    Stu
     
  7. Adamantoise macrumors 6502a

    Joined:
    Aug 1, 2011
    #7
    I had the same problem.

    Connecting to a power outlet solved it for me.
     
  8. jauhari macrumors regular

    jauhari

    Joined:
    Mar 20, 2007

Share This Page