Thunderbolt issues?

Discussion in 'MacBook Pro' started by liberalart, Jul 8, 2014.

  1. liberalart macrumors newbie

    Joined:
    Apr 28, 2009
    #1
    My MBP has recently been behaving badly. It started as crashes while asleep with no obvious crash message (i.e. your mac shut down improperly) doesn't require a 10 sec shutdown, a quick press of the power button reboots.

    I can't see any obvious crashes in the log (but I'm no expert).

    Tried resetting the PRAM, SMC, energy savings settings.

    Eventually mac started freezing and an external drive (1 of 2 Seagate go flex thunderbolts) didn't show up anymore. Rebooting with that drive in would result in a frozen system within a minute or two of restarting.

    RMA'd that drive, but soon after the other drive starting doing the same. RMA'd that one and before I could ship it back, the replacement for the first started doing the same.

    I've tried running them straight to the second thunderbolt port instead of via thunderbolt display. Checked for new firmware, etc.

    Is there a way to diagnose or test the thunderbolt bus? I'm hesitant to wipe and reinstall because my Time Machine backup is on the external drive that's now shifty.

    Pertinent Details:
    RMBP mid 2012
    10.9.4
    two segate go flex thunderbolt drives (B dupes A via Superduper when both are working)
    Thunderbolt Display

    Any help much appreciated.
     
  2. elmoensio macrumors newbie

    Joined:
    Jul 19, 2014
    #2
    I am tagging on this thread as I have similar issues on my Early 2011 Macbook Pro. My new OWC Elite Mercury Pro external RAID drive just keeps freezing my computer when connected via Thunderbolt. Tried two different cables. Via USB it works fine.

    Tried SMC and PRAM reset and it did not help.

    I am running out of ideas what could be the reason.
     

Share This Page