TI Powerbook combo drive won't accept disks

Discussion in 'Macintosh Computers' started by pcuthbert, Jan 9, 2004.

  1. pcuthbert macrumors newbie

    Jan 9, 2004
    My TI powerbook combo drive has suddenly decided to lock out all disks, CDs and DVDs (after burning a CD). There's something physically preventing me from putting a disk in the drive. Tried restarting, ejecting, etc., but to no avail. Running 10.3.

    Any ideas anyone? HELP...
  2. MattG macrumors 68040


    May 27, 2003
    Asheville, NC
    You can't even insert one while it's booting up? Sounds like you might have a bad drive on your hands. Don't think there's anything you can do personally to fix it. You might have to <gulp> send it in to Apple.

    Anyone else?
  3. lepwisk macrumors newbie

    Jan 13, 2004
    This happened to me, on my GHz TiBook with DVD-R. Ressetting the PMU worked for me. It seemed to restore power to my seemingly dead drive.

    Cheers, Lewis
  4. pcuthbert thread starter macrumors newbie

    Jan 9, 2004
    Good news. I fixed it.

    After sending the PowerBook into Apple I was told that the drive was stuffed and needed replacing; expensive and time consuming since there are currently no Combo drives in stock.

    This seemed unnecessary to me. The problem appeared to be a simple mechanical failure and I couldn't help but think that they probably didn't even try to fix the original drive. So I had a go myself, and managed to fix the drive without any problems.

    This is what I did (follow these instructions at your own risk!):

    1 - Removed the Combo drive. (see http://www.macresq.com/store/detail.php?prodID=P009644 for instructions).
    2 - Undid a bunch of obvious screws to pull the drive apart, being careful to remember what goes where. This was pretty straight forward, except that I didn't have the correct (Torx) screwdriver, so I had to use a regular flat-blade screwdriver instead.
    3 - Near the back of the drive, away from the pastic pulley that was preventing the disk from being inserted, was a relatively large sheet of metal that is obviously supposed to slide freely against another, except in my case it was stuck. I applied a small amount of WD-40 lubriant, being careful not to get it anywhere unwanted, and this fixed the problem.
    4 - Reassembled everything and booted to test.

    The first time I tried to boot I got a fatal "system error" (something about a corrupt stack) just before the login window displayed. This caused some panic on my behalf, but I rebooted again and everything has been fine since. And now the drive works as good as new.

    Now I just have to tell Apple that I don't need that Combo drive after all.


Share This Page