Tiger applications?!

Discussion in 'Mac Apps and Mac App Store' started by renok, Mar 2, 2009.

  1. renok macrumors newbie

    Joined:
    Jan 15, 2009
    #1
    Can i download the apps listed on http://www.apple.com/downloads/ with a powerbook that has tiger? If not, where can i find the old official Apple app downloads for tiger?
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    If the app is compatible with Tiger, then yes. You'll have to look at the requirements for each app to find that out.
     
  3. alexbates macrumors 65816

    alexbates

    Joined:
    Nov 24, 2008
    Location:
    Georgia, USA
    #3
    Yeah, you can download anything off the downloads page as long as it meets your system requirements. For every application on the Apple downloads page, there is a system requirements section as shown below.
     

    Attached Files:

  4. renok thread starter macrumors newbie

    Joined:
    Jan 15, 2009
    #4
    ok...the thing is....im buying a used powerbook G4 tommorow which has tiger on it now. It will be my first Mac...do lots of apps accept tiger?
     
  5. GreenyOSX macrumors newbie

    Joined:
    Mar 2, 2009
    #5
    Pretty much, I've had Tiger for a very long time and my little kitty can do somewhat everything. :D
    You'll need to live with the fact that Apple has dropped support for it though, and that really new applications might not run on it anymore.
    But I presonally find that Tiger is much handier to work with as a first mac.
     
  6. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #6
    Adium 1.4 (not out yet) and TextMate 2 (also not out yet) are examples of apps that require Leopard or newer.
     

Share This Page