Tiger Server software install fails on G-4

Discussion in 'macOS' started by MacAuntie, Jul 14, 2005.

  1. MacAuntie macrumors newbie

    Jun 6, 2005
    Tried to install Tiger Server software from 2 shipped cd's (no dvd drive on the machine) on a Test machine in my office to see how it works and get familiar with it. (System only running on this machine, no data or other apps, not a main workstation.)
    What a wretched idea!
    It's a G-4 Digital Audio running 10.3.6 Server software with a small RAID attached; had 57 Gb free on 60gb hd-- has been running fine.

    Initial Upgrade install failed--froze after a few minutes on Disk one.
    On Restart- got Kernel Panic text message
    Restarted and ran Repair Permissions in Disk Utility as well as Repair Disk--seemed to be fine.
    Rebooted and proceeded to do a Replace/Erase install-- (Upgrade not an option anymore.)
    "Installation cannot be completed" error after one minute.
    Clicked "Restart" option from cd install disk and noticed the system software showing up on computer was now 10.4 (even tho installation failed.)
    On Reboot, (with 10.4 install cd still in cd bay) got blank gray screen
    Powered down and detached RAID--no other peripherals attached.
    On Reboot, holding down "C" key (with 10.4 install cd still in cd bay) got folder with ? mark
    Tried to eject cd from keyboard and by pushing tray button, Will not budge
    On Reboot, with 10.4 install cd still in cd bay, got blank gray screen
    On Reboot, started up from Firmware and tried Command line "eject cd" - would not work - froze.
    Tried starting up with Shift key--Nada--gray blank screen
    Could not eject cd--inserted paper clip. Manually ejected and inserted 10.3 Install disk.
    Reboots to folder with ? mark holding down "C" key
    I noticed that the cd light never goes green--blinks amber. Can;t hear any spinning.
    Still can't eject cd. Paper clip not working now.

    Hmmmm....I wonder if the optical drive has failed.
    If it IS the cd drive--will attaching an external cd drive work? Never tried to reboot from an external drive.

    Any thoughts?
  2. cardiac dave macrumors regular

    cardiac dave

    Jun 23, 2005
    I know that you can install to an external disk and boot from it, but what about copying the CD images to an external HD and booting from that?
  3. MacAuntie thread starter macrumors newbie

    Jun 6, 2005
    Tiger Server software install fails...

    Just attempted that.

    Copied DVD to Firewire drive via Disk Utility Restore modes and connected FW hd to G-4.
    (Finally, manually ejected Tiger install cd from drive bay )
    Rebooted--drive did not mount--still blinking ? mark.
    Tried booting with "Option" key held down.
    Got Blue screen with two arrow buttons on it: a Curved arrow and a right-pointing straight arrow.
    Tried clicking right-pointing straight arrow. Nada
    Tried clicking curved arrow. Clock ticked, but nothing happened.
  4. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Did you do the G4 Apple Firmware Update before starting your install?

    There are different firmware updates depending on your model G4
    " If you are upgrading from Mac OS 9 to Mac OS X 10.2 or Mac OS X 10.3 on a computer that otherwise meets the system requirements, make sure that the computer's firmware has been updated. This list shows which firmware updates are available and appropriate for each computer. "

  5. Blackheart macrumors 6502a


    Mar 13, 2004
    If there's a boot-able volume attached, that volume will appear between those two arrows. The curved arrow is a "refresh" arrow while the right-pointing arrow is a "go ahead with my selection" arrow. If you haven't selected anything in between the two arrows, then nothing should happen.

    1) Insert the Tiger install cd.
    2) Restart the computer.
    3) Boot holding the "option" key.
    4) Choose the install cd to boot from (and click the right arrow).
    5) I think you'll come to a language select screen, click the language you want, then the arrow.
    6) When prompted with the installer, go to the menubar (tools? utilities?) and open Disk Utility.
    7) Click on the internal volume you are attempting to install on.
    8) Erase this volume.
    9) Check the S.M.A.R.T. status at the bottom of the window, what does it say?

    Note: A blinking question mark means that a system folder could not be found. Also, if you booted holding option, and nothing appeared in between the 2 arrows, you definitely don't have a system folder available to boot from.
  6. MacAuntie thread starter macrumors newbie

    Jun 6, 2005
    Tiger software install fails...

    Tried holding down Option key and booting with Install cd in drive...NO drive icon appears in between the arrows.

    Canada Ram:
    I didn't think a firmware updater was needed--I was upgrading FROM 10.3.6 to 10.4 on a Digital Audio G-4
    If I DO need a firmware update--how would I do it with this unresponsive system?
  7. Blackheart macrumors 6502a


    Mar 13, 2004
    Before continuing, I think it may be wise to physically disconnect the RAID volume from the computer if you have any data that must remain safe on it.

    On startup, hold option-command-O-F. (that's an O, not a zero). This will boot the computer into open firmware.

    At the prompt, type the following with a return after each line:


    After the final command, the machine will reboot. Hold option-command-P-R and wait for 3 "dings". The first will be the initial start-up, the 2nd will be a PRAM flush, the the 3rd is a flush for good measure. The computer will again attempt to restart only this time, hold the option key and attempt to boot off the CD again.
  8. MacAuntie thread starter macrumors newbie

    Jun 6, 2005
    Tiger Server...


    Disconnected RAID long ago :)

    Reset nvram and PRAM in Open firmware.
    Still get blue screen, two arrows, nothing in between
    (Install cd in tray, holding Option key)

    I don't think it can read anything in the cd drive.
  9. Blackheart macrumors 6502a


    Mar 13, 2004
    ... interesting...

    Might you have another Mac lying around with which to boot the G4 into target disk mode (holding T on startup while connected via firewire to this other computer) and install 10.4 Server from?
  10. MacAuntie thread starter macrumors newbie

    Jun 6, 2005
    Tiger Server software...

    Blackheart: (thanks for sticking with this)
    Target mode---good idea --- hmmmmm --- gave it a try:

    The G-4 mounted on my G-5 as a FW target disk.
    I attached another FW hd drive on which I had copied Tiger to (using Restore tools in Disk Utility to make it fully bootable.)
    I thought I could just copy all these folders (System, Utilities) etc. over to the 30 Gb drive from the G-4 that mounted because when I inserted the Tiger Install dvd in the G-5, it asks to restart THAT computer...

    I was surprised when I rebooted the G-4 and it STILL comes up with a ? folder.

    Booting holding the Option key STILL won't show any volumes from which to choose.
  11. Blackheart macrumors 6502a


    Mar 13, 2004
    With target disk mode, the G4 drive is mounted on the G5. From here, you will launch the 10.4 Server install (just use the DVD in this case) and instead of installing on a G5 drive, you will install on the G4 drive that is connected via firewire.

    Normally the installer will have you restart your G5 and will boot from the installation DVD. You can do this to install on the G4, it will work just fine. However, if you want to leave the G5 booted in its own OS while installing on the G4 drive, you need to find the installation mpkg on the DVD that you can launch w/o restarting the computer (note to anyone else reading this - you can only do this when you aren't installing over the system you are currently booted into. MacAuntie is installing on a separate volume so it works). I'm not at work so I can't pull out the 10.4 Server DVD and tell you what the mpkg you need to open is but as an example, the package for 10.4 Client is located @ /System/Installation/Packages/OSInstall.mpkg on the DVD.
  12. MacAuntie thread starter macrumors newbie

    Jun 6, 2005
    Tiger Install Now Sizzling


    The install over Target FW mode worked!
    I am now configuring.

    (Will test cd drive later to see if its defective...I also removed the ATTO PCI card--another techie thought it might be problem--will add it back in later to see if it was a culprit.)

  13. Blackheart macrumors 6502a


    Mar 13, 2004
    No problem! I've already sent the invoice! ;)
  14. Lebowski macrumors 6502

    Oct 10, 2005
    Phoenix, AZ
    I am having a similar issue upgrading from 10.2 to tiger on a digital audio G4. I cleaned everything off of it, repaired permissions, ran software update and installed tiger. Everything goes fine till the very end, I get a message saying error installing tiger, please try again. Well after about 4 tries, i gave up for the night. Its a family pack disc, giving 5 licenses, and only installed one so far on my powerbook 17.

    I assume trying the firewire target install described above might work? I am gonna try to install off the powerbook to the digital audio via this method and see what i can find.....

    funny thing is, im killing myself trying to figure all this out, and im giving the digital audio to my sis!!! It will be her first mac, and she is excited to get it, i just hope i can get tiger up on its feet!
  15. Blackheart macrumors 6502a


    Mar 13, 2004
    Along with attempting an install via target disk mode, I'd perform a hardware test on the G4 with it's original install disk (or hardware test CD/DVD if it was separate). To use the hardware test: insert the disk, restart the computer, hold the option key while the computer starts up. You *should be prompted with squares of volumes to boot from (with a "refresh" button to the left and an button point right, on the right). Choose the hardware test volume, and press the right-pointing arrow if necessary. Follow on-screen instructions for the rest... it should be fairly straight forward.

    * - that may be a pre-os x hardware test cd, I can't attest to the similarities (if there are any) between the older style and the one I describe.

Share This Page