tiger spotlight search text in .ppt or .pptx?

Discussion in 'macOS' started by tkjazzer, Mar 30, 2008.

  1. tkjazzer macrumors 6502

    Joined:
    Nov 30, 2004
    #1
    I noticed that spotlight in tiger does not search text within .ppt or .pptx files (from microsoft office 08)

    Is there a way to make it search that text within the file?

    does google desktop do a better job of searching within .pptx and .ppt files?

    does leopard spotlight do it?

    Thank you!!

    google desktop doesn't want to index my external HDs but spotlight will!

    It appears google desktop does index text inside .ppt but i dislike the way it is organized compared to spotlight...
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    I only have problems with the .pptx (and .docx) files. If I save them as .ppt or .doc spotlight is able to index them properly.

    I read something in the support forum for Office 2008 that it is a bug in the mdimport plugin and should be corrected soon...
     
  3. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #3
    are you on leopard or tiger?

    I only get the .ppt files to show up if the search word in spotlight is in the filename.

    I can't seem to get it to search the words written in each slide.

    I'm on tiger with office 08
     
  4. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #4
    I am also using tiger with office 2008 and the search in the .ppt files works fine.
     
  5. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #5
    can i get spotlight to index my fat32 external hd? i can't seem to add it to the privacy not to index...

    I was thinking if i told spotlight to NOT index things, and then I told it to index them again, then it would re-index everything and maybe work.

    My .ppt and .pptx files are on my main mac HD though.
     
  6. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #6
    Your idea is good but it doesn't work with FAT32 partitions.

    You may have to use the mdutil command in the terminal.

    To disable the indexing of a disk:

    sudo mdutil -i off /Volumes/your_hard_drive_name_1

    To remove the index of a specific disk:

    sudo mdutil -E /Volumes/your_hard_drive_name_1

    To restart the indexing of a specific disk:

    sudo mdutil -i on /Volumes/your_hard_drive_name_1

    I hope it helps.
     
  7. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #7
    ok, so if I tell Tiger to not index a folder...

    do I have to do anything like Shut Down, log out, etc to make it work?

    Then if I want to tell it to index a folder again, do I have to shut down, log out, etc.

    Do I have to open files in that folder?

    What triggers spotlight to start indexing things it hasn't indexed yet?

    I have a huge folder on my desktop that it hasn't touched.

    Do I have to make my computer go idle?

    Thank you!



    what is the name of the main hard drive disk? I haven't changed the name of it. what would i enter for that?

    Thank you!

    ok, so i think some of my problems is that spotlight is busy?

    I did the privacy, add subtract thing, but now my main folder with pdfs and ppt is not being indexed at all. I can't even get the folder name up.

    so i checked the macrumors guides.

    they said you can't add a file to privacy to be not indexed if mdimport is busy.

    It is present on the activity monitor. Does that mean it is busy?

    do I just have to weight until it is not busy?

    How do you tell if something is busy?

    Maybe someone could clarify the wiki

    thank you!

    http://guides.macrumors.com/Repairing_a_faulty_Spotlight_index
     
  8. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #8
    If you really need to index a folder (Spotlight should do that automatically, if you delete the index, although it may take quite a while) you may use this command:

    sudo mdimport -f /Path_to_the_folder


    But really after executing the command I gave you above try restarting the mac and the leave it. You should see that it is busy indexing by looking at the blue icon on the right or by chacking the CPU usage of the process in activity monitor.
     
  9. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #9
    so when I first put the main HD to privacy mode - do not index and then back again,

    I got the little flashing plus arrow and the blue status bar.

    It initially said it would take 2 hours, but then about 10 minutes later it said 27 minutes.

    My main .ppt and .pdf folder was not indexed.

    However, when I check the Activity Monitor I see the mdimporter pop up for a few seconds and then dissappear, when I check what files it is accessing, it is slowly going through the files in that folder.

    So why did spotlight not index this when the blue status bar was going. Why is it going at turtle speed now?

    My plan is just to weight a few days and see if it ever indexes completely.

    I still don't think I will have luck with the .ptt files having their internal text be indexed - at this early stage of the game, it appears that only the title is indexed, not the text inside.

    it appears from a google search that spotlight should indeed search the contents of the powerpoint files...

    i wonder why it doesn't...
    http://wilshipley.com/blog/2005/05/on-payroll-of-microsoft-much.html
     
  10. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #10
    Try giving it more time, it may help.

    As i said before the search in ppt files works on my macbook with tiger. I just have problem with the new format from office 2008.

    The following command will give you the lis of the spotlight plugins you have installed on your system:

    mdimport -L

    Does the office plugin show up? Should be something like this:

    "/Library/Spotlight/Microsoft Office.mdimporter"
     
  11. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #11
    yes, that importer does show up.

    However, none of the powerpoint files that are currently showing up in spotlight is indexed inside; just the filename is indexed and searchable.

    i'm getting frustrated that the .ppt files are not being indexed. I've tried clearing my caches with app mainmenu - nothing

    I'll try the terminal stuff next I guess.

    Why are ONLY the ppt files not importing properly in the index??

    if I delete the mdimporter would that be useful? would os Tiger then replace it? Is there a newer version of mdimporter that I am not aware of?

    OK i keep catching mdimporter doing something in the activity monitor. Can anyone tell me what it is doing? I appears to be working with various .ppt files in the main .ppt folder. Could this be something?

    Code:
    /
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mdimport
    /System/Library/CoreServices/CharacterSets/CFUnicodeData-L.mapping
    /System/Library/CoreServices/CharacterSets/CFCharacterSetBitmaps.bitmap
    /System/Library/CoreServices/CharacterSets/CFUniCharPropertyDatabase.data
    /Library/Spotlight/Microsoft Office.mdimporter/Contents/MacOS/Microsoft Office
    /Library/Caches/com.apple.IntlDataCache.le.sbdl.501
    /Library/Caches/com.apple.LaunchServices-014501.csstore
    /usr/share/icu/icudt32l.dat
    /usr/lib/dyld
    /usr/lib/libSystem.B.dylib
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreText.framework/Versions/A/CoreText
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
    /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    /usr/lib/libicucore.A.dylib
    /usr/lib/libobjc.A.dylib
    /usr/lib/libstdc++.6.0.4.dylib
    /usr/lib/libgcc_s.1.dylib
    /usr/lib/libauto.dylib
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
    /System/Library/Frameworks/Security.framework/Versions/A/Security
    /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJP2.dylib
    /usr/lib/libxml2.2.dylib
    /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
    /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
    /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
    /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
    /dev/null
    /dev/null
    count=0, state=0x2
    /tmp/com.apple.csseed.61
    apple.shm.notification_center
    /Library/Spotlight
    /System/Library/Spotlight
    /Users/****USERNAME****/Desktop/***FOLDER NAME***/***SUB FOLDER NAME****/.DS_Store
    count=0, state=0x2
    /Users/****USERNAME****/Desktop/***FOLDER NAME***/***SUB FOLDER NAME****/XXXXX(filename).ppt
    /Users/****USERNAME****/Desktop/***FOLDER NAME***/***SUB FOLDER NAME****/XXXXX(filename).ppt.ppt
    

    both files above (XXXXX) were the same files.

    Can this issue be solved by the Mac Geniuses at the Mac Stores? Do they charge?

    I think my computer has the 3 year apple care but I don't really know what that entitles me to.

    Thank you

    so what do the mac geniuses actually do?

    is there an article about their job description?


    http://www.officeformac.com/ProductForums?13@885.P4S2aX0etbF@.ee974b8/11
    "1) check the list of mdimporter actually recognized by the system
    2) use the command on a file to see what has been indexed for it
    3) force-reindex a file or folder to see if it corrects the problem for
    the file or folder
    4) force-reindex everything if 3 worked. It will run for some time...."


    Which terminal command do I need to use to make objective 1, check the list of mdimporter actually are recognized by the system????

    Thank you!
     
  12. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #12
    It's the command I gave you above:

    mdimport -L

    The mdimporter that are recognized by the sstem are those on the list you get after that command.

    You should get a list, something like thi:

    "/Library/Spotlight/Microsoft Office.mdimporter",
    "/System/Library/Spotlight/Font.mdimporter",
    "/Library/Spotlight/Microsoft Entourage.mdimporter",
    "/Library/Spotlight/SourceCode.mdimporter",
    "/System/Library/Spotlight/Bookmarks.mdimporter",
    "/System/Library/Spotlight/QuickTime.mdimporter",
    "/System/Library/Spotlight/vCard.mdimporter",
    "/Library/Spotlight/AppleWorks.mdimporter",
    "/System/Library/Spotlight/PDF.mdimporter",
    "/Library/Spotlight/Numbers.mdimporter",
    It may be different (I get a longer list than this one) but the first item is probably the one you are looking for.

    Try looking in this folder (the one in your HD):

    /Library/Spotlight/

    Do you see the "Microsoft Office.mdimporter" plugin? try getting informations about it and check the version. I have 12.0.2.
     
  13. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #13
    hello,

    I did the terminal command "mdimport -L":

    I have :

    2008-04-12 14:18:10.685 mdimport[16403] Paths: id(501) (
    "/System/Library/Spotlight/Image.mdimporter",
    "/System/Library/Spotlight/Audio.mdimporter",
    "/System/Library/Spotlight/Font.mdimporter",
    "/System/Library/Spotlight/PS.mdimporter",
    "/Library/Spotlight/Microsoft Entourage.mdimporter",
    "/Library/Spotlight/Microsoft Office.mdimporter",
    "/System/Library/Spotlight/iPhoto.mdimporter",
    "/System/Library/Spotlight/RichText.mdimporter",
    "/Applications/OmniOutliner.app/Contents/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter",
    "/System/Library/Spotlight/QuickTime.mdimporter",
    "/Library/Spotlight/GBSpotlightImporter.mdimporter",
    "/Applications/Microsoft Office 2008/Microsoft Entourage.app/Contents/Library/Spotlight/Microsoft Entourage.mdimporter",
    "/System/Library/Spotlight/Mail.mdimporter",
    "/Applications/Transmit.app/Contents/Library/Spotlight/Transmit Favorite Importer.mdimporter",
    "/Library/Spotlight/Numbers.mdimporter",
    "/Library/Spotlight/AppleWorks.mdimporter",
    "/Library/Spotlight/Keynote.mdimporter",
    "/System/Library/Spotlight/QuartzComposer.mdimporter",
    "/System/Library/Spotlight/vCard.mdimporter",
    "/System/Library/Spotlight/Application.mdimporter",
    "/Library/Spotlight/iWeb.mdimporter",
    "/Library/Spotlight/Pages.mdimporter",
    "/System/Library/Spotlight/PDF.mdimporter",
    "/System/Library/Spotlight/Bookmarks.mdimporter",
    "/System/Library/Spotlight/Chat.mdimporter",
    "/System/Library/Spotlight/SystemPrefs.mdimporter",
    "/System/Library/Spotlight/iCal.mdimporter"


    I also went to the folder and found the version number.

    The icon does NOT have the office "O" symbol on it. Does yours?

    My version of Microsoft Office.mdimporter is 12.0.2 (070927)
     
  14. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #14
    What is the command for number 2)
    "use the command on a file to see what has been indexed for it"

    Thank you so much for your help, I really appreciate everything that you are doing to help me. I can't wait until my spotlight actually works the way it is supposed to.
     
  15. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #15

    If I remember correctly the command is the following:

    mdimport -d2 path_to_filename

    (with path_to_filename the path to your ppt file)

    This should give you the list of the metadata associated with that file. You can compare that data with another file type that is indexed correctly by spotlight. You can also try changing the to -d1 or -d3 or .d4 to get more or less informations (the d flag in the command is to get debugging informations).
     

Share This Page