Time Capsule block Port 22 and 80?? Help

Discussion in 'Mac Accessories' started by mobbbx, Oct 10, 2009.

  1. mobbbx macrumors newbie

    Joined:
    Oct 10, 2009
    #1
    Hi,

    I'm trying to setup a web server and SSH on my ubuntu server using time capsule as a router. My current network setup is:

    internet --> Linksys BECMU10 (cable modem) --> time capsule --> ubuntu server

    However, i am unable to access the webpage and SSH from WAN.

    What i've tried so far:

    • port forward 80 and 22 on time capsule via airport utility

    • reserved a DHCP ip for ubuntu server (10.0.1.201) via airport utility

    • enabled NAT Port Mapping Protocol

    • port scan using network utility on ubuntu server (10.0.1.201) shows port 22, 80 and 3306 open

    • port scan on Linksys BECMU10 (192.168.100.1) shows port 21 and 80 open

    • port scan on time capsule (10.0.1.1) does not show port 22 and 80 open even though i've setup port forward for 22 and 80

    • if i setup share time capsule disk over internet (public TCP 5678 and private TCP 548) i have no problems accessing time capsule

    • i also tried setting up default host at the ubuntu server (10.0.1.201) but no still no access!

    It seems that apple configured time capsule to block port 80, 22 ?????

    Any help is appreciated!!!
     

    Attached Files:

  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #2
    where are you trying to connect from? sometimes trying from within the network can get a bit weird.

    i would try the same tests here, but my network utility keeps crashing :(

    it might be your ISP is blocking 80, i've had that happen in the past.
    try moving your server to 81 then you can forward 81 to 80 so inside your network would stay the same but you would have to add a ":81" to the end of the base address so ".com:81/_____" or "##.##.##.##:81" if you're using an IP address to access from outside.

    I've also had problems connecting to 22 from within a corporate environment (trying to SSH home from work)


    has your server taken the new address?
    try ifconfig on it to see what your address is. if it's not correct "sudo /etc/init.d/networking restart"
     

Share This Page