Time Capsule Internal disk needs repair

Discussion in 'Mac Accessories' started by ncboston, Sep 21, 2012.

  1. ncboston macrumors newbie

    Joined:
    Sep 6, 2012
    #1
    So my whole world just got turned upside down...

    Background story... I had a Macbook pro for work that i used to keep everything on but had to give it back and I have my own macbook which has a substantially smaller HD which could not hold all the data. So i bought a timecapsule to hold me over until i could purhchase a new imac (whenever they come out)

    Present time - I woke up this morning and my time capsule was blinking orange...i unplugged it and re-plugged it still blinking orange...i ran the airport utility and it told me that my internal disk needed repair (i crap myself).

    Literally my whole life is on this stupid timecapsule!...I know if i send it to apple they will give me a new one but the data will be lost forever...and I know if I try to professionally to recover the data I void the warranty and pay a fortune to maybe get the data back...

    I am willing to try anything in between...my buddy at work just told me to put it in the freezer for a day or two and it might give me a couple of hours to get everything off before it dies again...so that is all I have right now.

    Does anyone have any other ideas or know of a cheap data recovery method/company? Any help would be awesome!

    Thanks
     
  2. Mike in Kansas macrumors 6502a

    Mike in Kansas

    Joined:
    Sep 2, 2008
    Location:
    Metro Kansas City
    #2
    Just to be safe, try connecting to it with an ethernet cable just to take the wi-fi part of the system out of the mix.

    I'd also try a hard reset of the TC - hold the little button in on the back for 5 seconds. If you only hold it in for one second it will do a soft reset.

    According to Apple, neither reset will wipe the data - you need to do that from the Airport utility.

    Before doing anything, take a read through this just to know what you are getting into:

    http://support.apple.com/kb/HT3728

    The extreme approach would be to try and take the HDD out of it and try and get to it via an enclosure or multi-purpose drive cable. Warranty is gone at this point, but if your data is worth more than that, it may be worth it. The thought being is that the drive may be OK, but the controller could be messed up.
     
  3. ncboston thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #3
    Mike - The wifi part of it still works fine. So I will jump to your second tip and give that a try. Thanks for the advice!
     
  4. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #4
    Does the TimeCapsule not mount in Finder? Mine stays connected under SHARED
    Then you just copy your backup to an external.

    Always have a backup of a backup if you have very important info stored.
     

    Attached Files:

  5. MCAsan macrumors 601

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #5
    So there is data on the Time Capsule from previous backups of a former large internal HD...that is not on the current internal HD?
     
  6. aquin001 macrumors newbie

    Joined:
    Sep 22, 2012
    #6
    Time Capsule

    I just joined hiere because of s similar issue. Incidentally noted that backups weren't happening (3 separate machines) but no warning was given. Green light on. Time machine says "backup delayed" and doesn't list any old backups at all.
    When I try to set it up again, there is no disk recognized on the menu to select, and I can't get passed that. When I go deeper, it sasy internal disk needs repair...but I don't se that message consistently. Plus, I am a Mac moron so anyone needs to talk to me like I am 2.
    I reset it to FActory setting from the utility from the Airport Utility- and same problem. Router works fine.
    Help!
     
  7. ncboston thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #7
    yeah exactly...and I haven't had a chance to download it from the time capsule before it had the error. I am going to try the freezer trick...hopefully that works.
     
  8. ncboston thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #8
    Ok...so after calling several differn't places and the recovery looking to cost a fortune, i thought I would first give it a shot on my own. So I opened the time capsule out and hooked the HD up to an EHD enclosure.

    Luckly it read the disk and I got really exited untill the two partins that showed up apconfig and apswap were totaly empty.

    I opened up disk utility and saw a third partition that was the size of my hd (2TB)...however it was grayed out and it showed that it was unmounted.

    (Check out the image below.)

    I tried to verify it and then repair it but got the message below. Does anyone have anymore ideas??

    Verifying volume “disk1s3”
    Checking Journaled HFS Plus volume.
    Invalid node structure
    The volume could not be verified completely.
    Error: This disk needs to be repaired. Click Repair Disk.

    Verify and Repair volume “disk1s3”
    Checking Journaled HFS Plus volume.
    Invalid node structure
    The volume could not be verified completely.
    Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.
     

    Attached Files:

  9. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #9
    Hi ncboston,

    The best thing I can suggest is for you to try using Disk Warrior to try and salvage the hard drive. If that works, pull everything off of there as fast as you can and replace that HDD immediately.

    I'm not sure if Apple would still honor the warranty on it since it was opened (you might still want to try), but if not then you can purchase another HDD and replace the stock one. Just format it HFS+ on your Mac and erase it using AirPort Utility once it's installed to make sure those other two partitions you saw get created.

    Lastly, make sure you back up your data to multiple locations. One place isn't enough. And if it's possible, try having an offsite or cloud backup so that in case of a fire or theft, your data is still safe.

    Best of luck!
     

Share This Page