Time capsule issue?

Discussion in 'Apple TV and Home Theater' started by elkem, Mar 23, 2010.

  1. elkem macrumors newbie

    Mar 23, 2010
    Ok, I don't know anything about computers...

    Yesterday, I was downloading something from the iTunes store, and in during the download the time capsule lost network. So I rebooted the time capsule, thinking that it would fix the problem... Sure enough I was wrong!

    When the time capsule went online again, iTunes said that it can't save the file and closed out. Since then I haven't been able to open iTunes at all... it just bounces up and down for like a minute and then it crashes.... What the hell did I do??? What will fix the problem?

    Since then the Time Capsule runs very screwy, can't connect to it, goes off-line completely... I am not even sure where to start with this whole garbage... The Time Capsule holds all of my iTunes content and is connected to three apple TV's, of course without the time capsule... nothing works.

    Please help if you have any input...

    Oh this happened on my iMac that runs of OS X version 10.6.2

    Thanks so much guys.
  2. MacBoobsPro macrumors 603


    Jan 10, 2006
    What is happening exactly?

    There is a history of many TCs dying after about 18 months due to power unit problems. Is power getting to the unit? Or is it a network issue?

    Personally I would get everything off your TC ASAP unless you have it backed up. I used my TC as an iTunes server but when I saw all the reports of them failing I quickly removed all data from the drive. I now use it as a VERY expensive router.
  3. elkem thread starter macrumors newbie

    Mar 23, 2010
    well, I did see all the issues and I am going to get a new iMac with much more storage... Until then the time capsule will have to work...
    It seems like the time capsule just connects when ever it feels like it and even when I think it is connected, I am not really sure that it is. I just don't understand what really happened.. I am sure the iTunes and the Time Capsule issues are related... since it all happened at the same time. I tried to fix the aliases but it still won't work... Quite frankly, right now; nothing works.

    The power is getting to the TC, and it is approximately 2 years old, i think...
  4. pjj macrumors newbie

    Apr 3, 2009
    Time Capsule died

    Bought my 1TB Time Capsule after my first purchase of an Apple product, a MBP 2.5GHz in first half of 2008.

    Time Capsule just stopped working a few days ago.
    Disk will not spin up
    No WiFi

    Tried removing power source, let sit for a day. Reconnect, no go.
    TC is connected to a surge protector.

    (Is the TC repairable?)

    Now ethernet connected directly MBP for internet use.
    We have FIOS in my area.
  5. MacBoobsPro macrumors 603


    Jan 10, 2006
    Could it be that you just overwhelmed the network? Having 3 AppleTVs would mean while your were downloading from iTunes it was also trying to sync to the 3 ATVs at the same time?

    Can you not try resetting the network settings on your TC. This shouldn't affect the content on it just the network settings but be careful as there are a few things that will wipe your drive. Its been a while since I played with the Settings on my TC so I cant remember what the options are.
  6. elkem thread starter macrumors newbie

    Mar 23, 2010
    well its been running with the same setup for years now. I don't know how to reset the TC... I am not sure if I am doing something wrong. I also don't understand why my iTunes acts strange at the same time. :(
  7. elkem thread starter macrumors newbie

    Mar 23, 2010
    now, how is this related to my post?
  8. toolbox macrumors 68020


    Oct 6, 2007
    Australia (WA)
    My TC died also, i opened it up to find some nice bulging capacitors on the power supply

Share This Page