Time Capsule & Realplayer 11

Discussion in 'Mac Accessories' started by mjeshurun, Feb 29, 2008.

  1. mjeshurun macrumors newbie

    Joined:
    Feb 29, 2008
    #1
    I own both Airport Extreme and Airport Express.

    when using either of these wireless routers my computer cant stream video or audio on Realplayer 11 or 10. the problem happens when Realplayer is operating 1. however, when streaming through the web browser video and audio works fine.

    i have checked changing and opening all ports in the router, but nothing works. i even tried changing Realplayer preferences to use the web browser port 8080, but the problem still occurs.
    from what i understand this is a hardware compatibility issue.

    can anyone confirm if the this problem occurs also when using Time Capsule?
     
  2. ktswami macrumors newbie

    Joined:
    Apr 6, 2008
    #2
    RealPlayer Socket Error with Time Capsule

    Yes, I can confirm. I just setup Time Capsule, and I'm not able to stream Real video or audio...I keep getting socket errors. I thought it was because of the Mac Real 11 beta, but same error with Real 10. Ugh.

    Real plugins work within Opera v9.5 beta and Safari v3.1.

    17" 2.33mhz MBP, v10.5.2.
     
  3. mjeshurun thread starter macrumors newbie

    Joined:
    Feb 29, 2008
    #3
    solution to realplayer problem

    Dear fellow Apple Hardware users,

    I'm glad to announce that as it currently seems, I have found a simple yet effective solution to the problem, most of us encountered when trying to run realplayer streams out of the browser window.

    for the moment, i have only checked this method on the Airport Express G Wireless router. in the next few days i'll try this solution on the Airport Extreme Wireless router as well.

    the procedure is very quick, easy and simple. (at least it was for me).
    in Airport Utility, change
    Radio Mode: from 802.11 b/g compatible to --> 802.11 g only.

    update the router, and.... thats it.
    according to all tests i've preformed to this moment, all communication with realplayer works fast and fine.

    hopes this help you all,

    do let me know if this solution also solves the problem for Airport Extreme Gigabit and Time Capsule.

    Cheers,

    Michael.
     
  4. ktswami macrumors newbie

    Joined:
    Apr 6, 2008
    #4
    TC still breaking Real Player 11

    Thanks for the info, Michael.

    No go, for me with Time Capsule. I tried all radio modes, including N-only (both 2.4 & 5 mhz), and Real still doesn't play and getting invalid socket error.

    TC team, we need a fix, please! :confused:
     
  5. oweneck macrumors newbie

    Joined:
    Jun 25, 2008
    #5
  6. lmeier1962 macrumors newbie

    Joined:
    Sep 4, 2008
    #6
    TC and RealPlayer

    Http transport only didn't work for me. After sniffing the network both inside and outside the firewall, I determined the following course of action that worked for me.

    1. In the Real Player Preferences, goto manually configure RTSP, check the box and,

    Under RTSP column, highlight

    UDP
    TCP
    HTTP

    2. Under the UDP ports section, check the box and use specific UDP ports 6970-32000.

    Do not play with port mapping on the AirPort Configuration. You don't need to.

    ALL my streaming now works, hardwired or wireless. One thing for sure - I'm think I'm going back to and sticking with Cisco products for my routing needs, from here on out.

    Feel free to contact me for action or info. lmeier1962@gmail.com
     
  7. bankerkys macrumors newbie

    bankerkys

    Joined:
    Nov 14, 2008
    #7
    Re:

    Has anyone solved this problem? I have had nothing but h_ll since setting up Time Capsule. I finally got the Internet working today, and now I get the socket error in real player. And when I try to run http only, I cannot view the video lectures at my school. I have no idea what the deal is or why Time Capsule is creating the real player problem.
     
  8. bankerkys macrumors newbie

    bankerkys

    Joined:
    Nov 14, 2008
    #8
    Problem Solved

    For everyone who has been suffering with this problem, I think I have found the solution for the RealPlayer issue:
    - Open Airport Utility
    - Go to the Advanced tab
    - Go to Port Mapping, then select "+" for add
    - Go to Service and select "Quicktime Streaming Server", then select Continue, then select Update

    Now go to RealPlayer and the problem is solved (or at least it's solved for me). I spent hours working on this after failing to find anything online. Good luck. :D
     

Share This Page