time capsule suddenly turns off when is plugged with LAN, itdoes not turn off when it

Discussion in 'Mac Accessories' started by sacho1979, Aug 29, 2014.

  1. sacho1979 macrumors newbie

    Joined:
    Aug 29, 2014
    #1
    This is really bother me, i got TC 3gb was working good for 6 months, when suddenlt started to turns off, so i have to turn it off and turn it on again, and few hours later turns off.

    now i unplugged the LAN wire or ethernet port and the TC yellow light is blinking and is more than a week and it is still on, i though it was woriking good again so i plugged the LAN again and TC turns off again in few hours.



    Any suggestions
     
  2. MCAsan macrumors 601

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #2
    take it to the Apple store....especially if it is still under warranty or AppleCare.
     
  3. sacho1979 thread starter macrumors newbie

    Joined:
    Aug 29, 2014
    #3
    It does not have guarantee anymore other suggestions??
     
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    Apple has a 1 year limited warranty on AirPort base stations. It is also covered under iPhone, iPad, Apple TV, and Mac AppleCare Agreements.
     
  5. sacho1979 thread starter macrumors newbie

    Joined:
    Aug 29, 2014
    #5
    I got it January 2013, since December I haven't use it, well I will use it like paperweight
    Thanks
     
  6. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #6
    Do you have AppleCare on any other devices? What firmware is it running?
     
  7. MCAsan macrumors 601

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #7
    Take it to the Apple Store and get a repair estimate. Then make a business decision.
     

Share This Page