Time Capsule - USB Drive on PC?

Discussion in 'Mac Accessories' started by rittchard, Mar 4, 2008.

  1. rittchard macrumors 6502

    Joined:
    Aug 12, 2007
    #1
    I've got my TC doing just about everything I wanted thus far, with a couple nagging things.

    I've attached a USB hard drive, and it shows up on my Mac, but not on the PC (running Vista). If I run Airport utility on the PC, I can see that the drive is recognized and attached, but I can't figure out how to actually access the drive. I tried "add network drive" but couldn't get it to show up. I don't actually remember how I got the TC itself to show up, I do recall it didn't work at first.

    On a side note, I had a rather hit or miss time with the TC setup. Some stuff was incredibly easy/quick. Other misc steps seemed off but fine when I rebooted. Interestingly you're never told (that I saw anyway) to restart/reboot the computer, but it seemed like it was required (for me anyway) in a number of instances.

    Another odd quirk is the TC doesn't seem to show up on my iPhone, haven't quite figured that out yet.
     
  2. rittchard thread starter macrumors 6502

    Joined:
    Aug 12, 2007
    #2
    Anyone else have a similar configuration? That is, USB external drive on the TC, trying to access it through a PC (running Vista)?

    Both my Macs see the USB drive with no problem, but so far still no dice on the PC no matter what I try.
     
  3. davricho macrumors newbie

    Joined:
    Nov 13, 2006
    Location:
    Australia
    #3
    I have the same problem, USB drive with 2 partitions (1 HFS, 1 FAT) connected to time capsule which is connected to Vista Pc via ethernet.
     
  4. rittchard thread starter macrumors 6502

    Joined:
    Aug 12, 2007
    #4
    Update: I got this working last night. Kind of. I say kind of because it seems a little flaky so I'm leery to say it's "solved."

    I can't even tell you exactly how I got it to show up. I was playing with the Airport utility on the PC, and suddenly I seemed to see it. The only thing different I did was enter the WORKGROUP name in the Disks/File Sharing tab. But I don't think that was what did it.

    What I *think* is the key is to simply Add Network Drive/Folder - they tricky part being what is the exact correct name to use. In my case, it turned out it was a folder structure, with the TC's name truncated for some odd reason. It was something like:

    //rittchards-T/WD Passport/

    where the full name of the TC was "rittchard's Time Capsule" and my new drive's name was automatically given as WD Passport (that's the product name). I have no idea how or why it decided to truncate the title and change spaces to dashes.

    I also had some trouble transferring files from the TC to the USB drive. At this point, I'm thinking I may not stick with this configuration unless I hear it has been specifically addressed. Presently it seems not worth the effort.
     

Share This Page