Time Capsule Wi-Fi Connectivity issues

Discussion in 'Mac Basics and Help' started by tpter1, Jan 12, 2010.

  1. tpter1 macrumors newbie

    Joined:
    Jan 12, 2010
    #1
    Hi. We use a Time Capsule 1 TB as our Wi-Fi connection. We bought it when they were first out. Normally, there are about 3 wireless devices using it: iPod touch, MacBook, MacBook pro. Recently, we upgraded to a wireless printer. So now there are 4 devices competing for connectivity. When we connected the printer, I lost connectivity to my touch. I tried everything, even restoring it (including calling tech support, who had it up and running for a short burst). I'll either get no IP address or an invalid IP address. All was fine before we connected the printer. It seems that no more than 3 devices can connect at once. Is this a limitation of that generation of time capsule? Will an Airport Express remedy the problem?
     
  2. tpter1 thread starter macrumors newbie

    Joined:
    Jan 12, 2010
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    The Time Capsule should support up to 49 devices (50 if you count the Time Capsule drive) simultaneously. Have you tried getting another device to join the network, another computer perhaps? Have you tried power cycling the Time Capsule, your modem it's connected to? How about resetting and reconfiguring the Time Capsule from scratch?
     
  4. Habitus macrumors 6502a

    Habitus

    Joined:
    Feb 26, 2009
    Location:
    Where ever my life takes me...
    #4
    Have you tried hard-wiriring the printer? I know this defeats the purpose, but it may solve the issue. Also, have you tried with another wireless device (i.e., connecting more than 3 devices)?

    Habitus :apple:
     

Share This Page