Time Capsule Wi Fi on iPhone?

Discussion in 'Mac Accessories' started by pad07, Jan 9, 2010.

  1. pad07 macrumors regular

    Joined:
    Jul 29, 2007
    #1
    Hi guys

    Odd problem here. Got a Time Capsule which works perfectly on my Mac providing wireless internet; works perfectly with my printer plugged into it for wireless printing; but does NOT work with my iPhone for wireless internet.

    iPhone sees the network and asks for the password. It shows as connected to Wi-Fi with full signal.

    Yet the internet does not work. It simply times out. Any ideas why this is and how I can fix this? I have already done a Network Settings reset on the phone.
     
  2. pad07 thread starter macrumors regular

    Joined:
    Jul 29, 2007
  3. ftaok macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #3
    Do you have MAC address filtering turned on? I remember back when I had my Netgear router, if I forgot to add a new MAC address onto the router, it would look like that device (in your case, the iPhone) was on the network, but I wouldn't be able to surf with that device.

    I don't know why, but it always took me 5 minutes to figure out what was going on ... even though it was the same thing every time.
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    A bit more information on your network setup would help. What type of network are you running? Is it mixed b/g/n? Or is it simply n only? If it's the latter, and it's broadcasting at 2.4 GHz, your iPhone will be able to see the network but will not be able to connect. Are you able to get any other g devices to connect?
     
  5. simastu macrumors newbie

    Joined:
    Jan 10, 2011
    #5
    SAme problem

    I have the same problem. 1 year and 3 months old time capsule and brand new iPhone4. All running latest firmware version.
    I tried many different configurations of the time capsule (i think i tried all the possibilities).
    The iPhone won't connect to it (asks for password and then says: unable to join network) or it will connect but the connection would drop randomly.
    Every other devices (mac and pc) work fine.
    I've heard from many different forums that many people are experiencing this issue and no one found a solution as of now.
    Anybody has any ideas?
     
  6. ssdeg7 macrumors 6502a

    ssdeg7

    Joined:
    Jul 15, 2010
    #6
    I'm having a similar issue, my new time capsule's network connects to my iMac, MBP and iPad but does not connect with any iPhone or iPod. I called Apple and they couldn't solve my problem, I tried restarting everything in the Time Capsule, even reseting my iPhone and nothing worked.
     
  7. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    It's kind of funny when the whole point of buying overpriced Apple stuff is that "everything just works" together in the Apple ecosystem.
     
  8. hitekalex macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #8
    Check if the iPhone gets IP address assigned via DHCP. Click on the arrow next to connected WiFi network, and look under DHCP tab. I have seen weird behavior on iDevices where they connect to WiFi network, but unable to get DHCP address.

    The workaround would be to not use DHCP, and configure static IP address / DNS server manually.. under Static tab.
     
  9. DaveyJake macrumors newbie

    Joined:
    Aug 10, 2012
    Location:
    Orange County, CA
    #9
    It's been awhile since the last response but...

    I was having a similar problem and then I read here that changing the channel connection (e.g. 802.11 a/b/g/n) setting found in Wireless > Wireless Options may be the remedy to this issue. Older iPhones (2G/3G/3GS) are incompatible with 802.11n. They'll see the network and connect to it only to drop when the receiving channel "n" signals.
     
  10. CWallace macrumors 603

    CWallace

    Joined:
    Aug 17, 2007
    Location:
    Seattle, WA
    #10
    The iPhone 4(S) will connect to a 2.4GHz 802.11n network. It cannot connect to a 5GHz 802.11n network. My iPhone does not see my 5GHz 802.11n network (I am using the latest Time Capsule with 802.11n at both 2.4GHz and 5GHz).
     
  11. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #11
    Check the date of the first post. It wasn't an iPhone 4 or 4S. Probably a 3GS, which didn't have 802.11n
     

Share This Page