Time Capsule wireless router not working.

Discussion in 'Mac Accessories' started by xraydude, Feb 13, 2009.

  1. xraydude macrumors newbie

    Joined:
    Feb 13, 2009
    #1
    I've had my time capsule for several months now, and the wireless has worked fine during that time. A few days ago the power went out in my neighborhood (turned off by electric company for maintenance work), and since then I cant get my network to function correctly. Specifically, my macbook pro, wife's macbook, and my mini can't connect wirelessly to the network if i have any security on the network. If i disable all security they work fine. It also works fine if i connect directly with the ethernet cable. Occasionally i can connect with the WEP or WPA security on, but the computer will randomly lose all signal and not be able to connect again. This doesn't happen if I have the security settings disabled. I have reset everything several times, reconfigured the network from scratch, etc. I don't know if the TC is damaged in some way or how to check it. Help?
     
  2. FarSeide macrumors 6502a

    FarSeide

    Joined:
    Feb 17, 2008
    Location:
    Earth Lane
    #2
    couple of days ago i had the same issue with my TC. I simply unplugged the power to the TC and reconnect few minutes later and everything was working fine.

    If the TC is only few months old, call Apple Care and see how they can help you.

    have you tried to unplug the power ?
     

Share This Page