Time for an JB upgrade. What are my options???

Discussion in 'Jailbreaks and iOS Hacks' started by jayeskreezy, Feb 10, 2011.

  1. jayeskreezy macrumors 65816

    Joined:
    Mar 3, 2005
    #1
    I have an iphone 3GS running IOS version 4.0 with baseband 5.11.07. I haven't jailbroken since the release of 4.0 last year using Pwnage tool. What do I need to do in order to upgrade?

    Is there a software upgrade (4.1 or 4.2) that allows me to keep my current phone unlocked?

    I read the dev team blog, but I've been out of the loop so long that I'm confused. :confused: Thanks in advance!
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Check Cydia to see if you have your phone SHSH in Cydia. If it doesn't, then you are out of luck to upgrade your IOS while preserving old baseband.
     
  3. jayeskreezy thread starter macrumors 65816

    Joined:
    Mar 3, 2005
    #3
    It's on file with Cydia. So what are my options? Can I use Green Poison if i've used Pwnage tool previously? Also, will I still be able to unlock if I use Green Poison?
     
  4. lucifiel macrumors 6502a

    lucifiel

    Joined:
    Nov 7, 2009
    Location:
    In your basement
    #4
    You will need to use the pwnage tool to cook up your own custom 4.1 IPSW (one that will NOT upgrade the baseband) and install it through iTunes whilst using Tiny Umbrella.
     
  5. spetznatz macrumors regular

    spetznatz

    Joined:
    Jan 5, 2006
    #5
    Whilst using TU? Care to elaborate?

    I've cooked up a 4.1 .ipsw with Pwnage Tool 4.1.2, but when (option-click) restoring in DFU mode in iTunes, I get a message about 'Erasing, Restoring and Verifying with Apple'. Is that normal?
     
  6. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #6
    Using TU
    -after opening TU, pick the correct device and click save my SHSH
    -once your blobs are on your computer, you can determine which iOS you can install
    - start the TU server. It may be necessary to check settings to ensure that TU is pointing toward the cydia server
    -<option>+restore and pick the appropriate ipsw
    -if the bb doesn't update, you'll get an error message
    -if necessary, kick out of recovery with TU
     
  7. spetznatz macrumors regular

    spetznatz

    Joined:
    Jan 5, 2006
    #7
    Phew, so much to take on board.. This is what I don't get... all the vids I've watched on YT make no mention of using TU when updating from 4.0 --> 4.1 using Pwnage Tool.

    Also, 'if the baseband doesn't update, you'll get an error message...'

    I thought the point of using Pwnage Tool was that the baseband doesn't update, preserving your unlock.

    Sorry if I'm being a bit thick.. this is all new to me...
     
  8. jayeskreezy thread starter macrumors 65816

    Joined:
    Mar 3, 2005
  9. spetznatz macrumors regular

    spetznatz

    Joined:
    Jan 5, 2006
    #9
    I did, thanks.

    I spent all that time & effort learning about jailbreaking (my iPhone was sold to me jailbroken) because I need to use PAYG SIMs in the UK & Germany. Then I gradually find out that under European law, carriers are obliged to unlock your iPhone after the initial contract expires. So that's what I did. No jailbreaking necessary (I'm not interested in jailbreaking per se, it's the unlock that's important to me, and I was told that you have to JB before unlocking). So I'm a happy camper.:)
     

Share This Page