time in OSX after windows

Discussion in 'Windows, Linux & Others on the Mac' started by Craiger, Oct 8, 2007.

  1. Craiger macrumors 6502a

    Craiger

    Joined:
    Jul 11, 2007
    #1
    Every time I reboot from xp into mac osx, my time changes, and it does not correct until I open up date and time. I don't have to do anything in "date and time" I just have to open it up. Any suggestions? I would hate to have to do this every time I boot back to OSX.
     
  2. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
    #2
    The short solution for people who know how to edit the registry:
    A DWORD key called HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal needs to have the value of "1"

    The step-by-step solution is as follows:

    1. Boot Windows

    2. Click Start --> Run and type regedit. Click OK

    3. The Windows Registry Editor should pop up. Navigate within the explorer to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

    4. Click on the TimeZoneInformation "folder" from the navigation pane if you haven't already done so.

    5. This assumes the correct key doesn't exist. If it does, you will just change the existing key's value: Right click on the white space within the folder (If you don't have a right mouse button, you may need to download a program called applemouse to emulate the "control-click" of the apple 1-button mouse). Select new --> DWORD Value. Title the key "RealTimeIsUniversal" (No quotes). Set the value to "1" (No quotes again). Hexidecimal should be fine.

    6. Either reboot and set the clock in MacOS or set the clock in Windows. You should now be able to reboot into either OS and have a correct clock.

     
  3. Craiger thread starter macrumors 6502a

    Craiger

    Joined:
    Jul 11, 2007
  4. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #4
    I've found that Windows' Internet Time works just fine as well.
     
  5. Craiger thread starter macrumors 6502a

    Craiger

    Joined:
    Jul 11, 2007
    #5
    This worked! Thank you.
    if you don't mind, could you quickly explain what the problem was, in layman terms. I am just curious.

    Thanks again!
     
  6. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #6
    Off the top of my head:

    Windows stores system time as local time - for me that means it adds one hour to the system time for BST (GMT+1) every time I reboot.

    Mac OS X as well as every other OS in the world stores system time as GMT. So when you load OS X, it checks system time, which Windows will have changed to be whatever your local time is. It will assume that that is GMT, then add or subtract your local time zone...

    The registry changes you've just made are something carried over from Windows NT - presumably someone in Microsoft wanted to make Windows standardised, but it was never fully implemented.
     
  7. Craiger thread starter macrumors 6502a

    Craiger

    Joined:
    Jul 11, 2007
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    I did this awhile ago and it seems to work until recently.

    Anyone else has problems with it? Running 10.4.11, but I installed the Leopard bootcamp drivers.
     
  9. jeamland macrumors newbie

    Joined:
    Nov 15, 2006
    #9
    so this works fine, everything's AOK

    but apple installs something that periodically sets the time and makes it "smart" to re-adjust it.

    in other words, the apple software ignores the realtimeisuniversal setting in the registry.

    anyone know how to disable the apple time checking thingy?

    (in other words, it works and everything seems fine, and then when apple's periodic "fixit" program runs, it breaks again.)
     
  10. jeamland macrumors newbie

    Joined:
    Nov 15, 2006
    #10
    SOLUTION:

    After setting the "RealTimeIsUniversal" setting as above, go into services (manage computer -> services or control panel -> administrative tools -> services) and select the "Apple Time Service" and set it to DISABLED. this will prevent apple from being "smart" :)
     
  11. coohou macrumors newbie

    Joined:
    Feb 18, 2008
    #11
    Thanks a lot for the info. It was very helpful.
     
  12. ryannazaretian macrumors 6502a

    ryannazaretian

    Joined:
    Sep 21, 2008
    Location:
    Mississippi
    #12
    We should sticky this, because Microsoft isn't going to fix this.
     
  13. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #13
    Thanks jeamland and everyone else that contributed.
    This was very helpful :)
     
  14. najeebanwer macrumors newbie

    Joined:
    Dec 13, 2011
    #14
    Bug in Windows 7 Wake Timers when RTC = UTC

    The registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal when set to the DWORD value = 1 indicates that the RTC is set to UTC.

    This works properly, in that Windows 7 correctly sets the time according to the Time Zone information provided, except that apparently the WAKE TIMERS (powercfg -waketimers) are not configured properly and will wake up the computer at the wrong time or not at all (if, for example, the wake time has already passed in UTC terms).
     

Share This Page