Time is messed up when I boot back to OSX from Windows.

Discussion in 'Windows, Linux & Others on the Mac' started by Slowstick, Dec 17, 2008.

  1. Slowstick macrumors 6502

    Joined:
    Dec 16, 2008
    #1
    Hello!!

    Why is it when I restart my MacBook into OSX 10.5.6 from Windows my date and time are messed up? I am on internet time and it takes awhile for it to correct itself. It always manages to mess up my Time Machine backup.
     
  2. TheVendor macrumors member

    Joined:
    Aug 11, 2008
    Location:
    Canada
    #2
    Same problem here, and I don't think anyone has figured out a solution (please correct me if I'm wrong :)).
    You could try stopping Windows from syncing its clock with a server, which I think will solve your issue in OS X (but then your clock would always be wrong when in Windows...)
     
  3. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #3
    You can set both OS X and Windows to pull time from an online server, although I had this problem with Vista and I was able to fix it by ONLY setting OS X to sync with apple.com under System Preferences.

    It takes a few seconds after a reboot into OS X to get the time right, but it DOES work.
     
  4. Slowstick thread starter macrumors 6502

    Joined:
    Dec 16, 2008
    #4
    Your right! It does work! Thanks for the help!!!
     
  5. superwoman macrumors regular

    Joined:
    Apr 25, 2005
    Location:
    Monterey,CA
    #5
    Actually, there's a registry key in Windows that you can set:

    HKEY_LOCAL_MACHINE/SYSTEMCurrentControlSetControl/TimeZoneInformation/RealTimeIsUniversal

    I believe it's a DWORD, and you need to set the value to 1.

    If the key is not there, you can create it.
     
  6. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
  7. Slowstick thread starter macrumors 6502

    Joined:
    Dec 16, 2008
    #7
    Well.....after I did what Tomorrow did, it worked for about three days and then Windows tried to connect to the internet time server even after i disabled it.

    So I did some research and a posting at paulstamatiou.com by richard said to do this (While in Windows):

    Open notepad and copy these four lines into notepad:

    @echo off
    net time /setsntp:tick.usno.navy.mil
    net stop w32time
    net start w32time

    Save it has a .bat file and then copy that file into your Startup folder.

    Restart into Mac OS X and the time is fixed!!!!!!!
     

Share This Page