Time Machine: 1 Infinite Loop

mcdj

macrumors G3
Original poster
Jul 10, 2007
8,859
3,722
NYC
Google says others have had similar issues, but none of the fixes seem to work for me.

I have Time Machine set to back up my 2017 MBP 15 running High Sierra, to a 2TB WD bus powered portable drive connected to an Airport Extreme (tower, non-drive model). I have around 700GB to back up.

The router is in bridge mode, with another AE tower which is a Time Capsule model. (I don't back up the 15" MBP I'm using to this TC because a complete backup won't fit)

The WD drive has been formatted properly (a few times now). Disk utility says it's healthy.

Time Machine recognizes it no problem.

Everything starts off fine. Time Machine progress shows the expected "x" of 700GB backed up.

The problem starts when I close the lid. I keep it plugged in. Power nap is enabled. Actually one time, the same thing happened even when I left the lid open overnight and set sleep to never.

If I go to bed, the next morning, I get either "preparing backup", "waiting to complete first backup", or sometimes, "backing up X of Y", where Y is not 700GB, it's less, but the number keeps getting larger.

Currently it says backing up 6.2GB of 7.13GB. 10 min ago it said something like 115mb of 200mb.

The blue status bar is at maybe 95%. but it's been that way for 3 days.

I went through all of this very same thing last week. Wiped the WD drive and started over Sunday. It's now Weds. and there hasn't been a complete backup.

I'm out of ideas.

Anyone?
 

hammerfangs

macrumors newbie
Jul 31, 2010
6
0
I am re-posting this from a different thread. Hope it helps...

Do you have WD Drive Utilities or WD Security installed on your Mac? I am not sure if this is relevant to your case specifically but both of these applications do not play nice with High Sierra; yet.

In my case, Time Machine on my WD My Cloud would not complete the backup which includes a USB 3 connected WD My Book. It would start but would not complete as the backup size grew continuously. WD website shows that these applications are not compatible with High Sierra. Sure enough, upon uninstalling the application, Time Machine completed the backup and I have had no problems since.

I am not sure if this will help, but try uninstalling the WD applications (if you have them installed, that is), at least until WD updates their applications for High Sierra.

If the above doesn't help, check the System Log. It might give you hints as to what is messing with Time Machine.
 

mcdj

macrumors G3
Original poster
Jul 10, 2007
8,859
3,722
NYC
Thanks. Unfortunately that isn’t the issue. Not running any WD software.
 

jds2005

macrumors newbie
Dec 4, 2017
1
0
Hi,

I've been having the same problems on High Sierra. Maximum size keeps increasing, and I don't have any WD software installed. Have you found a fix? I also can't find any other articles online, only this one.
 

rodpmartins

macrumors newbie
Apr 26, 2018
1
0
Hi,

I've been having the same problems on High Sierra. Maximum size keeps increasing, and I don't have any WD software installed. Have you found a fix? I also can't find any other articles online, only this one.
same problem here. I've just tried everything....
 

iOSGoober

macrumors newbie
Sep 17, 2013
17
2
Similar issue here. Estimated backup size just keeps increasing until the backup fails due to lack of space. I spent some time on chat with Apple support and they had no solution for me as yet. They suggested booting into safe mode. Problem remained.

I had this issue about a year ago also, and reformatted my external backup drive. That solved the problem until today. Not much point using Time Machine if I have to completely purge it periodically.