Time Machine and Aperture

Discussion in 'Digital Photography' started by carlgo, Jul 25, 2011.

  1. carlgo macrumors 68000

    Joined:
    Dec 29, 2006
    #1
    Do they actually work together? I screwed up an Aperture book and want to go back to a time prior to that, but TM keeps coming up with the new, screwed-up version. Unless I am doing something wrong...I have never used TM to restore before. I also back up the vault to a second external HD, but don't need to restore the whole program and all the photos and so that would seem to be overkill. Am running SL, not Lion still.
     
  2. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #2
    When you enter time machine there is a scale on the right hand side of the screen with some dates on it. Click on one of them that will roll you back to that date. You'd want to select a time that is before your aperture file got corrupted. Once you roll time machine back you can go into it's finder window and select the folders and or files that you want to restore. Then click restore.

    Good Luck.
     
  3. carlgo thread starter macrumors 68000

    Joined:
    Dec 29, 2006
    #3
    Well, that is what I have been doing. Still the same messed up book is showing. Evidently you can't select "book" so I have been selecting the Ap3 icon, the one of the lens, going back to well before I made the silly experiment that messed up my book, and then after the copying there are two lens icons showing in the TM applications folder. Both look the same when opened. I must be missing a step. Also, when I go back in time, I am presented with, again, the Ap3 lens icon and then I can also get an Ap3 folder. I have tried selecting both, at different times, with the same results.
     
  4. carlgo thread starter macrumors 68000

    Joined:
    Dec 29, 2006
    #4
    Jeez, the usual endless answers to which canon lens should I get, and nothing for this?!!!! C'mon, I can't be the only one that has had this problem!
     
  5. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #5
    I'm not at my Mac right now, but you want to restore your photo library, not the Aperature app. Look in the time machine vault for your "photos" folder and in there should be your aperture library file (assuming you are letting Aperture manage your photos). Try restoring that.
     
  6. carlgo thread starter macrumors 68000

    Joined:
    Dec 29, 2006
    #6
    Thanks for the reply. In the meantime I started over and am afraid to rock the boat and potentially mess things up. Ap3 is unforgiving and if you screw up, it is really time consuming to deal with it.

    In fact, it is such an unfriendly program, to me at least, that Time Machine should have a dedicated Aperture section to where you can deal with Ap3 in detail. The command-Z thing only goes so far and that is not really up to the task either.
     
  7. mousemd macrumors member

    Joined:
    Nov 21, 2002
    #7
    I may not be the most friendly person for time machine now (see my previous horror show experience with it and aperture 3) but there is a chance that time machine DID NOT back up your photo library. No matter how far you go back, it may have only updated a few here and there. You should check the file sizes of the time machine backup BEFORE you replace the library because it may even give you less photos than before. Good luck.

     

Share This Page