Time Machine and Networked Folder/Drive?

Discussion in 'OS X Mountain Lion (10.8)' started by Namtaro, Aug 18, 2012.

  1. Namtaro macrumors regular

    Joined:
    Dec 4, 2011
    #1
    Hello all, I'm wondering if there's a way to use Time Machine on a networked drive/folder?

    I tried searching for guides, but all that pops up are guides for Snow Leopard and it no longer works for Mountain Lion.

    Any help/links/guides would be great! :)
     
  2. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #2
    yep it works, just select it and Mountain Lion will create a sparsebundle image where the TM backups will be stored.
     
  3. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #3
    What OS is running where the networked drive is?
     
  4. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #4
    Lion or mountain Lion.
    Never tried on a windows share.
     
  5. phyrexia macrumors 6502a

    Joined:
    Sep 3, 2010
  6. SlCKB0Y, Aug 20, 2012
    Last edited: Aug 20, 2012

    SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #6
    Apple require you to have Server installed on the target machine.
     
  7. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #7

    Nope, it doesn't. I don't have any server SO and can use a remote share as a TM destination.
     
  8. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #8
    Sorry about that..my mistake.
     
  9. Namtaro thread starter macrumors regular

    Joined:
    Dec 4, 2011
    #9
    Hello, the networked computer is running Windows XP.

    If I mount a harddrive the harddrive doesn't show on the time machine options.

    I've tried the sparsebundle image thing, but the guide was for snow leopard. Anyone have a link for mountain lion?
     
  10. tgreena, Aug 24, 2012
    Last edited: Aug 24, 2012

    tgreena macrumors newbie

    Joined:
    Jun 29, 2011
    #10
    I am having the same issues, hopefully someone can come up with a fix soon. I am trying to back up my 10.8 MBP to a drive on my Windows 7 desktop that is on the same network. I had it working great and backing up over the network while my laptop was running 10.7 (Lion) but ever since I upgraded to 10.8 (Mountain Lion) Time Machine won't show the unsupported network drives.

    WHY NOT!? Can anyone answer this question?

    Every guide I find or search I make gives me back results for Lion or under. I know how to make it work with lion, I need Mountain Lion help!
     
  11. Mikey7c8 macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Montreal, Canada
    #11
    CIFS sucks ?

    Shouty capitals will get you nowhere.

    Running mine on a NAS, which is fine but I suspect it serves over AFP.
     
  12. tgreena macrumors newbie

    Joined:
    Jun 29, 2011
    #12
    ...
     
  13. Namtaro thread starter macrumors regular

    Joined:
    Dec 4, 2011
    #13
  14. kyle2194 macrumors newbie

    Joined:
    Jun 21, 2012
    #14
    Hey thanks for posting this link, I tried quite a few guides but this is the first to work for me. You need to first make a disk image, then copy the image to your network share. After this, mount the image. It should then be addressable via /Volumes/imagename and that is the mount point you want to use.
     
  15. moogs macrumors member

    Joined:
    Sep 13, 2006
    #15
    I've got the sparse bundle created on my windows pc and I can see and mount the drive on my mac but I'm having trouble seeing the drive in the Time Machine prefs. I've already run the terminal command to show unsupported drives but still nothing.
     
  16. tgreena macrumors newbie

    Joined:
    Jun 29, 2011
    #16
    Just confirming I am having the same issue and giving a bump in hopes of a fix. =/

    I have the sparse bundle on the windows drive and it is visible in finder. I did the terminal command for time machine to be able to see unsupported networks and the drive still isn't showing up in time machine.
     
  17. WAYLIFE macrumors newbie

    Joined:
    Aug 22, 2012
    #17
    Anyone??

    Hi all!

    Definitely would like to know how to fix this. I have done everything from mounting the image successfully (seeing it in disk utility), to running all the scripts and commands mentioned in this thread.

    Bumps for a great potential solution!!

    :apple:
     
  18. ResRules macrumors newbie

    Joined:
    Oct 14, 2012
    #18
    Did anyone ever get this working?

    I just get this with Mountain Lion

    sudo tmutil setdestination -a /volumes/OSX/
    /volumes/OSX: Incompatible file system type: smbfs (error 45)
    The backup destination could not be added.

    Ive enabled unsupported drives :(
     
  19. jonnycombs macrumors newbie

    Joined:
    Nov 28, 2012
    #19
    Got it working!

    The step I missed was opening up the share in finder, and double clicking the parse bundle so that it would mount the parsebundle as a device. Once I did that I was able to run sudo tmutil setdestination /Volumes/Time Machine Backup (note: this is not the name of the share on my Windows 7 machine, it is the name of the device that was attached after opening the parse bundle in the shared folder). Hope this helps.
     
  20. deeve macrumors member

    Joined:
    Dec 20, 2012
    #20
    Hello, I have been reading through this thread and get the same message as above after I use the tmutil command. I am using OS 10.8.2 and trying to access a HDD connected to a Win XP machine. The drive image can mount ok and I can see it from my Mid 2009 MCP, but it doesn't come up on Time Machine. Any ideas?
     
  21. Namtaro thread starter macrumors regular

    Joined:
    Dec 4, 2011
    #21
    Yeah, I got it working a month ago, but totally forgot about this thread... I just made a thread on how I got it working. Hopefully it'll help you! :)
    Feel free to ask questions on that thread.

    http://forums.macrumors.com/showthread.php?p=16530075#post16530075
     
  22. switon macrumors 6502a

    Joined:
    Sep 10, 2012
    #22
    RE: using Kerberos for authentication for tmutil?

    Hi all,

    I was just wondering if anyone has attempted to use Kerberos for authentication of the "tmutil setdestination..." command? This would automatically authenticate the mounting of the TM networked backup volume without the need for retyping your password. For example, if "tmutil" uses the same syntax as the "mount_afp", then the command would look like the following:

    Code:
    tmutil setdestination [-a] afp://;AUTH=switon%20Krb%20v2@host.machine/afp-share-volume
    
    I use this syntax for authenticating the mounting of AFP shares via Kerberos thereby eliminating the need to either put the password in the clear text or having to retype the password interactively to mount the AFP share. I was wondering if anyone has tested this for the "tmutil setdestination" command? I have not done so. The documentation for tmutil does not say that this is possible, and the manpage only lists the "username[: password]", but because of the inadvisable security risk of the password in cleartext, I was wondering if anyone has tried the Kerberos way?

    [There should not be a space between the : and password in the above, but when I put them together the colon is converted to an emoticon.]

    Thanks,
    Switon
     
  23. mtbeck macrumors newbie

    Joined:
    Feb 2, 2013
    #23
    Invalide File System

    I am having the same issue is DocsThaName. Here is the response:

    /Volumes/TimeMachine: Incompatible file system type: smbfs (error 45)
    The backup destination could not be set.

    I am at a loss, so any help would be greatly appreciated.
     
  24. Alster macrumors newbie

    Joined:
    Apr 14, 2013
    #24
    Entire Windows Time Machine Network Process

    I went through a lot problems mentioned here but I figured it out after reading many posts and articles. Here is a basic breakdown.

    1.Create a windows network share from a folder i.e. E:\TimeMachine
    2.With Finder open using the CMD+K option enter the share path i.e. smb://machinenamehere/TimeMachine/
    3. Open Terminal and run: defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1 * This shows the unsupported network drives.
    4. Download http://cache.gawker.com/assets/images/lifehacker/2010/11/makeimage.sh Script
    5. CD to downloads folder where makeimage.sh script is located.
    Run script from terminal sh ./makeImage.sh 130 /Volumes/TimeMachine/ where 130 is the size you want, change if you like and TimeMachine is your mounted volume. Press tab twice at /Volumes to get a list of all usable volumes.
    6. In finder locate the TimeMachine share and click on the Sparsebundle this will mount Time Machine Backups on your desktop and will make it show up in available volumes.
    7. In Terminal run sudo tmutil setdestination "/Volumes/Time Machine Backups/" enter your password and don't forget the quotes.
    8. The Back up option will now show when you click on Time Machine and you can select the drive and begin backups.

    I hope this helps I spent many hours figuring this out my configuration is Windows 7 and MacBook Pro running OS X 10.8.3
     

Share This Page