Time Machine and Spotlight Indexing really slow

Discussion in 'OS X Mavericks (10.9)' started by furcalchick, Nov 6, 2015.

  1. furcalchick macrumors 68020

    furcalchick

    Joined:
    Dec 19, 2006
    Location:
    South Florida
    #1
    I've been trying to figure out an issue I've noticed for about a week (but may have been happening for longer than that). About a week ago, I noticed my Time Machine hourly backups were taking a very long time. Like several hours for an hourly backup. I then did a search and found out that spotlight issues could be connected. And then I see my spotlight on "indexing" mode for a very very long time. So I decide to do the typical "make private and make public" trick to spotlight. And then it went and indexed for over a day. I think it's finally stopped indexing, but I thought that was happening before, so I'm not sure.

    So I looked in this thread [http://forums.macrumors.com/threads/macbook-spotlight-taking-forever-to-index.1327936/page-2], and followed the first two steps later on the thread. Here's the results I got.

    Not sure what it means, but the indexing stopped and spotlight at least looks to be working as it should.

    However, as of this moment, not sure if this will end the extremely slow Time Machine backups.

    Is this the end of my spotlight issues? Should I do something else? And what about Time Machine?

    Thanks in advance!
     
  2. furcalchick, Nov 6, 2015
    Last edited: Nov 6, 2015

    furcalchick thread starter macrumors 68020

    furcalchick

    Joined:
    Dec 19, 2006
    Location:
    South Florida
    #2
    It seems like it only worked for one cycle, as one hour later, it's doing the same thing again, indexing for a while, slow Time Machine backups. I would like to know how to solve this for the long term. And I noticed it only re indexes when it's time for a Time Machine backup.

    Just to let you know, the Time Machine hourly backups are usually only a couple hundred MBs, although I'm wondering why it's even that big.
     
  3. furcalchick thread starter macrumors 68020

    furcalchick

    Joined:
    Dec 19, 2006
    Location:
    South Florida
    #3
    Okay, this is weird. I restarted the computer, and now, the indexing meter has more or less started from zero. However, the spotlight seems to act correctly (as in I type something, results show up). I'm just confused right now.
     

Share This Page