Time Machine Backup Error

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
I just bought a new 2gb Time Capsule to replace my 3 year old 1gb model. I have 4 Macs that back up to the Time Capsule (3 laptops wirelessly, 1 iMac wired). It is the exact same setup I had with the old Time Capsule. I set up the new Time Capsule without transferring over prior backups.

On my Retina MacBook Pro, I am receiving the error "The identity of the backup disk “MyName” has changed since the previous backup." Some add'l details:

1) The new and old TCs were named the same and no other external drives are plugged into any computers
2) The other 3 computers are properly using the Time Capsule
3) The issue seems to pop up over night, in other words when I have not been using the MBP for a while, but I am not sure that has any bearing on this, just a data point
4) I have deleted the sparsebundle and plist file for the MBP, essentially trying to clear out all remnants
5) I am on Mavericks with all software up to date
6) I have selected and unselected the backup disk several times in System Preferences/Time Machine/Select Disk

I have looked at /volumes/ on both the MBP and my iMac and watched as I run a Time Machine backup. As the TM backup runs, additional volumes appear and then disappear once the process completes:

On the iMac: Volumes named "MyName Time Capsule" and "Time Machine Backups" appear while the process is running, then both disappear once finished.

On the offending MBP: Volumes named "MyName Time Capsule" and "Time Machine Backups" appear while the process is running, then both disappear once finished. However, there is another volume called "MobileBackups" that does NOT go away once finished. I've tried to manually dismount that volume, and when I re-run the Time Machine process it reappears and does not automatically disappear.

Any advice would be greatly appreciated.

Thank you in advance, John
 

MCAsan

macrumors 601
Jul 9, 2012
4,549
417
Atlanta
We had an older flat TC and I purchased a new 3TB TC Tower. I replaced the old TC with the new once as the wifi generator and the ethernet switch downstream from the UVerse home gateway (DSL modem). I told the wife's rMBP to use the new TC's drive for backups. I ran ethernet from a new TC LAN port to the old TC's WAN port. So I have cascaded the TCs. I told my rMBP to continue to backup to the old TC's HD. The two TCs running together gives more disk space for backups, more ethernet and USB ports. Our rMBPS connect to the new TC's ports while our printers connect to the old TC's ports.
 
Comment

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,169
9,838
California
Try going into Airport Utility and erasing the Time Capsule drive and naming it something different. Then go to each machine and turn TM off then back on and select the new TC drive.

It sounds like the systems are confused looking for the same name drive with a different hardware UUID
 
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
I am starting to triangulate on a reason this is happening...but I am not there just yet. I believe this has something to do with sleep mode.

I am only getting these errors in the mornings. And there have been different errors each morning. It is happening after an extended period of non use.

I have multiple MacBooks in the house, so was able to compare, and I noticed that the new Haswell rMBP has different energy saving settings that non-Haswell units. There is no longer a slider to put the computer to sleep (sleep relies on a combination of the display timer as well as an option to "Prevent the computer from sleeping automatically when the display is off").

I am trying to experiment with manually putting the laptop to sleep to see what happens.
 
Comment

priitv8

macrumors 68040
Jan 13, 2011
3,620
467
Estonia
I also sugegst you take a look at the backupd log it produces while running. It will contain lots of info about the process, success of mounting the drive & image etc.
You may leave it running in Terminal overnight to see what pops up.
Code:
sudo tail -f /var/log/system.log | grep -i backup
PS you need admin rights for this command to work!
 
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
I also sugegst you take a look at the backupd log it produces while running. It will contain lots of info about the process, success of mounting the drive & image etc.
You may leave it running in Terminal overnight to see what pops up.
Code:
sudo tail -f /var/log/system.log | grep -i backup
PS you need admin rights for this command to work!
I did not have the error this morning.

I'd be interested in running the command you specified...but I have no idea what it means. Can you or someone explain before I haphazardly run something I am completely unfamiliar with?

Thanks, John
 
Comment

priitv8

macrumors 68040
Jan 13, 2011
3,620
467
Estonia
It's no hazard. tail just keeps live track of the tail of system.log and grep filters out only those lines that contain word backup.
 
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
It's no hazard. tail just keeps live track of the tail of system.log and grep filters out only those lines that contain word backup.
Great...thanks for the education! I will run that tonight.

Once I start using that command...do I need to stop it? Or will just closing the terminal window end the process?
 
Last edited:
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
Well, I am virtually convinced that this is an issue around when the rMBP goes into sleep mode and loses connectivity to my network. I was away from the machine for a couple of hours today, and upon return noticed an exclamation point in the Time Machine icon. The menu indicated "Backup Delayed".

1) When I tried to manually start a backup, after several minutes I received a notice "Time Machine couldn't complete the backup to "myname". The backup disk is not available. Make sure the backup disk is connected or select a different backup disk."

2) When trying to select the disk in Airport Utility and trying to manually run a backup, after several minutes I received the error "There was a problem connecting to server "myname". Check the server IP address, and then try again. If you continue to have problems, contact your system administrator."

3) I also tried to open the drive via Finder but was unable to connect to the drive.

4) Based on a suggestion from someone, I ran the following Terminal command (see results below):
sudo tail -f /var/log/system.log | grep -i backup

5) Meanwhile, I checked both my iMac as well as my wife's MBA and both had been running Time Machine properly throughout, no errors in the past and no errors today. I manually ran a backup on both the iMac and the MBA and both ran perfectly.

6) I restarted the Time Capsule via the Airport Utility. Upon restart, I was able to successfully manually run a TM backup form my rMBP. I was also able to access the Time Capsule via Finder.

Add'l Notes:

a) I am not losing my network connection in general. I am still able to browse, etc. I am just losing my TC connection apparently.

b) I was using an old Time Capsule with this same laptop for about a month before buying this new Time Capsule. I never once had this issue with the old Time Capsule.

It seems clear to me that upon non-use I am somehow losing connectivity to the Time Capsule. While the issue hasn't happened in over the past 2 nights, it did happen today while I was out running errands. My hypothesis on why it didn't happen the past 2 nights is that there may have been some network activity (ie: receiving an email, receiving an iMessage, etc.) that allowed the rMBP to maintain connectivity.

Any additional ideas with the new info? I will call Apple ASAP, but cannot tonight.

Thanks in advance.

------------

Results of Terminal command while trying to run a TM backup:

Jan 4 16:02:56 Aaa-Bbbs-MacBook-Pro.local com.apple.backupd[3845]: NAConnectToServerSync failed with error: 89 for url: afp://aaa%20bbb;AUTH=SRP@Bbb._afpovertcp._tcp.local/Bbb%20Time%20Capsule
Jan 4 16:02:56 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: Attempting to mount network destination using URL: afp://Aaa%20Bbb;AUTH=SRP@DAgostino.local/Bbb%20Time%20Capsule
Jan 4 16:05:27 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: NAConnectToServerSync failed with error: 89 for url: afp://Aaa%20Bbb;AUTH=SRP@DAgostino.local/Bbb%20Time%20Capsule
Jan 4 16:05:27 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: Backup failed with error 19: The backup disk could not be resolved, or there was a problem mounting it.
 
Last edited:
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
Last evening I went through the suggestions on this page for "Symptom: The network connection drops unexpectedly":

http://support.apple.com/kb/HT4628

This morning no error...we'll see if resetting keychain and NW settings helps long term.
 
Comment

DeputyDawg

macrumors member
Nov 29, 2009
31
0
Well, I am virtually convinced that this is an issue around when the rMBP goes into sleep mode and loses connectivity to my network. I was away from the machine for a couple of hours today, and upon return noticed an exclamation point in the Time Machine icon. The menu indicated "Backup Delayed".

1) When I tried to manually start a backup, after several minutes I received a notice "Time Machine couldn't complete the backup to "myname". The backup disk is not available. Make sure the backup disk is connected or select a different backup disk."

2) When trying to select the disk in Airport Utility and trying to manually run a backup, after several minutes I received the error "There was a problem connecting to server "myname". Check the server IP address, and then try again. If you continue to have problems, contact your system administrator."

3) I also tried to open the drive via Finder but was unable to connect to the drive.

4) Based on a suggestion from someone, I ran the following Terminal command (see results below):
sudo tail -f /var/log/system.log | grep -i backup

5) Meanwhile, I checked both my iMac as well as my wife's MBA and both had been running Time Machine properly throughout, no errors in the past and no errors today. I manually ran a backup on both the iMac and the MBA and both ran perfectly.

6) I restarted the Time Capsule via the Airport Utility. Upon restart, I was able to successfully manually run a TM backup form my rMBP. I was also able to access the Time Capsule via Finder.

Add'l Notes:

a) I am not losing my network connection in general. I am still able to browse, etc. I am just losing my TC connection apparently.

b) I was using an old Time Capsule with this same laptop for about a month before buying this new Time Capsule. I never once had this issue with the old Time Capsule.

It seems clear to me that upon non-use I am somehow losing connectivity to the Time Capsule. While the issue hasn't happened in over the past 2 nights, it did happen today while I was out running errands. My hypothesis on why it didn't happen the past 2 nights is that there may have been some network activity (ie: receiving an email, receiving an iMessage, etc.) that allowed the rMBP to maintain connectivity.

Any additional ideas with the new info? I will call Apple ASAP, but cannot tonight.

Thanks in advance.

------------

Results of Terminal command while trying to run a TM backup:

Jan 4 16:02:56 Aaa-Bbbs-MacBook-Pro.local com.apple.backupd[3845]: NAConnectToServerSync failed with error: 89 for url: afp://aaa%20bbb;AUTH=SRP@Bbb._afpovertcp._tcp.local/Bbb%20Time%20Capsule
Jan 4 16:02:56 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: Attempting to mount network destination using URL: afp://Aaa%20Bbb;AUTH=SRP@DAgostino.local/Bbb%20Time%20Capsule
Jan 4 16:05:27 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: NAConnectToServerSync failed with error: 89 for url: afp://Aaa%20Bbb;AUTH=SRP@DAgostino.local/Bbb%20Time%20Capsule
Jan 4 16:05:27 Aaa-DAgostinos-MacBook-Pro.local com.apple.backupd[3845]: Backup failed with error 19: The backup disk could not be resolved, or there was a problem mounting it.

Hello, Ive been experiencing the exact same errors since I updated to Yosemite (from Mavericks). I have been in constant contact with apple, no luck. I even have an executive sponsor on this. However, he refuses to give me any updates - you know how secretive Apple is.

I have swapped out the TC 2 times per Apple, no luck. I have reset the TC, which will allow ONE backup but rest fail with the same errors you documented. Once and a while I can get it to backup for a week or two before the errors.

I tried changing the TC name from Time Capsule to TimeCapsule, no luck

My technical Apple contact states this is an OS bug. But of course no one will give me any details

Since I want my data backed up, Apple asked me to hook up an external drive to USB - that has been working without incident so far.

Btw I'm on a new Imac 27" and have taken all updates (i'm on 10.10.3). I have exhausted everything I know of and everything from the various forums that were suggested.

I'm afraid that since Apple has announced a new release (El Capitan) they will abandon this bug issue.

If there is anyone out there that has any information and/or can help, I would greatly appreciate it.

Thanks
 
Comment

jdag

macrumors 6502a
Original poster
Jun 15, 2012
831
213
Hello, Ive been experiencing the exact same errors since I updated to Yosemite (from Mavericks). I have been in constant contact with apple, no luck. I even have an executive sponsor on this. However, he refuses to give me any updates - you know how secretive Apple is.

I have swapped out the TC 2 times per Apple, no luck. I have reset the TC, which will allow ONE backup but rest fail with the same errors you documented. Once and a while I can get it to backup for a week or two before the errors.

I tried changing the TC name from Time Capsule to TimeCapsule, no luck

My technical Apple contact states this is an OS bug. But of course no one will give me any details

Since I want my data backed up, Apple asked me to hook up an external drive to USB - that has been working without incident so far.

Btw I'm on a new Imac 27" and have taken all updates (i'm on 10.10.3). I have exhausted everything I know of and everything from the various forums that were suggested.

I'm afraid that since Apple has announced a new release (El Capitan) they will abandon this bug issue.

If there is anyone out there that has any information and/or can help, I would greatly appreciate it.

Thanks
Sorry I cannot help further...I am no longer getting the errors, but I cannot recall what step(s) fixed the problem.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.