Resolved Time Machine Backup Going Very Slow, Freezes -

Discussion in 'Mac Basics and Help' started by NikMac, Mar 22, 2012.

  1. NikMac, Mar 22, 2012
    Last edited: Mar 22, 2012

    NikMac macrumors member

    Joined:
    Feb 9, 2008
    Location:
    Canada
    #1
    Hi,

    I've been using Apple's Time Machine software with a WD "MyPassPort Essential" external drive for about two years now with absolutely no problems. Today I plugged it in for the first time in a couple of months and when the backup reached 4.63 of 23.62 GB, it stopped progressing. The clock in my menu bar kept spinning as if it was backing up normally, but after half an hour it was still stuck at 4.63GB (it only took 15-20 minutes to progress this far). I stopped the backup and restarted it, this time it was very slow - After 20 minutes only 360KB had been backed up.

    After looking around on the internet I discovered how to fix this problem - by stopping the backup, deleting the .inProgress file in "Time Machine Backups/Backups.backupdb/MacBook"- but the third time it ran, I have the same problem when the backup reaches 4.63 GB.

    I am sure this is not a space issue as my drive still has 146.3 GB of remaining space. I've tried restarting my computer, but that doesn't help either. Any advice is very much appreciated.

    Thanks,
    Nik
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Turn off spotlight indexing of the drive you are backing up TO. If you have a Finder window open on the drive you are backing up TO, close it. You might have a corrupted TM backup. You can start a new one and the new one might finish faster than you could repair the old one. Keep in mind that once you are faced with a corrupte TM backup, there is a significant risk you have NOTHING. No backup whatsoever. It's better to simply delete the corrupted "sparsebundle" file and start afresh. This time make sure spotlight is switched off before the backup begins.

    Never back up over wireless via anything slower than 802.11n. I've had more than one instance of corrupted TM backups over the network and I know better than to rely on TM backup over wifi. Use gigabit ethernet if you can. Regular 100 Mbps ethernet is more reliable than 802.11g but you will be waiting a really long time for a "fresh from scratch" TM backup to complete.
     
  3. NikMac thread starter macrumors member

    Joined:
    Feb 9, 2008
    Location:
    Canada
    #3
    Thanks, it turned out to be something else actually - I found that whenever the backup appeared to slow down, the console mentioned something about mdworker32 leaving an error log in Library/Logs/DiagnosticReports - I checked the report and it mentioned a leftover file in my library from an application I had uninstalled earlier. Dragged the file to the trash and the problem was solved.

    Also, for anyone else having trouble, the dashboard widget "Time Machine Buddy" was also helpful in identifying the initial problem (I learned that time machine was unnecessarily attempting a deep traversal because of that strange file I mentioned).
     
  4. pencilcheck macrumors member

    Joined:
    Sep 2, 2010
    #4
    Your advices works for me, it seems to be that my spotlight is indexing so time machine will pause until it is finished. I also exclude my backup drive from indexing, and that helps speed up the process a lot.
     

Share This Page