Time Machine backup is not working.

soundsystem00

macrumors member
Original poster
Dec 15, 2016
59
5
Wow, this MacBook Pro has given me nothing but issues. I just got it back from repair for the second time.

I think my time machine backup was damaged. I was about to do a new backup and noticed that it was going to take a really long time, so I cancelled the backup.

It is still showing a lot of data on the drive and all, but whenever I go to run Migration Assistant, it has a "!" on the drive and it says that the backup has a newer operating system than I have. Well I updated the operating system and I am still getting the same message.

Is there any way around this or have I just lost years worth of data?
 

pippox0

macrumors member
Jan 23, 2014
73
53
Use some other backup sw instead of Time machine...
I. e. Carbon Copy Cloner or something else
 

Howard2k

macrumors 68030
Mar 10, 2016
2,574
1,831
You don’t mention anything at all about the details of what you have.

Which MBPro do you have?
Which versions of macOS have you been using?
Which one are you using now?
Is the drive a local USB drive or network drive?
Do you have screenshots of the migration assistant?
Are you trying to backup or restore?
 

Fishrrman

macrumors P6
Feb 20, 2009
17,194
5,543
Here's but one more instance where a Mac user put his faith into Time Machine, and then... in a moment of need... it FAILED him.

OP:
I agree with pippox above.

STOP USING TM as your backup app.

Instead, try either CarbonCopyCloner or SuperDuper.
Both are FREE to download and try for 30 days.

They will prove to be more reliable than TM in future "moments of need"...
 

soundsystem00

macrumors member
Original poster
Dec 15, 2016
59
5
Okay cool! I finally got it to work by updating the operating system to mojave. I restored it on top of another user account so I was getting a ton of glitches. I erased everything by going into the CMD+R menu when booting up. Then I did time machine from there and used a different cable. A direct usb C cable from the portable hard drive instead of using USB and a converter.

Not sure why those steps made a difference but I finally got it running. Thanks for the advice, I will use those apps next time, then.