Time Machine Backups External Hard Drive can't unmount.

Discussion in 'Mac Basics and Help' started by ghostoth, Oct 2, 2012.

  1. ghostoth macrumors newbie

    Joined:
    Oct 1, 2012
    #1
    Hello,

    I have been searching for a resolution for a couple weeks now with no success. Here is what I think I know.

    I have an eMac G4 desktop running 10.5.8. I have a 1TB Seagate External HD conneced directly to the eMac via USB that I am using for my Time Machine Backup. I also kept all my music and video files on this external HD. (Yes, I now know that was not a good idea)

    At some point a backup failed and subsequent backups all failed. At this point everything else on the drive was visible and accessible.

    Overnight my mac went to sleep and the next evening when I clicked my iTunes to play some music it said the Library could not be found. I opened the drive and all the folders were there but none of the files in them showed up. The used space and remaining space left on the disk remained the same but the files just didn't show up.

    After restarting the computer and trying to eject the disc, eventually nothing on the disk showed up though the disk is mounted on the desktop and it is recognized by Time Machine when it is on. In Finder the disk does not show at all but in Disk Utility it is there. I cannot unmount the disk either through ejecting it, in Disk Utility or by dragging it to the trash. It says it cannot be unmounted. I have also tried to repair it through Disk Utility and it says it failed because the disk cannot be unmounted.

    I also used Terminal to try to find what process might be using the drive by typing in the command:

    lsof | egrep 'Time Machine Backups'

    and this is what it said:

    lsof: WARNING: can't stat() hfs file system /Volumes/Time Machine Backups Output information may be incomplete. assuming "dev=e000006" from mount table

    Not sure what that means or what to try next. I bought a new Mac so I really don't care about the backups all that much but getting the 80GB of music off that drive is my main concern as it is decades of collecting and some irreplaceable.

    Thanks for any help that can be provided.

    Nyk
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Seems to me that the file system is corrupt, Have you tried running verify from Disk Utility on it? This should be relatively safe, but you may want to back up your back up before trying.

    B
     
  3. ghostoth thread starter macrumors newbie

    Joined:
    Oct 1, 2012
    #3
    Yes, I have tried verifying and repairing and it simply tells me that it failed because the volume cannot be unmounted. I have tried unmounting it and ejecting it via DU as well but it says it can't be unmounted and to close all apps that may be using it. The only things running are Finder (which I also relaunched once as well) and DU. That's why I was trying the lsof command, to try to see if there is some process that's hidden using the disk.

    Would powering down and completely unplugging the eMac disconnect any hidden processes? Thanks!
     

Share This Page