Time Machine Drive Full and Won't Delete Old Backups

Discussion in 'OS X Yosemite (10.10)' started by snerkler, Jan 17, 2016.

  1. snerkler macrumors 6502a

    Joined:
    Feb 14, 2012
    #1
    Hi,

    Admittedly I've not backed up for about 4 weeks, but I've just tried to backup and it says that the disk is full and won't backup, but normally when it's been full in the past it's just deleted old backups and then notified me afterwards. Why is it not doing the same now? If I go to options there's nothing to remove from the backup to make the backup smaller, all it lists is my Time Machine Drive and under it says estimated size of full backup 927GB. Why is it trying to do a full backup?


    [​IMG]

    I am running Yosemite despite the name of the Time Machine Disk.

    Any help appreciated.
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    You might want to check Macs inbuild help (In Finder select Help menu then Mac help), you can find detailed instructions about Time Machine there.

    Brief answers:

    1. That exclude items list currently has no folders/ disks or other items which means your Mac will backup everything. If you want to exclude something you have to drag those folders to that list and press Save. Alternative is to press the + sign and select folders/ other items you want to exclude, press save.

    2. As for why Time Machine wont back up there are several possibilities. You should first check hard drive you are using for backups with Disk Utility to make sure it has no issues. In Disk Utility select drive from the list and press repair. If drive is ok go to answer 3, if Disk Utility reports an error then post the result and I will provide further instructions.

    3. Check this Apple support document and follow its instructions.
     
  3. snerkler thread starter macrumors 6502a

    Joined:
    Feb 14, 2012
    #3
    Thanks, I'll look into this when I get home. As for the selections on what Time Machine backs up I've never altered this, and it's never done a full backup before either. Usually it just usually backs up any changes so don't know why it's chosen a full backup this time. Hopefully when I plug in the drive and follow some of the steps above all will become clearer.
     
  4. snerkler thread starter macrumors 6502a

    Joined:
    Feb 14, 2012
    #4
    So the disk did have issues and I repaired it using disk utility and it now says that it's OK, but TM still won't backup and I just I get this message.

    [​IMG]

    I followed that link and tried everything. Strange thing is if I hold option and click the backup icon in the top tool bar "verify backups" is greyed out and I can't select it, any ideas why?

    I do wonder if my backup drive is on the way out, which is a bit of a concern. I've thought about reformatting the drive and backing up from scratch but if the drive's on the way out there seems little point?
     
  5. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #5
    Verify backups is only available with Timecapsule or other such devices. As for why Apple decided on this limitation I have no idea.

    Unfortunately SMART which provides information about drive health wont work with USB drives, it works only on internal drives and in Thunderbolt docks which are expensive. You could install Smart driver which provides such functionality but it could cause other problems because it isn't officially supported.

    There are several possibilities why Time Machine backup wont work.

    1. Time Machine bug. If you are absolutely certain you don't need the oldest backup you could delete it from Time Machine interface. Enter Time Machine, navigate to external drive and open folder Backups. Select the oldest backup and delete it by selecting option "Delete backup". There is no quarantine this will help because I suspect problem is due to bug in Time Machine.

    2. Faulty hard drive, if you have another drive you could test making backup there and see if it behaves similar way. If it does its very likely problem is in Time Machine and you should report it to Apple. Provide as much information on the bug report as possible.

    Alternatively you could erase the drive if you have everything it contains backed up to another drive and try using it again for Time Machine backups.

    3. Filesystem. While Disk Utility didn't find any errors it isn't 100% proof and disk might be problems it didn't find but options 1 and 2 are much more likely.
     
  6. vexorg macrumors 6502a

    Joined:
    Aug 4, 2009
    #6
    If there's nothing you need, the I'd get a new drive and start over with a fresh back up. You'll never be happy trusting that drive again with backups.
     
  7. snerkler thread starter macrumors 6502a

    Joined:
    Feb 14, 2012
    #7
    Thanks for the advice, most helpful. I do run two time machine backups and it works fine with the other drive which is why I suspect that it's an issue with the drive rather than TM tbh.

    I think you might be right, there would always be an element of doubt. If it is a drive failure that's 2 drives that have failed in the past 12months for me. One that I use to manually backup files to from my PC laptop, and this one. Is in usual for external drives (one iOmega and one Toshiba) to fail so readily or am I just unlucky? (I do treat them well and don't drop them/knock them etc). I just assumed that my data would be safe 'forever'.
     
  8. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #8
    Do you have anything on the drive other than the time machine backup? If so, backup and delete whatever else you have on the drive.
    --- Post Merged, Jan 19, 2016 ---
    I suggest you read this link from the Time Machine Guru, Pondini: http://pondini.org/TM/C4.html
     
  9. snerkler thread starter macrumors 6502a

    Joined:
    Feb 14, 2012
    #9
    No, it's only ever been used as TM backup. Thanks I'll check out the link.
     

Share This Page