Time Machine Drive Wont Mount

Discussion in 'Mac Apps and Mac App Store' started by Rojo024, May 11, 2008.

  1. Rojo024 macrumors member

    Joined:
    Oct 18, 2007
    #1
    I am using a Western Digital My Book Hard drive for time machine backup on my MacBook Pro CD. I plug the time machine drive into my computer every time i am at home. But, about a week ago it stopped working. The Drive simply wont mount. The computer doesn't even recognize the drive in the disk utility. I have tried to search the apple website, and the forums here as well, but i am unable to find any helpful information. If someone could help or point me in the direction to find a solution that would be awesome.

    Also, is there any the information will be recoverable if the drive is lost?

    Thnaks
     
  2. ceres macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Dark Forests of Germania
    #2
    It´s likely that you suffered a hardware failure. In this case you would have to pay for professional data restoration. Have you tried your external drive on another pc/mac?
     
  3. Rojo024 thread starter macrumors member

    Joined:
    Oct 18, 2007
    #3
    Yes, I have tried it on both a pc and a mac. What are my options for data recovery? Is the external toast?

    Thanks for the help.
     

Share This Page