Time Machine Error: Backup Volume is Read Only?

Discussion in 'macOS' started by Mac In School, Nov 15, 2007.

  1. Mac In School macrumors 65816

    Jun 21, 2007
    Time Machine has been running fine for a week now. Suddenly, today, I get this error message:

    The Machine Error

    The backup volume is read only.

    To select a different volume, open System Preferences and choose Time Machine.

    I didn't change anything to make it read-only, and it's far from full.

    Any ideas what's going on?

    Attached Files:

  2. Cave Man macrumors 604

    Cave Man

    Feb 12, 2007
    Neander Valley, Germany; just outside Duesseldorf
    Holy crap, this just happened to me about 3 hours ago. I'm searching frantically for a solution. Did you ever find one?
  3. argentum macrumors newbie

    Nov 25, 2007
    time machine glitch

    I just had this same thing happen. Interestingly, it was soon after a new Leopard software download. Don't know if that had anything to do with it or not.
    Has anyone figured out what the problem is? Since I have Apple Care my plan is to talk with the Apple people tomorrow and see what they have to say.
  4. argentum macrumors newbie

    Nov 25, 2007
    After two unsuccessful backup attempts each one hour apart, the third attempt backed up OK. Not sure what is going on but maybe this just happens time to time:confused:
  5. Aaron Koolen macrumors newbie

    Nov 26, 2007
    This just happened to me about 5 minutes ago. It has also happened to me about a month ago and I had to reformat my backup drive.

    Just now as I was typing this the Time machine dialog popped up again saying the backup disk is read only.

    I'll leave it and see what happens - hopefully it will work itself out.

    What's weird is that if you do GetInfo you get

    myusername - read/write
    (uknown) - read/write
    everyone - read only
  6. lselsick macrumors newbie

    Dec 12, 2007
    Any progress on resolving this?

    Walked into my office this morning and 2 of my 3 macs are giving me the same error message (read only volumes for time machine). this is clearly a bug – does anyone have a solution?

  7. Aaron Koolen macrumors newbie

    Nov 26, 2007
    Nope not yet. Time Machine is still making my drive read only.

    I was wondering, are we all using external drives, or internal ones for our backups?
  8. GoodWatch macrumors 6502a


    Sep 22, 2007
    Rotterdam, The Netherlands
    I had the same thing yesterday on an external drive. A reboot fixed it.
  9. Aaron Koolen macrumors newbie

    Nov 26, 2007
    Yeah it seems some people can reboot and all's fine, but for some of us it's a bit more serious. It's also hard to find anything on the net about it. The odd post by someone who's had the problem, but no real solution yet.
  10. GoodWatch macrumors 6502a


    Sep 22, 2007
    Rotterdam, The Netherlands
    Have you tried cmd I on the drive to change your user permissions back to read-write?
  11. calumsm macrumors newbie

    Dec 16, 2007
    If it's an external drive, drag it to the trash to unmount the drive and take out and resinsert the usb cable after 10 seconds = should be sorted:rolleyes:
  12. dazed macrumors 6502a

    Jun 23, 2007
    i get this once every few days. hopefully the next update will fix it as its starting to get annoying.
  13. vestokes@mac.co macrumors newbie


    Jul 4, 2007
    San Francisco Bay Area
    RE: Time Machine Error: Backup Volume is Read Only?

    I just got back from an appointment at the Apple Store's Genius Bar. I found out what was causing my trouble. Hopefully this will help others:

    The guy who was helping me ran diagnostics but could not find logs to determine what caused the backup failure. I had already reformatted and backed up since the read only/reformat error. There's still no explanation as to why there were no logs.

    Anyway, I told him it would be okay to reformat and do another backup which he wanted to do to remove the master boot block which has been known to be the culprit on issues with Mac backup failures. Unfortunately, my device is a 250 GB USB Western Digital portable drive which is extremely slow for the first backup. I have about 120 GB of data to back up. So, I told him to stop the backup and I will finish it at home and come back if there is another issue.

    This is when the trouble began, it was taking a long time to shutdown. The laptop was at the stage where all you see is the OS X screen without the menu, desktop items, or dock and the little circling hashes indicating it was still trying to shutdown. This went on for over 10 minutes. I then told the Apple tech that this happened after the software update which required a reboot and that I just shut off the system with the power button. He explained, and I should have known better, that the system was trying to unmount the disk and this is what caused the disk failures.

    Sure enough when the tech stopped the shutdown and restarted the computer in diagnostic mode, the error reappeared. He reformatted the disk and the computer successfully shutdown.

    Some of you may be wiser than I but I normally do this for my PC which takes forever to shutdown but of course it may not be accessing the disk when I shut it down. Anyway, this is a change I will need to make with my Mac. Unfortunately, I have no idea how long the unmount process could possibly take; ten minutes seems like an inordinately long period of time.
  14. vestokes@mac.co macrumors newbie


    Jul 4, 2007
    San Francisco Bay Area
    Re: Time Machine Error: Backup Volume is Read Only?

    I tried changing permissions on the drive, via ctrl-click->Get Info, and reconnecting the disk but none of that worked. I reformatted the disk but within the week I got another backup failure. After losing the data from the last backup failure I decided to backup to other disks then take it to the Apple Store. Hopefully removal of the MBR and reformat of disk resolves all the problems.
  15. Rogermc macrumors newbie

    Jan 2, 2008
    Yet another Leopard problem?
    I managed to solve this one by using Disk Utility to unmount then re-mount my external firewire Time Machine backup disk which had previously been working perfectly since first installed some weeks ago.
    Then selecting Backup Now worked without problem.
  16. Rezdave macrumors newbie

    Jan 3, 2008
    Have had this happen a couple times, but I think I cleared it up last night ... here's a check-list:

    1) Use both Disk Utility & Get Info to confirm that the disk is formatted in HFS+ (Journaled) and not FAT-32;

    2) Use Disk Utility to confirm that the disk has the correct Partition Scheme. For Intel-Macs this is GUID and not Master Boot Record. When formatting the drive you can change schemes by clicking the Options button when setting the partitions before you format the drive;

    3) Boot the computer without the TM drive attached, and the TM System Preference Panel will say that the next back-up is scheduled for when the drive is connected. Now connect the drive;

    4) As silly as it sounds, simply reselect the drive (perhaps newly-formatted even though it has the same volume name and icon and seems to be recognized by Leopard) in System Preferences, and if it doesn't automatically start then repeat #3 above.

    Hopefully confirming all of these should help clear up this problem, as well as the 10Gb-hang and a few other TM-related issues.

    BTW, I'm using a USB 2 drive for TM on a MacBook. I don't know how the USB ports are bussed, but in past Macs multiple ports were sometimes on a single bus. It seems to run faster for large back-ups (I did 258Gb last night in 10 hours) when there are no USB 1 devices on the bus to potentially cause a step-down like happens when mixing 802.11b and 11g devices on a wireless network.


  17. segalman macrumors newbie

    Feb 14, 2008
    thanks for the fix

    I had the same problem- i dragged the icon for the TM backups drive to the trash-shut down and unplugged the drive. I then started up and it is running a back up as we speak. Hopefully this issue will be fixed in the next update. it just began when i updated to 10.5.2
  18. ncsmith4 macrumors 6502

    Jul 15, 2007
    Is anyone still having this problem? Ive tried rebooting, unmounting, mounting, etc... Nothing is working. I dont know what to do...
  19. Rezdave macrumors newbie

    Jan 3, 2008
    Did you try any of the steps already discussed in this thread or the referenced articles? Have you checked your drive set-up? None of what you did has been suggested as a fix, but plenty of fixes have been discussed that you do not seem to have tried.

    Let me know if you are still having problems after following the steps outlined in my post above or in any of the linked references.

  20. ncsmith4 macrumors 6502

    Jul 15, 2007
    Yes, actually. I did everything that people here suggested. I had a friend of mine try some things in Terminal, and its still stuck saying that I have read/write, (unknown) has read/write, and "everyone" can only read.

    I tried repairing and it just sits there for 5-10 mins and then says that the permissions cannot be repaired. I dont have the exact error message, but I tried lots of the things you said. The drive has been working since Nov 5, and it just started doing this about a week ago, so it WAS formatted correctly initially.

    Im not sure what else to try... :-/
  21. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    I had this too, which caused me a few worries.

    - Unmounted and disconnected external,
    - powered it down,
    - shut down laptop,
    - wait a few secs,
    - boot it back up,
    - plug in external and power it back up (maybe power it up first, can't remember)

    and all was fine again.

    (using TM over wifi network to an external firewire hosted by an old Powerbook running leopard, so I rebooted both the Powerbook and my macbook

    I think I might have had to bring up the powerbook's TM disk on my macbook desktop and re-link to it in the TM preferences. )
  22. groundling123 macrumors newbie

    May 5, 2008

    For me this message was followed by a complete lockup of the system. I can't explain the connection but both of these problems were solved by putting new batteries in my wireless mouse. Good luck.
  23. lionello macrumors newbie

    Jan 19, 2009
    P.E.I., Canada
    Time Machine Error: Backup Volume is Read Only

    I've had this problem a lot.

    I solve it by opening Disk Utility, unmounting the disk, and remounting it.

    Then: Back up now.

    Don't format the drive until the last resort.

    Good Luck!
  24. Jake381 macrumors member

    Jul 31, 2008
    I have just experienced this issue as well.
    I'm wondering if it is because I just starting using boot camp and parallels.

Share This Page