Time Machine Error Code 512

Discussion in 'macOS' started by ggrabner, Oct 20, 2010.

  1. ggrabner macrumors newbie

    Joined:
    Jul 27, 2009
    #1
    hi guys,

    recently i get this error, and I can't figure it out:

    "Time Machine could not complete the backup.
    Error Code: 512"

    My MacBook Pro is connected via LAN to a NAS drive where i have my time machine backups.
    No IPs have changed, i can connect to the server/folder/drive without problems, have read/write permissions, etc.

    The error occured all of a sudden, can't figure out why.

    thanks in advance for any help.
    gabriel
     
  2. doudgv macrumors newbie

    Joined:
    Feb 6, 2011
    #2
    Any news ?

    Hello,

    I have the same problem, which appeared suddenly too, whereas everything was working fine, and moreover I still can navigate through the time machine in the past backups. Did you have any explanations ?

    Thank you.
     
  3. yupitsnuge macrumors newbie

    Joined:
    Feb 22, 2011
    #3
    I have been running into the same problem for 2 weeks now... anyone know how to fix this?
     
  4. dollygal macrumors newbie

    Joined:
    Mar 6, 2011
    #4
    I've been having the same problem since Feb 17th. I'm not sure if it is due to some OSX updates or from having my MacBook pro away from my home network when it tried to do an update.

    I noticed that my sparsbundle on the NAS box had been renamed to something other than computerName_MACaddress.sparsbundle It had inserted a lot of dates after the MAC address. I tried renaming the sparsbundle to the correct name format, and running time machine again. Then I got error #25. Finally I just deleted the sparsbundle and re-did all the steps for using Time Machine with an unsupported NAS as per this blog: http://appleclinic.wordpress.com/2008/10/30/time-machine-on-nas/

    My machine had to start over from scratch with the initial back-up and all the back ups from before are gone... but it at least works now. *shrug* I'm not sure if this helps anyone else but I'm glad to have things up and running again. In the future, I plan to turn off the automatic back up with Time Machine any time I'm leaving my home network. I also intend to be more careful about shutting down or sleeping my Mac to make sure it isn't in the middle of a Time Machine back-up when I do so.

    If this ever happens again, I intend to first try re-doing step #3 from the above linked blog. I suspect that somehow that got turned off, but I really don't know for sure what happened.
     

Share This Page