Time Machine / External HD Unmounting Issues

Discussion in 'OS X Mountain Lion (10.8)' started by phased, Jan 16, 2013.

  1. phased macrumors member

    Jun 10, 2009
    hi all,

    i'm running osx 10.8.2 on a 2009 macbook pro with an WD external HD for mac. computer is in pristine condition and runs a dream, the external HD has no reason not to, but i'm having issues.

    they seemed to have arisen for the first time after having gone a long while between time machine backups. 6 months, perhaps? now i have great difficultly having my external HD mount at all (i have it partitioned in two, so sometimes one will mount and the other will not), and when it does and i commence time machine, it simply 'prepares' to no end. when finder occasionally allows me to access the external HD itself, i've tried trashing the current back up file (forgotten the specific name) as recommended, and whilst this will then allow TM to complete 'preparing', it still hangs soon after.

    i've tried verifying and repairing the external HD (both partitions) through disk utility, and may have successfully done this once or twice, but normally it fails sighting the inability to unmount the disc. i can't help but feel if i can get the external HD to normally mount / unmount as it should, i'd be moving in the right direction but so far i haven't managed to sort this. i've also tried relaunching finder during this process but normally this hangs, too.

    i'm pretty desperate for some help. i'm about to start my thesis and really need these regular TM backups. worst case scenario i'd be willing to wipe the whole drive completely, but i'm not even sure this will solve the issue?

    advice is greatly appreciated!

  2. phased thread starter macrumors member

    Jun 10, 2009
    FWIW, this external HD is a desk-bound version and has not seen any travel, nor knocks.

    and it's using FW, not USB.

Share This Page