Time Machine fail - error (-41) and 11

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Karatehero, Jan 29, 2010.

  1. Karatehero macrumors member

    Jan 5, 2004
    Greetings all!

    I have a mac server in a windows environment. The server is OS 10.6.2 - brand new hardware. We use it to run a windows domain, file sharing, iChat, and Kerio e-mail.

    We used Time Machine to backup / when our old machine was 10.5 and never had an issue. Now that we have moved to 10.6 we keep getting failures. They go something like:

    Error: (-41) SrcErr: NO Copying /Shared Items/Public/....... to /Volumes/Backup/Backups.backupdb/........
    Copy stage failed with error:11
    Backup failed with error: 11

    (I had to type that by hand - sorry I didn't type it all, its just a couple paths I left out).

    If I go in and skip the file that failed to copy, then next time it keeps copying and eventually fails on another file. I've had it fail on .xls files that were used that day, I've had it fail on iTunes album artwork that hadn't been accessed in years.

    The only thing I can see is that this folder has ACLs on it - but I cna't see that matters. I have other files with ACLs that copy just fine.

    I have it set to ignore all system files and only copy the 2 files I really need.

    Any ideas? I'm not even sure what to check.

    Thanks in advance!!!!!
  2. jaw04005 macrumors 601


    Aug 19, 2003
    Error −11 is common.

    Use the Mac OS X boot disc, run Disk Utility and repair permissions on both the backup drive and system drive(s).

    Do not just run Disk Utility from within an already booted environment.

    If that doesn’t work, search Google for your error codes. There are several articles about possible fixes.

    Like these:


    Corrupted Time Machine backups are a PITA. I usually just start over from scratch.
  3. Karatehero thread starter macrumors member

    Jan 5, 2004
    Kewl - Thanks for the tip. I'm going to read through those right now!

    I also found this:

    Pretty detailed there. Turns our just marking several 'bad' files was enough to fix it. I need to do more research here to find what caused the files to go nuts.

    Thanks again!
  4. fsharp macrumors newbie

    Apr 13, 2009
    Same Issue with Errors 41 and 11

    I have Windows and Mac desktops accessing my Mac Mini Server running Mac OS X Server 10.6.2.

    My Time Machine backup fails on thousands of files with the error.

    Error: (-41) SrcErr:No Copying [filename] to [Time Machine backup]

    I've tried every step in the Time Machine Support Docs and called support but nothing fixes the problem. The only way to get the files to copy is to remove the entire access control list from each file. Only then do the files copy but they are useless to users then. Other files with the same control list copy just fine.

    Any help would be appreciated. Time Machine is completely useless with this issue.
  5. aspi macrumors newbie

    Aug 1, 2010
    No resolution?

    Hi there,

    I too have a Mac Mini Server running OSX Server 10.6.4, which replaced my old Mac Mini G4 acting as OSX 10.5 Server. The Time Machine worked perfectly on the 10.5 Server with all the files I migrated to the new machine (copied them via Finder and then made a sharepoint and propagated all permissions (ACLs and POSIX).

    I tried everything I found via google on this topic, but still I’m receiving the -41 SrcErr: NO Copying error on lots of files.

    I’m backing up files from one internal mac mini drive to the second one. Both having GUID PT, both are Mac OS Extended (Journaled), Spotlight disabled on both, no antivirus, just a fresh 10.6.4 system.

    Nobody still knowing about a fix?
  6. GerardDirks macrumors newbie

    Jul 7, 2010
    I have found no solution for some weeks now.

    I will wait a couple of days and then i will kill my 10.6.4 server and made will go back to my 10.5.8 Server.

    It is a crime that after 1 Year off OS X 10.6 Server their are so many bugs in the Apple OS.

    A professional BackUp solution should backup everthing and and the end bring me a list of the file that are defektive. When I would delete every error, it will take me months for the first backup wll finished successfull. I run different testing programm and after a couple of runs non of them brings any errors, but TM still complain. I am 100% sure it is a bug. Both RAID runs for 1 1/2 year without any problem with the 10.5.8 server! I formated and installed the 10.6 server and share RAID as access points for the users. We use only the AFP and DNS services

  7. pismobrat macrumors regular

    Aug 13, 2007


    With all due respect, Time Machine is not a certified/blessed solution from Apple for backing up 10.x Server. It is designed as a client side backup solution. Despite it being included, with the enabled services in 10.6, it is not designed to run with those features.

    I do feel your frustration, but using a blessed backup solution like Retrospect is a better solution. Use a busniess product designed to backup a Server OS and your problems will go away.

    Best Regards.
  8. GerardDirks macrumors newbie

    Jul 7, 2010
    Hello Prismobrat

    I don't agree

    We run the TimeMachine with 10.5 for 1 1/2 year without any problem. In time we did 1 restore from Time Machine without any problem!!

    If it is not certified , Apple should delete all the Time Machine features from their server platform otherwise it is very easy to bring them to court because of misleading customers!!!

    As soon as you install an OS X server Time Machine is active. As you connect an external drive, OS X Server automaticly inform you if you want to use the drive for backup. If your statement is correct, Apple is strongly illegal selling software that doesn't support the feature list.

    I know their are a couple of bugs, but if you tell us it is not certified I need to go to an US Court and ask for US$ 20.000.0000!!!

  9. jamesbeith macrumors newbie

    Sep 24, 2010
    Fix worked for me (permissions error)

    I believe the problem is due to permissions.
    I had this "Error: (-41) SrcErr:NO Copying" problem and this FIX worked for me.

    Right click and click Get Info on a file or folder thats giving you the error.
    Expand the Sharing & Permissions.
    Check that all the YOURNAME (Me) say Read & Write, I had multiple occurrences saying Custom.
    To change them you may need to click the padlock button in the bottom right.
    If your finding loads of files and/or folder that have different permissions you can go to the top most folder (eg. Documents folder) set the correct permissions, then click the star/settings button underneath the permissions table and hit Apply to enclosed items.

    Screenshot: http://cl.ly/2WZk

    Now delete your current InProgress TM backup located on your TM disk.
    Run the backup again and it should be ok.
  10. BruceW macrumors newbie

    Nov 11, 2010
    Error (-41) on multiple files/folders

    I have this same problem. All the files/folders that fail to copy seem to have "custom" permissions for the admin. They are all in my "archives" folder which contains thousands of documents going back years.

    How do I change global permissions on this archives folder without going through each and every folder and file?


  11. Les Kern macrumors 68040

    Les Kern

    Apr 26, 2002
    Using TM is a production environment is really not all that good of an idea IMO. FOr home users? Sure.
    I have had my ups and downs with my setup (extensive) using all manner of backup strategies, and TM is on exactly one server out of 40. And that's only because it's a live Oracle DB and Oracle cannot easily be backed up live (in our case) and there is no sharing on it at all.
    SO the solutions are many and you probably know of them. I prefer Retrospect, but actually, almost every server I run uses Carbon Copy CLoner to an internal and/or external drive on a set schedule depending on the server's task list. It has never failed me. Not even once. As a matter of fact it has literally saved my ass on a few occasions. I try to keep the backups as small as possible, but in some cases do a daily clone. Mostly I omit everything but the shares. Mac servers are so darn easy to rebuild from scratch.
    Good luck.
  12. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    sudo chown -R username:group /Path/to/folder

Share This Page