Time Machine Failed... Missing all back ups after March 31st!

Discussion in 'Mac Basics and Help' started by ryanschmidt, Aug 20, 2009.

  1. ryanschmidt macrumors member

    Joined:
    Aug 20, 2009
    #1
    I know this is going to sound crazy. I know it because I have searched all over the web trying to find an answer and I cannot seem to find anyone that has even had this problem. I pray that someone here can help me.

    Last night I decided to format my Macbook Pro and do a clean OS install. This laptop has very sensitive information for my freelance work so I am sure to backup with Time Machine and also with BackBlaze (thank God!). I completed a manual Time Machine backup just before I formatted and confirmed that all the necessary folders were on the external Time Machine drive. The latest folder there showed August 18th 2009 dating all the way back to the day Leopard released (the day I began using Time Machine).

    I restarted the machine with the Leopard disk and chose Disk Utility to zero out my laptop's internal drive. Once it was done, I began the Leopard install. Once that was done, it asked me if I wanted to restore from a Time Machine backup. How handy! I didn't know that would be an option. Naturally I selected that I wanted to do that and then selected my machine (oddly it was the only one listed, more on this later) and it began to do it's thing. Said it would take about 2hrs so I went to bed.

    This morning is when all hell broke loose. I sat down to the laptop to see that my dock had icons that I removed long ago and the Menu Bar had icons missing... I immediately got sick to my stomach. I checked a file I was working on just a couple days ago to make sure it was there... WASN'T THERE. I then pulled up the contents of the Time Machine drive and this is when I almost fell out of my chair... The last backup folder in the list was March 31 2009. I checked all over the disk... the spareimage was last modified March 31st.

    I don't know what to do! I tried to explain everything in detail so you could understand that there is NO CHANCE that I could have done this. Luckily my files are backed up to Backblaze but my music and movies are not. I only back those up locally. And the hassle of downloading 60GB of data from Backblaze!

    PLEASE HELP!
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    RE: Time Machine Failed...

    One more reason why - on this forum - I've repeatedly warned against using Time Machine vis-a-vis a genuine backup utility like SuperDuper.

    SuperDuper creates a true, bootable clone of the source volume. You can boot from it, verify that everything is there, and then do a restore in part or in full if need be. You can use the clone to "work on" your primary drive if it's giving you problems.

    You can't boot from a Time Machine backup. TM clogs up drives with copy after copy of the same file, when all you really need is the most recent version of that file. It burns out drives because folks leave their TM drives on all the time.

    I'm seeing an increasing number of postings from folks who run TM, and - when the chips are down - have problems getting their data back.

    I contend that TM, as it exists now, was designed to be a "backup for those who don't usually backup" kind of utility, something you could plug in, turn on, and forget about. Backup with a dumb smile. TM makes it EASY to get your data onto the TM drive. The problem is that TM seems to run into trouble trying to get your data FROM the backup drive.

    Enough of the rant.

    I suggest you do what you need to do to get copies of your data from online.

    Some stuff may just be gone.

    What I also suggest that you do is - once you have your primary drive restored as best you can - that you WIPE CLEAN the backup drive, get a copy of SuperDuper, and use it to do regular clones of your primary drive.

    Yes, you have to think about running that backup (although SD may have "timed operations", I've never even bothered with them). But once it's done, you have a bootable backup in plain ol' Finder format - everything is there, an exact copy of your primary drive.

    - John
     
  3. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #3
    John, I appreciate the response however you can imagine that this is not the time to be telling me what I should have done. Haha. I have used SuperDuper many times when upgrading hard drives etc. Looking back, I ABSOLUTELY wish I would have had a superduper backup in addition to TM & BB but there's nothing I can do about that now. The reason I did not take the time to perform a SD backup is because I wanted a clean install. I did not intend for TM to put all my settings back in place, I just wanted the files. I would not have minded if it would have put everything back in place using the latest backup... instead it "chose" to use March 31st. Time Machine took my machine back in time... literally.

    Anyone have this issue before or have an idea of how I can recover my lost data? I have FileSalvage running on the drive while I am at work today hoping to pull up something.
     
  4. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008
    #4
    You can also use Carbon Copy Cloner, the free alternative to SuperDuper!

    You can try DataRescue, but really depends on how you formatted the drive, if you didn't zero out, you probably have a good chance. If you did...good luck...
     
  5. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #5
    Well, I am not trying to restore the drive that I formatted. I am trying to restore the Time Machine drive that magically deleted my backups that should come before March 31st. I should have backups from just yesterday but the latest backup folders the Time Machine drive has is from March 31st.

    I checked and double checked that those folders were there before formatting my other drive. When I got up this morning, my computer was restored to the way it was back in March and the Time Machine backup doesn't show any backups more recent than that.

    I know this sounds crazy... because it is! :(
     
  6. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #6
    I just wanted to update this thread in hopes to help someone in the future.

    After trying about 4 or 5 different file recovery apps I had almost given up hope. The recovery apps found NONE of my removed files. I used all options on each app including "search for deleted files" or "search existing partition" etc.

    Here is where I was confused: I have had two computers that happened to have the same name. They were both using Time Machine. The previous machine was formatted in March (that's where the date is coming from). The new machine, was backed up to a .sparseimage file. For whatever reason, I never thought to check the contents of that file. ALL of my files were there.

    Lessons learned: Snow Leopard will not see a .sparseimage file for the restore until you mount the image. Install Snow Leopard and then use Migration Utility to restore from the Time Machine backup AFTER you have mounted the .sparseimage.

    No clue why none of the recovery apps found the files. Maybe they cannot search within those .sparseimage files? What good would that be?!

    Anyhow, all is well. Running Snow Leopard and happy. Oh and before someone comments on where I got SL, consider how many people this could help who try to use the new SL feature "Restore from Time Machine backup".

    Good day.
     
  7. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #7
  8. jimjiminyjim macrumors 6502

    jimjiminyjim

    Joined:
    Feb 24, 2003
    Location:
    Canada
    #8
    Thanks for following up on your problem. There is a glimmer of hope for my situation here. My drive failed about 3 weeks ago... and this is the first glimmer of hope that I would see any files since november, even though there were many backups since then... time machine seems to be discovering the recent files in the mounted image as i'm doing a new backup - though they weren't there just on mounting the image - and this on a brand new hard drive. Fingers crossed!
     
  9. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #9
    Good luck! Keep me posted. I would love to know that I help someone after all of the crap I went through.
     
  10. jimjiminyjim macrumors 6502

    jimjiminyjim

    Joined:
    Feb 24, 2003
    Location:
    Canada
    #10
    Update

    Ok, so thank you! All photos recovered, which was the main object. Work files were mostly old news by now anyway... but still, all there, and pictures of our 1 and 3 year olds from the last 8 months are back. Happy wife, happy life.

    They were not visible on the time machine drive, but they were visible in the disk image. I did have to grab them manually out of the iphoto "package contents" but that was just fine. iPhoto doesn't let you import duplicates anyway, and I don't often modify the photos.

    Sweet.
     
  11. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #11
    I'm glad it worked out for you. I was able to find that if you mount the disk image on a different user account, you can use Migration Assistant to recover the entire user using the Time Machine backups. Without mounting the image it will not show in Migration Assistant.

    Since my first ordeal, the same issue happened (in a different form) with my wife's Macbook. Long story short I was not able to mount the disk image at all. Disk Utility found tons of errors and recommended that I reformat. With a lot of luck I was able to run DiskWarrior. Once it did it's thing it MOUNTS the drives to show you the Preview. Well, that's when I fired up Migration Assistant and was able to completely restore the user 100%.

    As you said, happy wife, happy life. Happy ending to a nightmare.
     
  12. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #12
    Are they encrypted? In any case, because they are compressed in some way at a low level, I presume the data doesnt look like 'normal' files that recovery programs would search for? Maybe.


    Whilst it may very well help a few people in future, how many of those would use TM to back up two computers, with the exact same name (why, too much room for confsuin here IMHO ?) to the same drive using sparseimage disk images? Maybe three?

    There are some very bizarre pronouncements in this thread such as TM wearing out hard drives because the drive is left on all the time!! I wonder if the same poster switches his Mac HD off every few minutes when he isn't using it? As that will obviously be used 100sx more frequently than TM. My TM drive, like most, gets used every hour for a few minutes. I somehow don't see that as a problem of overuse !

    Or "all you need is the last copy of a file you backed up" - oh really? So when I discover a day or two down the line that I need something from within a file I changed a few times, lets say I deleted a couple of pages from a document, then backed that up, overwriting the last backup with those pages in, how will having only the last backup help me?
     
  13. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #13
    Most likely the case. Simply documenting my findings to help someone in the future. Clearly it's already helped someone.

    As mentioned in the initial post, the previous machine had been sold or died. I forget what happened to it to be honest. Yes, having two sparseimages on the drive was not a good idea. As stated in the first post, this thread was not created so those on the outside looking in could tell me what I should or should not have done (because that's all very obvious). I was asking how could I fix what I had screwed up. I found the answer for myself and decided to keep this thread up to date to help someone else.

    Agreed. Assuming that's overuse is quite silly. As well as "all you need is the last copy".

    Repeat: the point of this thread was initially to get some help for myself. Because it was such a strange issue I did not intend I would get that lucky. Sure enough, I didn't. However, I did figure it out and have recovered all my files. I've been working on Snow Leopard as if nothing happened since then.

    Good luck to anyone else that finds themselves stuff with a TM issue whether you brought it on yourself or not!
     
  14. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #14
    Ryan, I think the real lesson is, you had offsite backup. From what you said, you'd have been fine even if you hadn't been able to get back the files from the TM images. Without offsite backup, eventually theft, fire, flood or plain old user screwups* will likely get you in the end. Oh, offsite backups and testing them now and again, which I'll do right now !

    * someone reported here, after deleting the originals, moving backups elsewhere and then deleting them before checking the move went ok!)
     
  15. ryanschmidt thread starter macrumors member

    Joined:
    Aug 20, 2009
    #15
    Yes! You are right. That is the real lesson here. Although I would have lost some movies (200GB) those could be found again. The important files were backed up to backblaze.com. Before I knew the TM backup was OK I started downloading the files from backblaze. As a shameless plug for them, it went flawlessly. Takes a little time because your downloading but the speeds were good and finished over night.
     
  16. TrevorGerzen macrumors newbie

    Joined:
    Oct 7, 2010
    #16
    Just curious...

    How did you have two computers on the same network, with the same name? I'm not being skeptical, I'm honestly curious. Every time I have two computers with the same name, on the same network the OS automatically changes the name of the newer computer to some thing like "same-name-2" thus avoiding the same name issue. Of course, your answer could be that they were never on the same network, at the same time which would be the only way I could see that happening. Just thought I'd ask. Thanks for this thread, by the way. I believe it's going to help me troubleshoot an issue at work right now :)
     
  17. arogge macrumors 65816

    arogge

    Joined:
    Feb 15, 2002
    Location:
    Tatooine
    #17
    This is also another example of why you don't touch a working machine until you have its data secured on a verifiable data volume that is independent of the machine that is being deleted. You don't just decide to reformat a machine in the middle of a job unless there is no other choice. I don't install any software updates, adjust any configurations, or do anything that could cause a problem until I have secured the current job on a disconnected data volume.
     

Share This Page