Time Machine fails to backup - no access to a specific file?

Discussion in 'macOS' started by yegon, Dec 31, 2008.

  1. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #1
    The following error message appears when I attempt backup using TM;

    "You do not have appropriate access privileges to save file “.0019e33d49f6” in folder “Time Machine Backups”.To view or change access privileges, select the item in Finder and choose File > Get Info."

    Spotlight can't locate this file, I've ran disk utility to verify and repair the internal drive, verified the external, no problems on both counts. I even tried allowing read & write privileges temporarily to everyone on both drives, but no luck.

    Any suggestions?

    edit: I notice under sharing and permissions on my root\user\matt (that's me) directory it has 3 users, Matt, Unknown and everyone. I can't change Unknown away from read only, is that normal?
     
  2. yegon thread starter macrumors 68020

    Joined:
    Oct 20, 2007
    #2
    Anyone?

    I'm really having no luck finding a solution to this. I could just treat the external as a new drive and re-backup from afresh (I've got another backup stored elsewhere) but over 300gb will take aaaaaages :-(
     
  3. kubla macrumors newbie

    Joined:
    Nov 13, 2006
    Location:
    Calgary
    #3
    I used Invisibility Toggler to make the offending file visible on the backup drive, deleted the fie, and then retoggled to make the files invisible again.

    It now seems to back up fine.

    You could probably get info on the file and change permissions instead of deleting it, but deleting seems to work.
     
  4. yegon thread starter macrumors 68020

    Joined:
    Oct 20, 2007
    #4
    Cheers, I may try that if it happens again.

    In the end, I just erased the disk and created a fresh backup from scratch and left it going overnight.
     
  5. steffi macrumors 6502a

    Joined:
    Jun 7, 2003
    #5
    In my case I'm switching back to an older Time Machine backup so I suspect this is done deliberately otherwise the FSEvents aren't in sync with the older backup so a lot will be missed. I think Apple wants you to backup from scratch when this event happens.

     
  6. late show macrumors member

    Joined:
    Nov 13, 2008
  7. lostngone macrumors demi-god

    lostngone

    Joined:
    Aug 11, 2003
    Location:
    Anchorage
    #7
    I ran into this same problem a couple of days ago as well.

    I just did a chmod 777 on the file and then TM started working.
     
  8. late show macrumors member

    Joined:
    Nov 13, 2008
    #8
    maybe better to chmod....I used my post above (which is perhaps too aggressive, and had some hanging issues...did a repair disk after starting off the install DVD...cleared it up...
     
  9. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan

Share This Page