Time Machine = Hot Garbage now?

Discussion in 'Mac Apps and Mac App Store' started by jclardy, Nov 30, 2016.

  1. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #1
    Running OS X Sierra, on a new 13" touchbar MBP. Nothing crazy, just installed my software and dev tools. Clean setup, no restoring from backup. Have a new hard drive, created a HFS+ partition of 2TB just for time machine. Excluded a few caches/xcode derived data folders. Start backup and it freezes at some point in the process. Hard drive is still responsive, I can view the time machine partition or even the other partition (also HFS+) Time Machine just decides to give up. Tried it twice now, reformatting the drive in between. Is there some place to look for errors from time machine? I ran first aid on my MBP's internal drive and of course, no errors as it is only a week old. The service isn't dying, it just gets to a specific amount of data then stops. The time remaining doesn't update (has said 24 minutes remaining after writing 97.46GB for the last hour, last time it wrote 170GB before stopping.)

    Is it time I give up on time machine? What other backup software are you guys using for your Macs? I'm looking for something I can use as a fast, local backup (that will be moved wirelessly to be connected to a Mac mini once the initial backup is setup.)
     
  2. Winterfibre macrumors regular

    Joined:
    Nov 30, 2016
  3. bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #3
    I am still using Time Machine. Love it but it does occasionally it gets hung up for me.

    Log files go to

    ../Backups.backupdb/COMPYNAME/Latest/.Backup.log

    or

    ../Backups.backupdb/COMPYNAME/YYYY-MM-DD-HHMMSS.inProgress/.BackupXXX.log

    or you can use

    sudo syslog | grep -i backupd



    I have NOT used Time Machine all with Sierra, but 10.6, 10.9 and 10.11 I have used the following to fix the occasional hang up or slowdown:

    1) Boot safe mode then boot normal

    If that does not work next I hit it with

    2) Boot single user mode, and remove /.fseventsd/ boot normal and run Time Machine backup but be prepared for a long one after removing .fseventsd as every file has to be compared.
     
  4. GerritV macrumors 65816

    Joined:
    May 11, 2012
    #4
    I'm a long time user of Chronosync.
    Tried TimeMachine when it was new, but on the two occasions I needed it, it failed on me.
    Like most of Apple, TimeMachine is kind of dumbed down. I prefer Chronosync's professional approach and very responsive support.
     
  5. oulipo macrumors newbie

    Joined:
    Apr 23, 2014
    #5
     
  6. oulipo macrumors newbie

    Joined:
    Apr 23, 2014
    #6
    With Sierra 10.12.2, my Time Machine has failed. I am not sure why; the logs point to failure in backupd but the specific cause has remained elusive. I suspected that there was an issue with Spotlight, that TM was hanging as it waited for a Spotlight process to complete and if, as I had, more than one internal volume, a full accounting could be more likely to be disrupted. Issues related to permissions, file types, etc. are probably not material,

    I was further curious if doing a fresh install of 10.12.2 would improve matters, or at least make TM update to the designated drive as expected. FWIW, the drive is a 2TB unencrypted external HD, though using a larger or smaller or encrypted or internal volume does not seem to matter. In the latest iteration, after having forced many full indexing, having erased, too, .Spotlight-V100 and so on, TM will in fact do a full copy then act as expected once, even twice, but then crash, crash again, crash yet more and so on.

    I speculate that this evident bug relates to Apple's move to its new but not yet implemented Apple File System, but I this is a speculation and I have no evidence. Could also relate to other new characteristics of Sierra and their intersection with legacy attributes.

    Fortunately, it's also not a fatal issue, though it is distracting. I do use Carbon Copy Cloner now for system backups, but also have taken to locating kinds of files in various clouds and repositories. Eg, I keep most of my working text and collaboration documents in my Google accounts, a lot of texts in Mega, photos, music, with iCloud, and so on.

    I tried ChronoSync and recommend it for a couple of reasons. It's reasonably fast, it produces accessible backups, it is even reasonably priced. It's options are a little annoying, but an ounce of patience will do the trick. The other backup systems Wikipedia details, are fine but don't add anything to what is present with ChronoSync and most lack it's virtues. Crashplan is free, does have a few interesting qualities, but it is unusably slow: a backup of a fairly small volume could take days, and that would be to a local not remote box.

    I'm guessing that by the time 10.12.2 is GM, much of these issues with the TM I and others, it seems, have been encountering, will be history. That would be good: I've spent a lot of time mired in logs, and though I do find this sort of stuff interesting, other things are more interesting.
     
  7. Ianbuckley macrumors newbie

    Joined:
    May 5, 2013
    #7
  8. steve23094 macrumors 68020

    steve23094

    Joined:
    Apr 23, 2013
  9. gr2020 macrumors member

    Joined:
    Oct 31, 2014
    Location:
    Colorado
    #9
    I realize this isn't helpful for those having problems, but just for a data point - I'm having no issues (yet?) with Time Machine and Sierra. Both on a new 2016 MBP (13 TB), and on a 2014 5K iMac. I've even had to restore the iMac from Time Machine once since upgrading to Sierra due to an unrelated problem, and the restore went fine as well.

    In both cases, it's backing up over the LAN (wifi for the MBP, wired for the iMac) to a Time Capsule.
     
  10. Chrystal Ocean macrumors member

    Joined:
    Sep 3, 2007
    Location:
    Vancouver Island, Canada
    #10
    In reading about these backup issues, I'd been wondering whether anyone using a Time Capsule was also affected. I use a Time Capsule for backups and arriving here next week is a 2016 MBP TB 13". Your comment, therefore, is appreciated.
     
  11. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #11
    It looks like its a problem in Sierra. See the Apple discussions thread below, some users report they have contact with Apple engineers who are investigating the problem. Some users report they solved the problem by downgrading to El Capitan. A clean install of Sierra does not help.
    https://discussions.apple.com/thread/7677444?start=0&tstart=0

    Hopefully Apple will solve this soon.

    In the meanwhile I have switched to Carbon Copy Cloner for my backups, as I can't get Time Machine to work correctly, despite following a lot of suggestions from other users.
    And some more links to webpages about Time Machine problems in Sierra:
    http://elcapitanslow.com/fix-time-machine-problems-mac-os-sierra/
    https://eclecticlight.co/2016/11/23/time-machine-problems-in-macos-sierra/
    http://blog.macsales.com/38608-common-problems-after-installing-macos-sierra-and-how-to-fix-them
     
  12. jmebbk macrumors regular

    Joined:
    Nov 20, 2013
    #12
    So what's the best program to back up my Mac?
    I've just bought a LaCie hardrivre to back stuff up....?
     
  13. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #13
    There are several good programs. I myself use Carbon Copy Cloner, it turns out to be a very nice program. An advantage is that you can make a bootable backup: when something happens with your internal HD, you can boot from the backup drive and resume working. With Carbon Copy Cloner you can also retrieve files you accidently deleted (just like Time Machine).
     
  14. JanDdd macrumors newbie

    Joined:
    Nov 16, 2014
    #14
    Just a tip: Sophos Antivirus on-access scanning seems to stall the Time Machine backups on Sierra. I disabled the on-acces scanning to get Time Machine backups working.
     
  15. Les Kern macrumors 68040

    Les Kern

    Joined:
    Apr 26, 2002
    Location:
    Alabama
    #15
    Too many failures with Time Machine, so went with archiving option with Carbon Copy Cloner. across the board. Has never failed since I started using it a decade ago.
     
  16. dmblue macrumors member

    Joined:
    Jun 18, 2008
    #16
    I was having huge issues with Time machine backing up to NAS and USB drives. Since the last update it has solved every single issue I had. I cant say it will work for everybody, but so far I am back in business.
     

Share This Page