Time Machine Lion Lockup problem

Discussion in 'Mac OS X Lion (10.7)' started by greyparrot, Aug 2, 2011.

  1. greyparrot macrumors newbie

    Jul 22, 2011
    I installed Lion on my 2009 MBP on the 1st day it was available. Since then every day Lion locks up at least once a day. The mouse would move and I could activate some menus but nothing worked. The only way I could exit was to hold the power button down until it shuts off. This happened with various apps and the only thing that was common to all lockups was that the Time Machine icon was rotating and I assume it was active. I tried waiting until the TM completed but it didn't stop after a very long time so I don't think it was actually working.
    I have now shut off the TM and disconnected it and I have had no lockups since. I'm sure Apple has a bug in Lion effecting the TM and I hope they solve it soon. Otherwise I like Lion but some features take time to get used to.
  2. Cheule macrumors member

    Mar 28, 2009
    Under Lion, what I've noticed is that any heavy disk I/O causes cursor pinwheels and extremely slow OS response. Time Machine, MobileMe syncing and anything that hammers the HD can cause this.

    I assume a patch will be in the works, because under Lion, the system does become unresponsive until the heavy disk I/O is finished, whereas under Snow Leopard the same tasks didn't grind the system to a halt.

    Your solution of turning off Time Machine isn't really a fix, because anything that accesses the disk a lot will cause this. It's not a bug exclusive to Time Machine.
  3. greyparrot, Aug 3, 2011
    Last edited: Aug 3, 2011

    greyparrot thread starter macrumors newbie

    Jul 22, 2011
    The rotating icon I was referring to is the TM icon on the toolbar at the top of the screen. I'm not getting the cursor pinwheel. I get the arrow cursor and I can activate menus but when I select something nothing happens. If a app freezes and I click it's icon on the dock and click on force quit nothing happens.
    Disconnecting TM is temporary while I do important things then I turn it back on so it can backup recent changes.
  4. zipper77 macrumors newbie

    Sep 3, 2009
    I've been having the same problem. I really hope a fix is in the works on Apple's side.
  5. purincess macrumors newbie

    Aug 16, 2011
    TM Freezes Up

    I've been having the same issue ever since I upgraded to Lion. Time Machine freezes up mid-way. Super annoying!!!
  6. purincess macrumors newbie

    Aug 16, 2011
    Issue Fixed!

    I uninstalled Sophos Antivirus (I didn't even realize I had it), which continuously scans the system and slows Time Machine down. Now everything works just fine. Yay!!!!
  7. zbeckman macrumors newbie

    Apr 24, 2005
    Same problem... 2-3 times a day

    Having the same issues here, 10.7.2 hasn't fixed the problem.

    I'm suspecting that Time Machine is making the situation worse, but turning it off (and disconnecting the drive) does NOT solve the problem. It just goes a little longer in-between system lockups. Same symptoms... apps become unresponsive, one after the other starts to beach ball, eventually the whole system locks up.

    Usually, when I see it start to happen, I try to open up Terminal and run a 'shutdown -r now' but... most often I can't even open up Terminal. I've taken to launching it (hidden) on login, so it's always there and I can switch over to it. Otherwise, I spend 20 minutes trying to get a shutdown and restart...
  8. tychoD macrumors newbie

    Nov 30, 2011
    Same problem

    I'm having the same problem, the computer locks up at various times and with different applications. One common thread is that Time Machine seems to be searching for the backup drive, in my case a Time Capsule on the Time Capsule's wireless network.

    I'm going to start turning off things in this order:
    1. Time Machine
    2. Logitech Control Center
    3. Sophos Anti-Virus
    If any of these steps help I'll leave a followup message here.
  9. jdacu macrumors newbie

    Feb 15, 2012
    Same here

    I also have the same problem, applications become unresponsive one after the other until the whole system freezes and I have to turn the laptop off.

    I also have Sophos antivirus installed, although I don't have any reason to think it is related to this problem.

    The last message shown in the logs is:

    2/15/12 10:39:11.837 AM com.apple.backupd: Starting standard backup
    2/15/12 10:39:13.000 AM kernel: nspace-handler-set-snapshot-time: 1329331155

    Although it does not freezes every time that it tries to make a backup.

    Do these messages also appear on your logs as the last messages before rebooting? Does anyone have found a solution?
  10. wnorris, Feb 16, 2012
    Last edited: Feb 16, 2012

    wnorris macrumors member


    Feb 16, 2008
    Sophos is most likely your problem. You will need to add two items into your Sophos exception list.

    1) Time Machine Drive

    2) ./MobileBackups (you can drag and drop this folder into your Sophos exception list)

    Try this thread in the Sophos forum for a somewhat decent explanation:


    It is mentioned that in an upcoming version (8, I believe) this issue will be resolved without the need for a workaround.

    This resolved the issue for me. Good luck.
  11. jdacu macrumors newbie

    Feb 15, 2012
    Thanks for the reply!, I'll give it a try and see if it works.
  12. PServe macrumors newbie

    Mar 5, 2012
    I had the issue with an iMac 12,2 freezing up with time machine on 10.7.3. I found the culprit to be MobileMe being turned on in system preferences after the account was upgraded to iCloud. The iDisk icon was still showing on the desktop. as soon as I turned off MobileMe the iDisk icon disappeared and the computer has been running good for 4 days straight and time machine has been working good also. Not sure if this helps but thought I'd post my solution.

Share This Page