Time machine missing "Pictures"

Discussion in 'macOS' started by fhall1, Feb 6, 2015.

  1. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #1
    Running OS X 10.9.5 on 2012 Mac Mini.

    Yesterday I was editing some old photos stored in user/Pictures with a third party utility, and messed one up and ended up saving it over the original.

    No problem I thought - I use Time Machine (have for years) - so I'll just open it up and restore the original photo.

    Imagine my surprise when I opened the most recent TM backup and there were only 40 objects in the Pictures folder. There should have been 337 - and the photo I wanted wasn't one of the forty.

    So - I started going back in time and I have to go all the way back to something like Oct 14th 2014 where the Pictures folder had over 300 objects in it. The TM backup from Oct 21st 2014 only had 30 objects. Skimming forward in time from Oct 2014 until today, the Pictures folder TM backup contains between 30 and 40 items.

    Any idea what happened, (maybe I upgraded from 10.9.4 to 10.9.5 in Oct???), and more important how to get TM to start backing up all my Pictures again?

    I'll have to check other folders too - like documents, to see if that's being backed up properly. Sheesh....I've never had issues with TM in all the years I've been using it until this.
     
  2. Bomb Bloke macrumors regular

    Bomb Bloke

    Joined:
    Feb 12, 2015
    Location:
    Tasmania (AU)
    #2
    It's possible someone attempted to manually remove some files from the backup, corrupting it - more likely (and hopefully), however, it's something in your exclusion settings.
     
  3. fhall1 thread starter macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #3
    Thanks for replying, but that's not it. The only people in the house are my wife and myself. She has a Windows PC and doesn't log into my Mac, that leaves me, and I didn't do any manual messing with TM.

    I outlined what I did to finally fix it here:
    http://cnygeek.blogspot.com/2015/02/os-x-1095-time-machine-backups-missing.html

    Of course it still doesn't help with why it happened in the first place.
     

Share This Page