Time Machine + NAS = FAIL

Discussion in 'Mac Accessories' started by jsbarone, Mar 7, 2008.

  1. jsbarone macrumors regular

    Joined:
    May 8, 2007
    #1
    Hopefully someone can help me with my NAS situation. I'd done a ton of reading, and still can't get Time Machine to back up to my NAS. I'll detail what I did, and the errors I got in hopes that someone can help me, or at least learn from my experience.

    I bought an External Enclosure for my 500GB SATA Seagate Hard Drive so that I could do network Time Machine backups. I didn't do much research because I remembered reading that NAS Backups worked in Leopard. I set it up and formatted it with the little web gui that comes on the NAS, and it formatted it as a 476g FAT32 Partition. There was no AFP option. I attached to it with the finder and copied some files to it. It worked. I then made a TMBACKUP folder on it for time machine backups, shared that out and went into Time Machine to specify the disk. I didn't see it. After a little research I discovered this handy little piece of code that enables unsupported drives:

    Code:
    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1
    I stuck that in terminal and hit enter, and upon checking disks in Time Machine again my drive was there. Yay. I chose the disk and told time machine to back up now. Then it hit me with this error:

    I did some googling on that error message, which lead me to this and this

    Basically the operation that I needed to try (according to both links) was to create a new sparsed image for Time Machine and name it what it had tried to name the sparse image it created. I did it, with these settings:

    [my computer name]_[my mac address].sparsebundle
    Volume Name: Disk Image
    Volume Size: Custom 293GB
    Volume Format: Mac OS Extended (Journaled)
    Encryption: None
    Partitions: No Partition Map
    Image Format: sparse bundle disk image

    It's about 140mb in size. I create it, delete the old sparse bundle from the TMBACKUPS folder that time machine created, copy this one over and try to backup again.

    It sits at "Preparing..." for a minute and then it actually starts copying data over. It gets 180MB into the backup and I get this:

    I check the log and get:

    Code:
    ar  7 14:27:00 Macbook /System/Library/CoreServices/backupd[234]: Error: (-36) copying /Applications/Dictionary.app/Contents/Resources/Dictionary.icns to /Volumes/Disk Image/Backups.backupdb/Macbook/2008-03-07-142241.inProgress/54C1E532-1C20-42FD-8424-3FC50C2C97CD/Macintosh HD/Applications/Dictionary.app/Contents/Resources
    Mar  7 14:27:00 Macbook /System/Library/CoreServices/backupd[234]: Canceling backup.
    Mar  7 14:27:00 Macbook /System/Library/CoreServices/backupd[234]: Error: (-8062) copying /Applications/Dictionary.app/Contents/Resources/Dictionary.icns to /Volumes/Disk Image/Backups.backupdb/Macbook/2008-03-07-142241.inProgress/54C1E532-1C20-42FD-8424-3FC50C2C97CD/Macintosh HD/Applications/Dictionary.app/Contents/Resources
    Mar  7 14:27:01 Macbook /System/Library/CoreServices/backupd[234]: Copied 16 files (181.4 MB) from volume Macintosh HD.
    Mar  7 14:27:01 Macbook /System/Library/CoreServices/backupd[234]: Copy stage failed with error:11
    Mar  7 14:27:01 Macbook /System/Library/CoreServices/backupd[234]: Backup failed with error: 11
    Mar  7 14:28:03 Macbook mds[21]: (Error) LSOF: File '/Volumes/Disk Image/Backups.backupdb' (fd=30) left open on device 234881028
    Mar  7 14:28:03 Macbook mds[21]: (Error) LSOF: File '/Volumes/Disk Image/Backups.backupdb' (fd=64) left open on device 234881028
    Mar  7 14:30:03 Macbook /System/Library/CoreServices/backupd[234]: Attempt to eject diskimage failed with status: -47, dissenting pid: 0
    Mar  7 14:32:36 Macbook sudo[286]: jsbarone : TTY=ttys000 ; PWD=/Users/jsbarone ; USER=root ; COMMAND=/usr/bin/grep backupd /var/log/system.log
    
    That's where I'm at now---stumped. Can anyone help?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Currently the only NAS supported is Time Capsule.

    TEG
     
  3. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #3
    I know nothing whatever about coding, but I presume that your apparent random substitution of "spare" for "sparse" may not be helping...
     
  4. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #4
    autocorrect ftw...it was sparse when I typed it. thanks for pointing that out
     
  5. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #5
    success?

    Too early to say for sure, but I *might* have made some headway here. That last error message that I posted up there got me thinking...the NAS box was doing the drive formatting---could it be the problem? With that in mind, I connected to the NAS via USB and formatted the drive as FAT with Disk Utility in Leopard. I made the sparse file, copied it over and tried backing up...so far so good! it's almost at a gig which is WAY more than it did before. We've got a long way to go before it does a full backup but preliminary results are promising.
     
  6. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #6
    Nevermind. It ended up erroring out too. After that I formatted the disk at OSX Journaled and made a new sparse image on that. I did the full backup to it, copied it onto my mac hard drive, then formatted the external drive back to fat, copied it back and tried the time machine backup. It worked, but only for very short backups. I tried backing up my music---12gb, and about 1gb in it failed with the same error. I am so frustrated! Can anyone help?
     
  7. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #7
    This is the correct answer. Everything else "works" via hack, so your milage may vary.
     
  8. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
    #8
    Here's a thread from a while back.

    http://forums.macrumors.com/showthread.php?t=390245&highlight=ReadyNAS

    I'm not sure how your mounting the share.

    In order for me to get it to work, I had time machine mount an external disk that was partitioned with GUID already. It created the spare image files. I just copied those files to the NAS and named the mount and directory names the same as my external disk.

    Everytime I mount the share, time machine kicks in and runs.

    I've heard that there aren't any issues with the backups until you fill the disk. That's when the Time Machine corruption happens. Until then it works well.

    I was hoping for the solution when they released Time Capsule, but I'm not sure if anyone has tested it yet.
     
  9. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #9
    GUID huh? Last time I checked, my drive is using MBR. I will try that next. Thanks for the suggestion.

    Also (for you two above), I think we all understand that this isn't a supported feature. You're not being helpful by stating the obvious.
     
  10. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #10
    You can get NAS to work but you'd need to edit some text files to change the defaults. But TM will never work on a FAT file system. TM depends on some tricks that only HFS+ has.
     
  11. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #11
    Lots of other people have it working on FAT....very few NAS drives support AFP/HFS.

    I'm still not making any progress. Even mounting to the drive and just copying/moving files over, they show up for a split second and then dissapear. They'll fully copy over, but when I try to use them they're nowhere to be found. If I try to copy the file over again, it sees that it's there and asks me if I want to replace. Anyone have some help on that?
     
  12. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #12
    More info about this problem...it may be something with the way that Leopard handles SMB shares, because when copying or moving data there it will get interrupted. Also, sometimes the stuff is missing (like I mentioned before).

    Trouble is, if I mount and copy/move those same files from XP, it works fine. Everybody plays nicely---no missing stuff, no interruption.
     
  13. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #13
    It would appear that I'm mostly having a conversation with myself...anyone able to help here?
     
  14. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #14
    Bumping this up because nobody has responded. I'm still trying to get this working---can anyone help? I can't even copy the sparse image to the windows share now---I get "Error code -1407".
     
  15. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #15
    This here is the weirdest part...

    Take NAS Drive, format it with NAS OS (Fat32), copy over created sparse image but it fails, attempt to copy over again and it asks if I want to replace the existing one, but nothing shows up....
    Code:
    defaults write com.apple.finder AppleShowAllFiles TRUE
    killall Finder
    nothing there...

    restart into bootcamp and tahdah, theres the sparse file with some corrupt ascii blocks at the end of it.

    Why on earth is OSX not able to see the files but Windows is?
     
  16. jsbarone thread starter macrumors regular

    Joined:
    May 8, 2007
    #16
    This will be my last post to this thread, and quite possibly the forum. I'm very disappointed that despite my strong effort to provide as much documentation and troubleshooting as I could, I have not gotten more than a few responses to this thread, only 1 or 2 of which were actually useful. I keep providing more information and keep getting ignored. Thanks for nothing.
     
  17. maxp1 macrumors regular

    Joined:
    Feb 12, 2005
    #17
    Hey, it's not that people are ignoring you, it's just that apparently nobody has helpful advice. I don't think there are a lot of people who are trying to do what you're doing with your specific hardware. You might see if there's a forum for this kind of thing at the hardware manufactures site.
     
  18. digitalfrog macrumors regular

    digitalfrog

    Joined:
    Nov 26, 2007
    #18
    I'm planning on doing the exact same thing. I have not started it yet, so this thread is already a great help for me and others. Sorry your are the biggest contributor, but you are helping out other people like me.

    I will contribute to this thread if I find a solution myself, getting to work ... now !
     
  19. The Sun King macrumors newbie

    Joined:
    Mar 21, 2008
    #19
    IF you haven't seen it, check out this thread:
    http://forums.macrumors.com/showthread.php?t=439304

    I just setup a NSLU2 with a 400GB disk attached, and except for access speed (~2.5MB/sec for the NSLU2) it works fine.

    The disk is formatted on the NAS as ext3, and shared via samba. Your NAS's disk format doesn't matter as long as it can read and share it using samba. So for Windows hosts use NTFS. For Linux hosts use ext2, ext3, riserfs, jfs, xfs (I would use a quick journaled fs). For a OSX host use HFS+. However for FAT32 I believe the maximum partition size is 32GB, and the maximum file size is 4GB -2. You will definitely have problems writing using Time Machine if you hit the 4GB limit on FAT32.

    I also had to create my sparse image on a local disk and copy it over. Direct creation on the samba share resulted in an OSX error. Just follow the steps first part of the other thread. Although it didn't say, I created the image as a single partition using HFS+. Time Machine will check and mount the sparse image on the samba share and store everything there.

    As far as Samba (SMB), Apple Talk (AFP), or NFS shares, it shouldn't matter. Time machine will be limited to the share's user, and meta data ONLY while accessing the sparse image file itself, and that doesn't matter. Once the sparse image is mounted by Time Machine, everything looks like HFS+.

    There is also the issue of users on the samba share. Starting out, I wouldn't bother with creating a Time Machine user and mounting the samba share with that account. Just pick a user on the share that already has read/write and either no disk quota, or enough for our sparse image size. You can figure automounts and users once you get Time machine working.

    Anyway, that's my ramble, hope it helps.

    Ok after looking into the NAS stuff over the Weekend, I did make a couple mistakes above. I'm still getting used to OSX; I've only been using it for the past two months, before that the last apple machine I used was an Apple IIc. Although Finder shows a sparse bundle as a container (like a zip) it's just a directory that Finder doesn't really show you.

    I have also just tried setting up a Qnap 409 Pro for Time Machine backups. It works about the same as the NSLU2 but I have run into the "Disappearing Files" issue when accessing it through Samba (search for it in the qnap forums). The odd thing is that initially everything worked fine until I started changing share permissions. I switched to using AFP to access the NAS, and so far no problems.

    To be clear, by NSLU2 (using openslug and Gentoo) worked with Time Machine on the first try. The Qnap started out with Samba and was eventually switched to using AFP and now has no problems.
     

Share This Page