Time Machine Not Backing Up /Applications

Discussion in 'Mac Basics and Help' started by tinix, Nov 8, 2013.

  1. tinix macrumors newbie

    Joined:
    Jun 14, 2013
    #1
    So after multiple drive switches my Time Machine suddenly stopped backing up system folders. I looked into /Library/Preferences/com.apple.TimeMachine.plist and indeed there is under ExcludedByPath /Applications, /System and so on. I have tried deleting it however the time machine always restores the exclusion path. I have tried copying it to desktop and removing exlude by path value but it still got restored to original value. Any ideas on how to fix this ?
     
  2. 2trout macrumors member

    Joined:
    Nov 2, 2013
    #2
    I had kind of a similar problem, the HD I use for TimeMachine was no longer recognized.
    In the end, I deleted the partition on the Time Machine HD, re partitioned it and that fixed the problem.
    Yes, you will loose your existing backup, but unless you've had major changes since the last backup, that should not matter at all.
     
  3. tinix thread starter macrumors newbie

    Joined:
    Jun 14, 2013
    #3
    The drive is recognized and time machines backs up /Users . I have tried reformating the drive but to no avail.
     
  4. Bruno09, Nov 9, 2013
    Last edited: Nov 9, 2013

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
  5. tinix thread starter macrumors newbie

    Joined:
    Jun 14, 2013
    #5
    Actually I am running Mavericks now; I saw that article and tried do the reset but it did not work the time machine would always reload the plist from somewhere.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    The problem is Mavericks caches plist files now. So if you make a change or delete the cached version will reappear. You need to reset Time Machine as described in that link, but reboot after you make the plist change to the cached plist does not replace the one you deleted.
     
  7. tinix thread starter macrumors newbie

    Joined:
    Jun 14, 2013
    #7
    Oh thank you, thank you, thank you. It worked like charm.
     
  8. Tumbleweed666 macrumors 68000

    Tumbleweed666

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #8

    Ah, well that at least explains my corrupted TM backup and why I couldn't restore from it ! Thanks.

    When I looked into the TM backup when it wasnt recognised as a valid source, there was no applications folder from a date sometime in October and onwards. Pretty sure that applications were not shown as excluded in the options list when I looked.

    Was able to recover as I had both a clone of my whole HD and the original machine, but shows that taking a copy of the TM disk itself isnt backup, you should backup from at least two independent sources.
     

Share This Page