Time machine not doing backups ....

Discussion in 'macOS' started by aduteau, Dec 30, 2008.

  1. aduteau macrumors 6502a

    Joined:
    Oct 14, 2007
    #1
    Hi guys, here is my problem, I have an Imac 24" and a Mybook external HDD.
    Ever since Leopard came out Ive been doing backups with time machine, then ... one day .. I start time machine for my weekly backup .. and this message comes up: "Unable to complete backup. An error occurred while copying files to the backup volume."

    Now I notice that my external HDD was almost not spinning while time machine was trying to backup ... the status bar of time machine saying how much files need to be copied and the total amount of space needed was super slow .... and stoped at something like maybe 10 mb ...

    I started time machine again ... same message.

    I though maybe Mac OSX needed some permission repaires. So I did just that and after that did time machine again ... same problem ....

    Then I said to myself ... maybe my External HDD has problems ... so I even formated the HDD, then stated Time machine again ... this time it was running smoothly just like before I had the problem ... but the problem came back after 6 gig being copied out of the 25 gig needed to complete the backup process.

    Now ... I hope I dont need a clean install of my Mac OSX ... or maybe its my external HDD ... maybe my USB having problems ???

    Im out of ideas guys ... please help me out.
     
  2. emptyCup macrumors 65816

    emptyCup

    Joined:
    Jan 5, 2005
    #2
    First, restart your iMac. Next, verify your internal drive with Disk Utility. If it is okay, verify your TM drive. If that is okay, try running Back Up Now from the TM Menuling. Let us know how it goes.
     
  3. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #3
    This has been discussed in a number of places and I wonder if there are a number of separate problems. The one that fixed it for me was a permissions issue on the /.Spotlight file. Here's the post from the other thread:

    --
    It turns out that my version of this problem actually pre-dated 10.5.6 (my last backup was 12/12). Anyway, I finally got Time Machine running again.

    The last entry details what worked for me:
    http://forums.macrumors.com/archive/index.php/t-438148.html

    Once I got through all of that it backed up about 5G immediately and then another 2G after that. Now it's running fine.

    There was clearly an issue with the permissions of the /.Spotlight file. I couldn't "Get Info" on it -- but i could delete the whole thing.

    I'm not an expert by any means but this did work for me. And, while it's in this thread, this Time Machine problem probably wasn't specific to 10.5.6. A friend that is having the same problem confirmed he's still on 10.5.5.
    --

    Good luck
     
  4. lostngone macrumors demi-god

    lostngone

    Joined:
    Aug 11, 2003
    Location:
    Anchorage
    #4
    You might want to look at this, it helped me find a group of corrupt mpeg files causing my Time Machine to stall out.

    http://www.macosxhints.com/article.php?story=20071201084525895&query=startup

    Edit: All I did was wait for Time Machine to stall and then I launched Interments and waited for backupd to respawn after timing out on on of the files and go on to the next corrupt file.
     
  5. aduteau thread starter macrumors 6502a

    Joined:
    Oct 14, 2007
    #5
    How do I get that "instrument" program ?... or how do I launch Interments ?? I am kind of new on the Mac OS X
     
  6. lostngone macrumors demi-god

    lostngone

    Joined:
    Aug 11, 2003
    Location:
    Anchorage
    #6
    First sign up for a online ADC account on-line, don't worry it is free.
    https://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/promo?source=ADCLOG&code=ADCLOG-NEX

    Then after that you could be able to go back to that site and navigate to downloads and look for Xcode and download it. It is kinda big.

    It will install the developers tools on the root of your HD.
     
  7. simaomm macrumors newbie

    Joined:
    Dec 16, 2008
    #7
    I am also having a problem with time machine.

    TM stops after a few GBs of data.

    I tried:

    Disk Utility -> Repair Disk with my internal and external HDD.
    Disk Utility -> Repair Permissions with my internal and external HDD.
    Added my external disk to the spotlight exclusions
    I tried deleting /.Spotlight
    I tried other external hdd
    I reformatted my external HDD to use GUID several times

    I ran out of ideas.

    Any suggestions?

    Thank you.
     
  8. simaomm macrumors newbie

    Joined:
    Dec 16, 2008
    #8
    Well, I managed to solve my issue.

    The problem was I had both disks using GUID and not MBR.

    I know apple says we should use GUID, but it simply doesn't work.

    I think it's because the SATA controllers of my external hdds don't play nice with GUID.

    So the solution was to format the disk and choose MBR instead of GUID.

    Everything works fine now.
     

Share This Page