Time Machine on network drive?

Discussion in 'OS X Mavericks (10.9)' started by jmmo20, Oct 30, 2013.

  1. jmmo20 macrumors 65816

    Jun 15, 2006
    Is this a bug? I want to create a new time machine backup in my Mac Mini server and the shared drives are not showing anymore in Time machine pref panel?

    It must be.. it was working perfect in 10.8.

    Edit 10 minutes later..
    OMG!!! I can't believe Apple's ineptitude in this.

    So basically I read online just a moment ago that Apple decided to give up on the AFP protocol in Mavericks and use SMB2. So I remembered that back in the day when I tried to use a time machine destination on a WINDOWS shared drive, it wouldn't show up as a valid destination.

    So I checked on my server and voila!! I could see that Mavericks was actually sharing my drives over SMB and not AFP (you can see the number of connected clients).

    I made an experiment: turn off file sharing, turned it back on, DISABLE SMB and only allow AFP. On my laptop I remounted the shared drive and.. as suspected.. my shared drive now shows up as a valid destination drive.

    I repeat: so much for the freaking "it just works".
    So Apple decides to scrap AFP and turn SMB on by default but... time machine doesn't work over smb!!!

    :mad: :confused: :eek:

    I'm speechless.
  2. jmmo20 thread starter macrumors 65816

    Jun 15, 2006
    does nobody use time machine over a network drive?
  3. whsbuss macrumors 68040


    May 4, 2010
    SE Penna.
    Yes I do. Have a MyBook Live NAS and after their latest firmware update my TM backup is working just fine. I did have to delete the previous backup and create a new one.
  4. snarfquest macrumors regular

    Jun 7, 2013
    I use Timemachine in Mavericks to a network drive on my Mavericks Server 3.0 over AFP. No problem at all.

    I've not seen anything saying Apple has abandoned AFP. Do you have a link to this info?
  5. haravikk macrumors 65816

    May 1, 2005
    Have you tried enabling unsupported network volumes? This should allow you to set just about any shared drive as a Time Machine target, which is fine since Time Machine uses a bit of disk image trickery behind the scenes anyway, so it doesn't really matter what protocol you're using.

    SMB2 may even be faster than AFP, though I dunno about stability; I'm not clear on why Apple is so restrictive with network volumes and Time Machine.
  6. jmmo20 thread starter macrumors 65816

    Jun 15, 2006
    but it worked in 10.8 why has it stopped working now?
    I know how to enable unsoported network drives, but that's not the point...



    Just try it, go to sharing, enable both AFP and SMB.
    now connect from a network computer and find which one OSX is using..

    always SMB unless SMB is disabled in which case it uses AFP.
  7. haravikk macrumors 65816

    May 1, 2005
    Because Apple's decided that SMB2 is now the default file sharing protocol, which is fair enough I suppose as it's better supported by Windows and Linux.

    But for some reason they didn't remove the restriction on which volumes Time Machine can select, so it's still only letting you select AFP shares.

    If you enable only AFP sharing, select the drive for Time Machine on your other computer(s), then re-enable SMB, then Time Machine should work just fine, mounting the AFP share as require.

    I mean yeah it's a complete hassle, and it really depends what your network's like; if you're using all Macs anyway then you can easily just switch back to AFP again.

    Otherwise if you have other OSes then it probably is better to adopt SMB2 as Apple is suggesting, but in that case I think the better solution is to enable unsupported volumes, rather than enabling both AFP and SMB, as that way you've only got one file sharing protocol in use.

    As an additional note, if you've got a machine sharing files with both AFP and SMB, then you force the use of AFP by using the connect to server command in the Finder, and entering an address such as afp://Haravikks-iMac.local as this will force OS X to connect via AFP rather than defaulting to SMB.

    Ultimately though, Apple really need to allow Time Machine to recognise SMB shares as a supported network volume, but for now enabling unsupported network volumes or forcing the use of AFP on all machines again are the only choices really.
  8. jmmo20 thread starter macrumors 65816

    Jun 15, 2006
    Let me rephrase, I know WHY Time machine is not working, and I reflect that on the edit on my first comment.

    I'm asking a rhetorical question to Apple: so they decided to switch over to SMB2 but "forgot" (???) that Time Machine over SMB2 is not supported?

    One step forward and 10 backwards because we've gone back to the very early days of Time Machine.. when we had to tinker with the OS to allow backup to anything that wasn't a local drive.

  9. Zoshchenko macrumors newbie

    Dec 6, 2013
    Time Machine on Mavericks Server

    Check this URL:


    I have a Mavericks server and another running without the server. The server now has a Time Machine service that let's you create a centralized location (on an external disk) to keep time machine backups of all your Macs. The issue is that Time Machine uses Bonjour, so if I understand the mechanism correctly, the multicast DNS and associated port used to locate the share needs to be available, which is not the case with simply using AFP or SMB. So, using the Server version for $20 or so is well worth it to get Mavericks to use this new feature. Simply create the share, give permissions as needed, and enable and configure the TM service on the server, then go to the other Macs, turn on time machine and you'll see the new share automatically. No sudo commands, no fuss, no nada else.
  10. razorme macrumors regular


    Jul 16, 2002
    Calgary, AB
    I agree fully. I was having trouble with an existing time machine network backup set up pre-Mavericks and removed the network volume as part of troubleshooting. Then I couldn't add it back again! No matter what I did, none of the volumes on the networked computer could be selected for backup. However, I could see them using the "Browse other backups" option. I noticed I was able to still select a network volume of an older Snow Leopard computer I had. I stumbled upon the AFP vs SMB issue when comparing the mounted volumes. By turning SMB sharing off I was able to get the volume to show up again.

    The frustrating thing was that none of my internet searches on Time Machine problems mentioned this SMB issue. Apple definitely screwed up on this one.
  11. ninja9 macrumors newbie

    Jul 17, 2012
    A potential fix

    So, I ran into this today after removing a network drive from time machine that I had set up prior to installing Mavericks. Lo and behold, when I went to go add it back, I couldn't... leading me here.

    Not wanted to spend $20 on OS X Server to do what I could do in 10.8, I think I found a way to get it to work—at least for me.

    On the server:
    - Make sure "Share files and folders using AFP" is checked
    - In my case, I don't have smb enabled, but I don't think it matters

    On the Mac you want to back up:
    - Don't connect using the Finder's sidebar. Instead, go to Go / Connect to Server
    - Specify that you want to connect using afp; e.g.


    - You'll then be prompted to pick a drive/share to connect
    - That drive/share should now appear in Time Machine; at least, it did for me!

    Hope this helps.
  12. bax2003, Dec 14, 2013
    Last edited: Dec 14, 2013

    bax2003 macrumors 6502a


    Dec 25, 2011
  13. satcomer, Dec 14, 2013
    Last edited: Nov 15, 2014

    satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
  14. JDnz macrumors newbie

    Nov 14, 2014
    Time Machine - Using across Mac to Windows platforms

    Background - I am an experienced Windows user opening up to the use of Mac since iPhones, iPads & Macbook Air's have tempted me to cross the bridge.

    On my 2011 Air using Mavericks Time Machine was unable to see Windows Network Drives to back up.

    Unmount the desired network drive
    Turn off file sharing - ie untick the file sharing box
    If the desired backup location has been previously used by Time Machine but has just stopped seeing it (as was my case) then also remove that drive from Time Machine

    Reboot Mac
    Open File Sharing and click Options. Tick AFP and SMB then exit Options. File Sharing will now be turned on, if it hasn't then click it on and check Options to see that the ticks in AFP and SMB have both stuck.
    Open Finder. Use Command+K or via Menu "Go" then "Connect to Server"
    Insert afp:// where the is the IP address of your desired NAS or Network drive eg: etc

    Open Time Machine
    Select Drive which now have a name including its IP address
    Back Up Now

    Upon doing the above my Mac functioned correctly once again for Time Machine Backups
  15. dcbill macrumors newbie

    Dec 30, 2014
    December 2014 update

    Choose Settings/System/Mac Backups/Time Machine Backups/Enable on MyBookLive.
  16. alex0002 macrumors 6502

    Jun 19, 2013
    New Zealand
    This seems like the most reasonable method. Use an CIFS (SMB) share with a sparse bundle and forget AFP.

    Then all your devices can use the same NAS with SMB enabled.
    No need to mess around enabling AFP and disabling SMB.
  17. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    I would be very careful about that. Time Machine requires AFP and is not reliable otherwise. I have read a lot of stories on here from users that tried that CIFS workaround then when they went to restore data it was corrupt. I would not trust my backup data to this.
  18. mccmaceng macrumors newbie

    Mar 2, 2015
    tmutil is the command you want to use. This will resolve your issue.

Share This Page