Time Machine "preparing" forever...

Discussion in 'Mac Pro' started by kirkbross, Feb 19, 2008.

  1. kirkbross macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #1
    Love my new mac pro... 8GB (w/ 6 OWC)...two Raptors and a 1TB Seagate for Time Machine... all working fine. Just installed 10.5.2 and other updates...

    One thing...

    Time Machine froze the system during it's first backup of about 62 GB of data, forcing a hard power off.

    Now, Time Machine "prepares" forever but never seems to copy anything... is that because there is nothing to back up?
     
  2. darkpaw macrumors 6502

    darkpaw

    Joined:
    Sep 13, 2007
    Location:
    London, England
    #2
    Check out MacFixit (http://www.macfixit.com) - they have some stories about that now, and some possible fixes.

    I had an issue with Time Machine, not the same as yours, and not really mentioned on MacFixIt. My Console.app was showing a failure to contact the backup server. I stopped Time Machine, repaired permissions, deleted the Spotlight index and let Spotlight re-index the drive, rebooted the Mac and enabled Time Machine. It works now.

    Hope you get yours fixed!
     
  3. kirkbross thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #3
    Thanks, I ended up just re-partioning my Time Machine drive and re-backing up and it's all good now.
     
  4. johnthegreen macrumors newbie

    Joined:
    Feb 10, 2008
    #4
    Would you be able to provide a newbie with directions how to do what you did? I have the same problem, but am very new to the mac world. John
     
  5. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #5
    I would be wary, I had this same problem and less than a month later my external hard drive went kaput.
     
  6. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #6
    All is well ;^)

    Hi -

    Just wanted to confirm your approach to the problem was the one that fixed
    my problem - thank you! I had an abnormal shutdown the other day (not
    sure what really happened, but it froze just before shutting off the power),
    and I think that messed up the Time Machine and/or Spotlight indices. After
    rebooting, I could never get Time Machine to finish preparing - many hours,
    and then I gave up. A little chat with AppleCare reminded me I should have
    let it run to completion, regardless of how long it takes . . .

    After deleting the Spotlight index, it took about 14 hours to re-index a
    half-full 750GB Seagate drive. Then, running Time Machine also took a
    long time (45 min) to finish "preparing" - but after that, the backup went
    to completion with no problems.

    The other reminder I got from AppleCare was that I should boot the
    Leopard install DVD, and run Disk Utility from it. For whatever reason,
    doing this found many "bad" permissions on the Time Machine backups disk
    which were not seen when running it from the internal HD. Once these
    were fixed, I'm now able to eject this disk (and others) without any
    problems.

    Now, if I can only get my fan to be more quiet . . . :)
     
  7. st01tz macrumors newbie

    Joined:
    Jan 7, 2009
    #7
    I tried just about everything to get the preparing issue to stop. In the end I backed up the files I needed and did an erase and install. Started fresh and that did the trick.
     
  8. Khryz macrumors 6502a

    Joined:
    Jan 7, 2007
    #8
    EDIT: Nevermind, it started working about 32 seconds after I posted this.
     
  9. summitscout macrumors newbie

    Joined:
    Mar 11, 2009
    #9
    A (somewhat) common problem with Time Machine is that the backup disk image will become corrupt. I believe this was the issue for the thread starter.

    Should you encounter the endless preparing problem as cited by TS, first try repairing the disk image with Disk Utility.

    For directions, see:
    http://support.apple.com/kb/HT3275
     
  10. Dataguy macrumors newbie

    Joined:
    Apr 28, 2009
    #10
    Time Machine Fix for External Drives Stuck in Preparing

    To watch the system open Console and search for "backupd" in the log All Messages

    1. Right Click on the Time Machine disk to which the OS is attempting to back up to. Eject.
    2. It will say that is isn't possible because it is in use. Wait 2-3 minutes and the backup should stop preparing.
    3. Attempt the eject again. This should do it.
    4. If it ejects, then Opened Disk Utility and Mount the External HD.
    5. Tell Time Machine to backup up now(if it hasn't started automatically by now)

    This has worked for me everytime....
     
  11. timsutcliffe macrumors 6502

    Joined:
    Jun 18, 2007
    #11
    Just wait

    Hello all,

    I've been having the problem with Time Machine spending an age preparing. I picked up some advice from one forum saying just to let it carry on preparing and eventually it'll work, which it did.

    So wait for about 20 minutes, and it'll work eventually.

    Tim.
     
  12. cheesepuff29 macrumors newbie

    Joined:
    Aug 13, 2010
    #12
    Time Machine stuck on preparing back up

    I waited and its now been two days of "preparing to back up". The log shows this:

    Aug 13 21:08:53: --- last message repeated 1 time ---
    Aug 13 21:08:53 Macintosh kernel[0]: HFS resolvelink: can't find dir_253501
    Aug 13 21:09:08 Macintosh kernel[0]: disk1s2: operation was aborted.
    Aug 13 21:09:08 Macintosh kernel[0]:

    I'm currently trying to repair the disc to see if that works...anyone have any other suggestions?
     
  13. cheesepuff29 macrumors newbie

    Joined:
    Aug 13, 2010
    #13
    I'm trying to now verify my disk and repair it and its saying that "the volume time machine backups needs to be repaired. Error: file system verify or repair failed." It also says "invalid node structure."...any ideas of how to fix this?
     

Share This Page