Time Machine recovery corrupted

Discussion in 'macOS High Sierra (10.13)' started by stringzz, Apr 2, 2018.

  1. stringzz macrumors member

    stringzz

    Joined:
    Jan 4, 2008
    #1
    I had a mac Pro 2008 with El Capitan that I backed up to a external HD with Time Machine.

    I traded my Mac Pro for a Mac Mini 2014 which had High Sierra installed. I hooked up my external drive and used migration assistant to transfer my files and apps. The whole thing took a really long time, like overnight, so the next day when I go to see the progress, I see it froze on the restart. So I turned off the mac mini and turned it back on. The restore had created all the users I had on there previously but no files or apps. When I tried to use the migration assistant again, the time machine backup was not recognized.

    It looks like it got corrupted somehow. I unplugged the external drive, and re-formated and installed El Capitan thinking that might be the issue. Still no luck.

    Any ideas on how to fix a corrupted drive with time machine on it?
     
  2. liya1201 macrumors regular

    Joined:
    Sep 8, 2010
    #2
    If I were you, I will try to use DiskWarrior to rebuild the time machine drive. Good luck!!
     
  3. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    Folks, this is why I don't recommend TM for backups, and NEVER will.

    Use CarbonCopyCloner or SuperDuper instead -- for a backup that's bootable, and mountable "in the finder" with everything there -- just as if it were the original drive itself!
     
  4. Papanate macrumors 6502

    Papanate

    Joined:
    Jul 21, 2011
    Location:
    North Carolina
    #4
    Do you have another Mac? If so plug in the HardDrive and see if it's really corrupted.

    If not corrupted reset Setup Assistant - which is different than Migration Assistant
    in that you can choose a specific restore point rather than the last back up. I would also
    go to High Sierra before doing this.

    • Launch Terminal
    • copy: sudo rm /var/db/.AppleSetupDone
    • Enter your password.
    • Restart your mac.
     
  5. Voenix Rising macrumors member

    Voenix Rising

    Joined:
    May 1, 2013
    #5
    I had the same issue with my external TM backup last summer. I ran disk utility to repair it (overnight) and it came back with unrepairable errors. I finally took this as a sign it was time to do a really clean install and reload everything from scratch. Luckily I was able to manually transfer all my files over from the TM without incident, but while I was doing it I kept thinking, "THIS is why I gave up on Windows!"

    I now use Carbon Copy Cloner on a new(er) external hard drive and haven't had any issues whatsoever.
     
  6. davidmartindale macrumors regular

    davidmartindale

    Joined:
    Jan 28, 2011
    Location:
    PNW, USA
    #6
    I would probably just manually bring stuff over from the backups.backupdb folder on your Time Machine drive if Migration Assistant keeps failing. You will likely have to reinstall your apps and recreate the users but at least you can get your data off of there.
     
  7. stringzz thread starter macrumors member

    stringzz

    Joined:
    Jan 4, 2008
    #7
    The disk warrior did the trick. Well at least it repaired the drive and I was able to use migration assistant. Some of the apps though were not available.

    I will look into Carbon Copy Cloner.

    Thanks
     

Share This Page