Time Machine searches failing

Discussion in 'macOS' started by iKenny, Oct 28, 2007.

  1. iKenny macrumors member

    Joined:
    Jan 31, 2004
    Location:
    Paris, France
    #1
    I've been having issues with Time Machine Spotlight searches. They seem to be flaky. Anything that was present on my hard drive at the time of the initial backup seems to be found just fine, but anything added later doesn't show up in every iteration. For instance, I downloaded some PDFs off the internet a few hours ago, and Time Machine has backed up twice since then, but they don't show up in either of those backups in Time Machine, although they do show up in a normal Spotlight search. I don't have the drive in Privacy in the Spotlight prefs.

    Also, on a somewhat related note, does anyone have the ability to search in Mail? Any time I enter Time Machine from Mail, the search box goes gray.
     
  2. deiacovo macrumors newbie

    Joined:
    Oct 27, 2007
    #2
    Same problem here

    I've exactly the same problem! Spotlight doesn't index time machine backups...

    Please help!

    Thank you,
    M.
     
  3. iKenny thread starter macrumors member

    Joined:
    Jan 31, 2004
    Location:
    Paris, France
    #3
    So I was using my computer today and Spotlight suddenly started indexing my Time Machine drive, of its own accord. Now Finder searches seem to be working within Time Machine. I'd just wait a few days and see if it decides to index the drive. DO NOT attempt to reindex it yourself (using Spotless or Terminal or something). I tried that and it created a real Spotlight index that was searched along with my main HD, so I just erased the drive and started over. It looks like a TIme Machine spotlight index is special and doesn't normally get searched.

    I still don't have search functionality in Time Machine with Mail though. Does anyone???
     

Share This Page