time machine slow initial backup - fix

Discussion in 'macOS' started by renault4, Oct 31, 2007.

  1. renault4 macrumors regular

    Jul 5, 2007
    My initial experiences with time machine were not great, glacially slow initial backup rate, left external HDD in unstable state that could not be repaired, stuck on "preparing" etc. The initial backup rate was minutes per Mb--unacceptable.

    here are some steps I took, based on watching this and apple support discussion groups--this may not work for all problems being experienced.

    turn off time machine

    Although TM doesnt require exclusive use of an external drive and will use HDs that have other data, you are placing those data at risk:

    before you turn on TM backup anything you have on your intended time machine external disk, partition ( as GUID) first, then erase (format as HFS extended, journaled) and check/repair permissions. (dont let time machine format the disk)

    exclude the external disk from spotlight indexing (or turn off spotlight altogether); certainly do not commence initial backup while spotlight is performing initial index after leopard install

    turn off any virus checking!!

    remove TM plist file from any previous attempts and erase and trash any previous backup files

    exclude any large frequently updated database files (Entourage, Parallels) from time machine.

    If you have multiple drives that you dont intend including in your routine backup, make sure you exclude them in TM

    avoid daisy chained FW drives for the initial backup, time machine disk should be directly connected.

    that's about it, Time Machine backed up a ~90G system from a 2.4Ghz SR MBP to a LaCie 500G d2 (FW800) in about 120 minutes and has continued with hourly backups since.

    good luck!
  2. Bagelsurf macrumors newbie

    Nov 1, 2007
    Virus checking was key!!

    Shutting off virus checking was the key to speeding it up. It was crawling at glacier pace like you said. Turning off virus checking had the progress bar moving 10x faster at least. On my way...
  3. fatstuff macrumors newbie

    Jan 30, 2008
    Disabling Norton Anti Virus

    I have a brand new Magdor External Hard Drive and initially was ready to return it since the firewire was running so slow. Reading the thread on this site got me to disable my Norton anti virus. Bottom Line: i restarted this morning and it has almost backed up the entire 60 gigs in a couple of hours. Thanks to all for the great help. These sites are far more valuable than any Apple Support Program. I hate to say that aside from waiting hours on the phone to get to a level one support that knows less than me. The techs have become arrogant and snotty to boot. Thanks againhttp://images.macrumors.com/vb/images/smilies/smile.gif
  4. danny_w macrumors 601

    Mar 8, 2005
    Austin, TX
    I only just received a new iMac at work and started TM yesterday afternoon on an empty partition of an external USB drive (MyBook 500GB). I know I don't have much on this machine yet (about 28GB) but all the talk about slow initial backups had me worried. Anyway it finished in under 1.5 hours, and there was even a ccc clone going to the other partition on the same external hdd at the time! So far that doesn't sound so slow to me. Since then I have looked and it shows all of my backups every hour since then.
  5. aircraft macrumors newbie

    Feb 16, 2008
    100 Times Faster Now - Stop Norton In Activity Monitor

    After 2 hours 30 minutes, Time Machine had copied 1.26GB of 89.27 to my Seagate external hardrive. So, I did a little research, and found this forum. On the advice of a previous poster, I opened Activity Monitor to see which processes were running in the background. Sure enough, Norton has some Auto Protect thing going on. I Force Quit that one process (Norton Auto Prote) and in the 7 minutes since, I have gone from 1.26GB to 7.34GB now copied. Without exaggeration, I think this course of action sped the process up by a factor of 100.

    Doing the math, I had 1.26GB copied after 150 minutes. During the 7 minutes following the fix, an additional 6.08GB were copied. I went from one half GB per hour to almost one GB per minute. UNBELIEVABLE.
  6. msteele999 macrumors newbie

    Jun 25, 2006
    Same resolution - Virus Scan

    I too just purchased a new drive WD320GB disk and was shocked at the performance. I just disabled background scanning for Intego VirusBarrier X4 and the backups are now progressing as they should.

    I appreciate this forum as well.

  7. vincebio macrumors 6502a


    Jun 27, 2005
    maybe im going mad here....


    im assuming you had all these pointless anti virus software apps for your Windows installs?
    I thought that the Windows partitions were completely seperate and you would not be able to see Norton etc running on OS X?

    Please tell me you people havnt installed Anti virus for OS X :confused:
  8. AndyK macrumors 65816


    Jan 10, 2008
    Why, why, why in the name of all things holy are you running NORTON ON A MAC?!

    If you insist running an AV on a mac (personally I don't, firewall is all that's needed, macs are no where near as vulnerable as a pc is - common sense is the best form of AV you can get for a mac) at least run something not quite to domineeringly anal with its self.

    It's like dual booting Windows onto a mac and using it all the time :(
  9. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    I decided to start using TM today, and was on the point of tearing my hair out with frustration.

    Just couldn't get the inital backup to complete. Time Machine froze, crashed, froze my OS, halted, refused to stop, different things at different times.

    Finally I saw the advice on here:

    - turn off TM

    - exclude the external from Spotlight.

    - clear any data off the external HD, including old TM aborted backups (had to use a spare iBook with 10.4.11 for this, see below)

    - reformat in GUID (I had to use a ibook with Tiger for this as disk utilities on my macbook refused to deal with the external - kept giving me error "Disk cannot be unmounted" or "Disk will not unmount")

    - partition into two GUID partitions, then repartition into a single GUID. Both times, with Apple Extended (Journaled).

    - run disk verify / repair on the external and the internal (from the Leopard macbook - after a restart, Disk Utility now worked fine)

    - let Time Machine run.

    - if it hangs again, start Console, (in Utilities folder) and click on show all, then search / filter for 'backupd'. Make a note of any 'error -36' messages and exclude the folders they occur in from Time Machine. (on mine, it was the Warcraft III folder)

    - Let it run again. See above if it stops again.

    Finally, Time Machine completed! Am excited to finally have this outstanding if slightly buggy application working.

    These last few bugs must be why Apple is releasing its own TM drive, Time Capsule.
  10. danny_w macrumors 601

    Mar 8, 2005
    Austin, TX
    Admittedly I haven't used TM much, and only on one computer (my iMac at work). I haven't seen any of the issues that others have talked about - it just ran for me. I guess I am just lucky so far. I haven't yet attempted TM at home, and I may run into these issues when I do. When I do I will remember this thread!
  11. RedRoy macrumors newbie

    Mar 1, 2008
    turning off Sophos Anti-virus did it for me

    Glad I found this thread.
    TM extremely slow until I turned Sophos Anti-virus off.
  12. tampaappleman macrumors newbie

    Jan 9, 2008
    Initial Time Machine Backup to Time Capsule

    Reading thru this thread I would like to add, that even if you are using Time Capsule for your initial Time Machine backup - make sure that your virus scanner is turned off. In my case it's Intego's Virus Barrier which was scanning in the background and holding up the entire backup process to TC vehemently. Once background scanning was turned off, the entire process went from snail to train speed. Improvement factor must be 100 x.
    Great forum - love it.:)
  13. richard.mac macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    antivirus scanners cause more trouble than they are trying to prevent in OS X. my recommendation is uninstall them as they have no use. if you dont believe me search up on the many anti virus discussions in this forum.
  14. James9000 macrumors newbie

    Oct 24, 2007

    My timemachine drive is an internal one in my Mac Pro.

    Adding this drive to Spotlight's Privacy list seemed to make the initial backup run much faster.

    I have no anti-virus software installed at all and it was glazier slow before I tweaked spotlight.
  15. RexCat macrumors newbie

    May 10, 2008
    Turning off Norton's

    I have found I don't have to turn Norton's off for Time Machine. I am using V11.0.

    Open "Norton Antivirus", Goto "Automatic Protection", Select "Auto-Protect" Configure..., Select tab "Auto File Scan", Select Button "Don't Scan", Add 'the name of your Time Capsule from the SHARED column on the popup finder menu' and the file "Backups.backupdb" (might be different on your machine) from the DEVICE column on the finder popup menu.

    To speed up other file transfers you would likely have to do the same routine to tell Norton to ignore the other directories on Time Machine.

    FYI, Stopping Spotlight on Time Capsule also added a speedup for me. :)
  16. RexCat macrumors newbie

    May 10, 2008
    Turning off Norton's - Addendum

    To add 'the name of your Time Capsule from the SHARED column on the popup finder menu' and the file "Backups.backupdb" (might be different on your machine) from the DEVICE column on the finder popup menu - TIME MACHINE MUST BE RUNNING a backup to see this file.

    FYI, Stopping Spotlight INDEXING on Time Capsule also added a speedup for me.
  17. shawnuff macrumors newbie

    Jun 20, 2008
    Disconnect USB hub

    My initial Time Machine back up was painfully slow. After letting it run about 12 hours only 58GB of 128GB were backed up from my iMac!

    The problem was the USB 2.0 hub to which the LaCie 750GB HD was connected. I stopped the backup up, unmounted the drive, connected it directly to the iMac, and began the Time Machine backup again. I didn't erase the disk and start over, just started the TM backup.

    In 10 minutes about 17GB have been backed up. I had stopped and restarted the backup before and 17GB would have taken about 45 - 60 minutes before!
  18. Orthogonal macrumors newbie

    Jan 7, 2008
    San Francisco
    Timemachine backup hanging

    I recently purchased a 1TB Time Capsule to use as my external drive using Timemachine. After 6 attempts I managed to get an initial backup done (took about 12 hours to move about 65GB of data).

    Since then Ive been encountering problems with the hourly backups - the process launches, seems to backup successfully but then stalls indefinitely in a "finishing backup" mode (as displayed on the timemachine preferences window). I'm not sure how to interpret that..

    I have diasabled Noton AV as previous posters have advised and excluded my external drive from spotlight.

  19. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    See my post above re 'error -36'

    Certain files seem to cause TM to hang.

    Ah, I'll just quote myself below, save you the hassle of searching:

    (as previously posted)

    - if it hangs again, start Console, (in Utilities folder) and click on show all, then search / filter for 'backupd'. Make a note of any 'error -36' messages and exclude the folders they occur in from Time Machine. (on mine, it was the Warcraft III folder)

    - Let it run again. See above if it stops again.
  20. Orthogonal macrumors newbie

    Jan 7, 2008
    San Francisco
    Thanks - forgive any naivete on my part - I'm new to Mac and TC/TM

    I perused console messages as you suggested and don't see any error-36 messages.

    It appears that all of the files on my hard drive are being backed up successfully but for some reason the backup process is not terminating itself - I have to force quit the process manually.

    Any other ideas or is this a "feature" I'm supposed to live with?
  21. everfangomanga macrumors member

    Jul 12, 2008
    Osaka, Japan
    Simple fix that worked for me

    Under the Apple Menu, go to System Preferences, then in the Systems area click Accounts, select the appropriate account, click the Login Items tab and deselect all items that will "open automatically when you log in."

    That did the trick for me. I was going at about 10MB a minute (Sweet Moses...) before this, and after this I was seeing almost exactly a gig a minute. Talk about a time saver.
  22. shakenmartini macrumors 6502

    Apr 29, 2008
    Also time machine will hang if you have badly behaving non-N netowrk device connecting to to TC.

    It seems best to dedicate the TC to wireless-n devices only during the initial backup and only add devices back that behave OK.

    My wife's work Cisco Aironet card literally brings the WPA network to its knees. However, without WPA there is no problem, but this is risky with your whole backup going over wireless hourly.
  23. splott macrumors newbie

    May 7, 2006
    Found this thread while experiencing snail-pace first backup to a 1TB Time Capsule. So far it's been running about 11 hours and has only managed 46GB (of 260GB). I didn't see the bit in the manual about running the first backup via ethernet, so it's running wirelessly. The transfer speed started out jumping around anywhere between 1KB/s and 1.5MB/s.

    This morning I checked Console and found Little Snitch to be the culprit. It was continually causing exits (code 255) and throttling respawn (whatever that means), so I throttled it. I also put the Firewire 800 external HDD the backup is currently reading from onto Spotlight's privacy list.

    However neither of those moves seem to have made much difference to the transfer speeds. Any suggestions?
  24. cwolynez macrumors newbie

    Aug 30, 2008

    Thanks for the antivirus tip. I also disabled Sophos and the backup is now running at normal speed (don't blast me for using AV, I'm running a mail server.)
  25. bobr1952 macrumors 68020


    Jan 21, 2008
    Melbourne, FL
    Something interesting concerning my Time Capsule and Spotlight. I really didn't realize Spotlight even indexed my Time Capsule. Regardless, the other day it was taking forever to do a routine hourly backup--it finally finished after an hour but the Time Capsule did not dismount. I finally looked in the log and saw that Spotlight was reindexing the Time Capsule drive--and 5 hours later it finished--and dismounted. The thing I am wondering is that it seemed that Time Machine was looking for the index and was not happy that it couldn't find it--perhaps it got corrupted? Once the drive was reindexed, all is working fine again.

Share This Page